Connected but Not working

rcwynn's Avatar


11 May, 2022 11:51 AM

I get errors when trying to setup online banking. Tried 2 different banks, and get the same error. Tried one of the banks twice and got the same error. Now I have 3 connected that all say no name on the account. I can't even delete them. The error pops up twice for each account entry. So now I am getting the error 6 times every time I try to refresh.

  1. Support Staff 1 Posted by Maddy on 11 May, 2022 12:02 PM

    Maddy's Avatar


    We are sorry to hear about the problem you have encountered.

    Generally, when you are returned Error code: INVALID_ACCESS_TOKEN, it means that Moneydance + is trying to refresh but Plaid is saying there is a problem. You should navigate to the Online>Setup Moneydance + menu again and look in the connections list.
    When you see "no name" listed, you should disconnect it.
    Finally, you should restart Moneydance.

    If this still doesn't seem to help, we recommend upgrading to Moneydance 2022.4 (4078). This is now available to download from this page.

    After running the update, navigate to Extensions->Manage Extensions and install the Toolbox.
    Launch Toolbox and navigate to Toolbox Options (on top left corner) and select -
    Update Mode->Yes->Do Back Up Now (recommended). Then, navigate to Menu: Online Banking (OFX) Tools (2nd tab down).
    In the resulting window, under Update Functions you should select :
    Delete OFX Banking Service / Logon profile (

    Finally, restart Moneydance and recreate the connection as outlined here.

    I hope this information is helpful. Please let us know if you have further questions or need more assistance.

    Maddy, Infinite Kind Support

  2. 2 Posted by rcwynn on 12 May, 2022 10:53 AM

    rcwynn's Avatar

    Trying to disconnect was throwing the 'Unable to remove the connection' error. I closed the program an re-opened it and that seemed to have solved the issue.

  3. Support Staff 3 Posted by Maddy on 12 May, 2022 11:01 AM

    Maddy's Avatar

    Excellent news!

    I'm glad the issue seems to be solved now.

    I'll close this discussion for now, but do not hesitate to contact us again, if you need further assistance.

    Maddy, Infinite Kind Support

  4. Maddy closed this discussion on 12 May, 2022 11:01 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac