Moneydance+ and Fidelity Netbenefits

solerve's Avatar


19 Jun, 2022 07:49 AM

Hi there,

I signed up for Moneydance+ a while ago but when I go to download transactions from Fidelity Netbenefits it asks me to map the securities to the ones in Moneydance. The only problem is the ones that would be the right ones don't appear in the list, leaving only the option to choose 'none of the above.'

I tried to deal with the problem the way this thread suggests:
But it breaks everything. The totals of the securities are all wrong in the end.

Thank you for any insight into this,

  1. 1 Posted by Stuart Beesley ... on 19 Jun, 2022 10:20 AM

    Stuart Beesley (Mr Toolbox)'s Avatar

    Step 1. Instal/run toolbox extension. Security tools. There is an option to view CUSIP settings. What does this say?

    What happens after you say none of the above? Did it create a new security?

  2. 2 Posted by robert.l.spauld... on 19 Jun, 2022 03:31 PM

    robert.l.spaulding's Avatar

    If your holdings are in a workplace account more than likely there is no Ticker or CUSIP associated with them. I've had that problem for years. The only option I had was to manually input the holding without a ticker symbol and a made up CUSIP, and then manually input the price for the holding. I was hoping that Moneydance+ would have resolved this, but it did not. I was unable to get ahold of anyone at Plaid to discuss, and just kind of gave up.

  3. 3 Posted by solerve on 19 Jun, 2022 05:43 PM

    solerve's Avatar

    Tried to use toolbox, but got a warning that the developer sent a "stop now" command.
    choosing 'none of the above' did create a new security.

    I was able to download the transactions prior to Moneydance+ without problems. Wish I could go back to that system without losing the ability to use Moneydance+ for the credit cards. It works well for them.

  4. 4 Posted by Stuart Beesley ... on 19 Jun, 2022 05:47 PM

    Stuart Beesley (Mr Toolbox)'s Avatar

    You need to update toolbox. Extensions. Manage extensions. Upgrade.

  5. 5 Posted by solerve on 19 Jun, 2022 06:04 PM

    solerve's Avatar

    Updated toolbox and then it worked. Ran the view hidden CUSIP settings tool and a bunch of the securities came back with the following note:


  6. 6 Posted by solerve on 19 Jun, 2022 06:06 PM

    solerve's Avatar

    I should add that most of the broken securities also have a duplicate that is not broken.

  7. 7 Posted by Stuart Beesley ... on 19 Jun, 2022 06:18 PM

    Stuart Beesley (Mr Toolbox)'s Avatar

    Once you accept the ‘none of the above’, does it then keep this setting and never ask you again? Does it basically work from that point onwards? If so, what is the actual issue you are left with?

  8. 8 Posted by dtd on 19 Jun, 2022 06:22 PM

    dtd's Avatar


    just a user - sounds like you are moving toward a solution, but I want to address one of your "wishes" - OFX and MD+ can be used concurrently for your datafile, as long as you pick one for each account (you can't do both with the same account)

    80-90% of my accounts use OFX, I only use MD+ for those accounts that won't work under OFX anymore (like Schwab)

  9. 9 Posted by solerve on 19 Jun, 2022 07:08 PM

    solerve's Avatar

    Ran the fix. Then relinked the account with Moneydance+. Downloaded, again got the choice to choose the security, but the right (the ones I needed to link) securities did not show up in the window, so went with 'none of the above.' It downloaded a ton of stuff and put its own names to it. The portfolio view now shows double the securities and of course, the values are all wrong. Will have to revert to back up and try something else.

  10. 10 Posted by solerve on 19 Jun, 2022 07:11 PM

    solerve's Avatar

    @dtd Turns out the only download choices I have are QIF and CSV. So I think I'm stuck trying to download with MD+

  11. 11 Posted by Stuart Beesley ... on 19 Jun, 2022 07:18 PM

    Stuart Beesley (Mr Toolbox)'s Avatar

    What I’m getting at is this. If you accept none of the above does this ‘stick’? Do new downloads go to this new security without prompting? Thus, can we just move the other/old txns out of the original security into the new security?

    Toolbox has a feature to merge duplicate securities and you can select to keep the new one that md created.

    If your using that security via downloads in other accounts then this solution might be ok?

  12. 12 Posted by solerve on 19 Jun, 2022 07:34 PM

    solerve's Avatar

    @Stuart Beesley

    Tried to run the merge "Duplicate' Securities tool, but it crashes.

    "Minor error - Merge 'Xuplicate' Securities (by 'Ticker'): Crashed before any merge actions. Please review output and console."

  13. 13 Posted by solerve on 19 Jun, 2022 07:35 PM

    solerve's Avatar

    Traceback (most recent call last):
      File "extension(toolbox)", line 17741, in merge_duplicate_securities
    IllegalArgumentException: java.lang.IllegalArgumentException: Cannot create PyString with non-byte value
      File "extension(toolbox)", line 25148, in actionPerformed
      File "extension(toolbox)", line 18443, in merge_duplicate_securities
      File "extension(toolbox)", line 653, in dump_sys_error_to_md_console_and_errorlog

  14. 14 Posted by Stuart Beesley ... on 19 Jun, 2022 07:42 PM

    Stuart Beesley (Mr Toolbox)'s Avatar

    Yuck! Do you have toolbox debug on? If so, can you turn it off and try again?

  15. 15 Posted by Stuart Beesley ... on 19 Jun, 2022 08:02 PM

    Stuart Beesley (Mr Toolbox)'s Avatar

    Also, I just fixed that error from appearing.... Latest preview here:

    But as I said, turning off debug should bypass the issue anyway. Let me know?

  16. 16 Posted by Stuart Beesley ... on 19 Jun, 2022 08:52 PM

    Stuart Beesley (Mr Toolbox)'s Avatar

    In fact I’ve realised you may not have debug on…. You will need to use the preview toolbox from link above. Download, unzip. Double click toolbox.mxt to install it.

  17. 17 Posted by solerve on 20 Jun, 2022 12:53 AM

    solerve's Avatar

    Hmmm, installed your upgraded extension. Ran it. Error code with instructions on how Tools>Securities>EDIT to change the security IDs but match all the other things that must match. Still getting error: Merge 'Duplicate' Securities (by 'ticker'): Not enough Securities / no valid duplicate Tickers found (refer report on screen for details) - NO CHANGES MADE

  18. 18 Posted by solerve on 20 Jun, 2022 12:55 AM

    solerve's Avatar

    ^31564P289:rate 23.1800931516:dpc 4::Shares:(27 price recs) ' NOTE: has 27 price history records
    ^31564P289:rate 23.1800931516:dpc 4::Shares:(27 price recs) ' CANNOT be MERGED as not the same decimal places

    Seems to have to do with decimal places, but I'm not sure where to edit that.

  19. 19 Posted by dtd on 20 Jun, 2022 01:16 AM

    dtd's Avatar

    Looks like progress is being made, Stuart is based in the UK, so probably will get back to you in his morning....

  20. 20 Posted by Stuart Beesley ... on 20 Jun, 2022 04:38 AM

    Stuart Beesley (Mr Toolbox)'s Avatar

    MD changed the dpc default to 5 - annoying..!
    OK, so Toolbox can edit that for you.... Same place, edit Security Decimal Places... Edit the new one from 5 down to 4 decimals (unless you really want to keep 5)... Then try again....

  21. 21 Posted by solerve on 20 Jun, 2022 06:40 PM

    solerve's Avatar

    All right, so that was a bit of a nightmare, but thanks to your help and your amazing toolbox, Stuart. I finally got it all worked out. Let's hope when the next investment period is over, the download will be flawless.

    Thanks again. V

  22. 22 Posted by Stuart Beesley ... on 20 Jun, 2022 06:52 PM

    Stuart Beesley (Mr Toolbox)'s Avatar

    Toolbox 🧰 +3 ⭐️ 😃

  23. solerve closed this discussion on 25 Jun, 2022 05:16 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac