USAA log on

Ron Siegfried's Avatar

Ron Siegfried

04 Jul, 2022 01:55 PM

I have not used my USAA signature plus credit card since they disallowed downloads to Moneydance. I recently had reason to initiate its use so decided to use Stuart Beesleys python script. I was successful in all aspects until it came time to log into my account. When MD says set up on line banking it prompts me for user name and password/pin. I have used the username and password that downloaded from Quicken to no avail. The response I always get is ID and password are incorrect, suggest you contact financial carrier. I have rebooted and all obvious options to no avail. The only thing I can think of is I think I changed my password for USAA access a few months ago. The password I received recently from Quicken was the same one I had received a year ago. Since I am so close thought I would reach out for a simple solution?

  1. 1 Posted by Stuart Beesley ... on 04 Jul, 2022 01:59 PM

    Stuart Beesley (Mr Toolbox)'s Avatar

    First thing to try is to Help/Console Window. KEEP CONSOLE OPEN.
    Now try to connect.
    Go back to console, copy the contents and post back here as an attached file.. Then we can see if it's connecting...

  2. 2 Posted by Ronald Siegfrie... on 04 Jul, 2022 02:07 PM

    Ronald Siegfried's Avatar

    Ron Siegfried
    H-610-866-4424
    C-610-703-0257

  3. 3 Posted by Ronald Siegfrie... on 04 Jul, 2022 02:08 PM

    Ronald Siegfried's Avatar

    Replied under separate cover the console window which did not allow my access. I assume I should only use the username and password that I received from Quicken? Why does it also ask for PIN?

  4. 4 Posted by Stuart Beesley ... on 04 Jul, 2022 02:26 PM

    Stuart Beesley (Mr Toolbox)'s Avatar

    Ok. It’s working and connecting to usaa.

    However, right at the end you are getting
    ‘Signon Invalid’

    So either the client uid or your username/password are wrong.

    Yes you use the same quicken credentials.

    Run toolbox. Online banking tools. Select the option near the bottom to run the ‘old’ script method to populate all usaa data in one go.

  5. 5 Posted by Ronald Siegfrie... on 04 Jul, 2022 02:54 PM

    Ronald Siegfried's Avatar

    All appears to be working correctly until it comes time to log on, then I receive the
    ‘signon invalid’. Frustrating but do not know what else to try? Will take one more look that all entries are correct?

  6. 6 Posted by dtd on 04 Jul, 2022 09:38 PM

    dtd's Avatar

    just a user - you keep saying "downloaded from Quicken", but I'm assuming you mean "downloaded Quicken id/password from USAA", correct?

    Also, after you get the quicken userid and password from USAA, do you go far enough (i.e. hit the "do it" buttons) to get an email from USAA saying you've approved access - given the time not using it, that access may have expired/been removed.

    When you get the client_uid from the URL, I'd recommend cutting/pasting it to a file, and then do the same when using the toolbox script.

    Also, did you delete potentially obsolete USAA OFX items (I think that's mentioned in the documentation (both in what I wrote, and what can be obtained from the knowledgebase.) - you may be using one that isn't valid.

    Just some thoughts on why the entries might not be correct/work.

  7. 7 Posted by dtd on 04 Jul, 2022 09:41 PM

    dtd's Avatar

    just a user - I see that Stuart has recommended you use the older script in which you type in all of the client_id and username/password in "one go". That renders some of my suggestions irrelevant, but some would still be worth checking .

  8. 8 Posted by Ronald Siegfrie... on 04 Jul, 2022 11:57 PM

    Ronald Siegfried's Avatar

    I printed out and followed your on line directions explicitly, in fact several times. As you mentioned I am just wondering if my userID and password that Quicken emailed me had expired? I have checked the client ID, user ID and password numerous times with no success. Even tried it with VPN on and off as I have found that affected some connections. If you think of anything more bizarre for me to try let me know. I will keep at it and let you know if I have any success? Thanks for all your efforts. Looks like I may not start using my USAA card after all? Ron Siegfried

  9. 9 Posted by dtd on 05 Jul, 2022 12:06 AM

    dtd's Avatar

    Ok, to go more bizarre, please forgive me asking "Is your computer plugged in" type questions.

    1) You still keep saying that Quicken is emailing you a userID and password. This is not correct. You login to USAA and go to a specific part of USAA and grab the information from there. NOT QUICKEN.

    2) What documentation are you using to walk you through this? Mine (Version 9a)? The kb article that was published by MD/IK? Knowing what you are using to gather this info would help me know what you are doing specifically.

    3) Did you get an email from USAA stating that you have authorized 3rd party (yes Quicken) access to your accounts?

    4) When you grab the client_id from the URL at USAA, could you possibly be grabbing the session_id instead?

    The entire issue here is you need 3 pieces of info... and two of them have to have been approved. This is all about being told you have your login incorrect - and that points specifically to those 3 pieces of info.

    Hope that helps.

  10. 10 Posted by Ronald Siegfrie... on 05 Jul, 2022 11:50 AM

    Ronald Siegfried's Avatar

    I have logged into USAA and received the access ID data, copied and pasted it on a separate sheet of paper ( the client ID is on the first line and the session ID on the last line) Then I select the authorize for Quicken to send me the credentials which I then receive via email. I have copied and pasted them on the same piece of paper with the client ID. I am approximately 99% sure I have the correct data??? The only unusual item is I normally use the Safari browser on my MAC. When I log in to USAA with Safari and then try to access the accessid it does not display the two options at the bottom (authorize or deny Quicken) I have to use my Chrome browser to access those two options and then for several attempts pressing the Authorize button did not work. After all my struggles with this I do not believe I am doing anything incorrectly but I do believe there is some small bug that is preventing me from connecting. I thought maybe too many failed attempts locked me out but I have tried on separate days, was it my VPN connection, was it my Safari browser (what browser does MD use to connect to USAA? Can I change it?) Connecting again to USAA is not a priority to me it is simply I get obsessed with conquering a conundrum. If and when I break the code I will let you know and what was the problem. Again, thanks for all your recommendations, and yes my computer is plugged in???

  11. 11 Posted by Stuart Beesley ... on 05 Jul, 2022 12:07 PM

    Stuart Beesley (Mr Toolbox)'s Avatar

    We know a few things:
    1/ my patch/script works. We have over 100 known people using it.
    2/ your computer is talking properly to usaa. So all that’s left is your authentication.

    MD does not use a browser. It makes internal http network connections

    Run toolbox extension and then online banking tools then the option to view installed service profiles. Validate that your client is, user, password are all stored and shown on screen correctly in all places?

    So…
    - are you sure you’re using the client ID captured from the web url once you have clicked on get details for quicken? - have you rang usaa to confirm that you are not locked out ‘for quicken access’?

  12. 12 Posted by dtd on 05 Jul, 2022 05:35 PM

    dtd's Avatar

    What concerns me is your continued use of nomenclature which is simply incorrect. That makes me worry that you are getting something wrong.

    Your answers to my items are odd, so let me try again, saying what is bothering me.

    1) You still keep saying that Quicken is emailing you a userID and password. This is not correct. You login to USAA and go to a specific part of USAA and grab the information from there. NOT QUICKEN.

    Current response: Then I select the authorize for Quicken to send me the credentials which I then receive via email.

    [Quicken does not send you anything. USAA is supposed to send you an email saying your account is authorized, and a button to go see that you are authorized. The title says: Quicken Now Connected to USAA Account - but this is from USAA not Quicken. Also, this email does NOT contain any credentials (ie userid/password).]

    2) What documentation are you using to walk you through this? Mine (Version 9a)? The kb article that was published by MD/IK? Knowing what you are using to gather this info would help me know what you are doing specifically.

    Current response: Your message implies you know what you are doing, but you still don't say what you are relying upon (i.e. documentation) to tell you what to do and when to do it.

    3) Did you get an email from USAA stating that you have authorized 3rd party (yes Quicken) access to your accounts?

    Current response: You continue to say that Quicken sends you an email with credentials.

    4) When you grab the client_id from the URL at USAA, could you possibly be grabbing the session_id instead?

    Current Response: the client ID is on the first line and the session ID on the last line

    [You don't need the session id at all; this is stated in the documentation, which is why I wonder what you are using. So, since you are grabbing both (you only need client id), is it possible you are accidentally using the session id?]

    It sounds like you are gathering the correct data, but these responses make me wonder.

    As for being allowed Quicken access, you should be able to click the button in the email FROM USAA that says "View USAA Profile", which takes you to "Security Preferences" and you should see under Connected Apps - "Quicken" and under Permissions "Bank Account Information and Details" at minimum (you may have more Permissions).

  13. 13 Posted by Ronald Siegfrie... on 05 Jul, 2022 08:44 PM

    Ronald Siegfried's Avatar

    Have been out all day so just returning to this dilemma. I obviously have not been using the correct nomenclature but be assured my actions have been in alignment with your directions. Yes, I have received the client ID from USAA and then clicked the Allow button which then send me an access ID and access pin. I have verified and entered that data several times to no avail. I just recently got off a call from USAA to verify I was not locked out of Quicken as you recommended checking. USAA could find nothing of the sort but then I am not sure I was talking with the right person. Here is another wrench in the works. About a month ago I signed up for Moneydance plus. I was hooked into all my accounts including downloading from USAA. I had problems with the service and ended it within a few weeks. Now however when I go to MD and try to disconnect from these services it says unable to disconnect. I assume that what I had signed up for and paid for has not run out. Maybe when I can disconnect for MD+ I will be able to reconnect with IK?

  14. 14 Posted by dtd on 05 Jul, 2022 08:51 PM

    dtd's Avatar

    Did you follow this instruction to determine if you were approved for access?

    As for being allowed Quicken access, you should be able to click the button in the email FROM USAA that says "View USAA Profile", which takes you to "Security Preferences" and you should see under Connected Apps - "Quicken" and under Permissions "Bank Account Information and Details" at minimum (you may have more Permissions).

  15. 15 Posted by Stuart Beesley ... on 05 Jul, 2022 08:51 PM

    Stuart Beesley (Mr Toolbox)'s Avatar

    If you have tried to disconnect, then refresh, then restart and the md+ doesn’t go away, then use toolbox. Advanced mode. Online banking tools. Option ‘ Force MD+ name cache & access tokens rebuild’ then wait. Then restart. What happens?

    Also did you try my toolbox option to verify what data about usaa has been stored? Option: ‘ View your installed Service / Bank logon profiles’

  16. 16 Posted by dtd on 05 Jul, 2022 08:53 PM

    dtd's Avatar

    If in alignment with directions, why did you record the session_id, as you don't need it and the instructions tell you to ignore it?

    That still makes me wonder if you are using all the correct information.

    And you are right, having MD+ with USAA IS another wrench in the works, and should have been mentioned.

  17. 17 Posted by Ronald Siegfrie... on 05 Jul, 2022 09:14 PM

    Ronald Siegfried's Avatar

    I simply copied the URL when I went to the accessid site. I was certain I had entered the correct data and just knew there was some detail I was overlooking. Hopefully it was the MD plus but my computer does some quirky things occasionally too. Thanks for all your help. Will let you know if and when I solve the problem.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac