Attempt to download transactions trashed an account

tetrault's Avatar


14 Aug, 2022 12:18 AM

My bank stated that an error occurred when I tried to download recent transactions. What an error! 36 invisible transactions. A new balance of about $-10,000,000. My register lost 11 years of transactions from before 6/15/22. Transactions since then are screwed up. Is there any way to fix this other than switching to a backup? Doing that will require me to manually enter dozens of transactions.

  1. Support Staff 1 Posted by Maddy on 15 Aug, 2022 01:30 PM

    Maddy's Avatar


    We are sorry to hear about the problem you have encountered.

    Which version and build of Moneydance are you using?
    To check, open Moneydance and select Moneydance --> About Moneydance

    When you download your data from the bank, do you use Direct Connect automatic downloads, Moneydance + or do you download files from the banks website?
    If you download from the banks site, which file format do you use?

    In addition, you could check the following:

    The filter at the top of the register should be set to "All".

    There is a button that toggles between "split" and "combined mode" at the top-right corner of the register, next to New Transaction.

    If this is in split mode, then all unconfirmed transactions will be shown in a second register which appears below the regular register.

    This can sometimes be collapsed, so that all it shows is a bar with a label that says "N unconfirmed transactions". If you see that bar, drag it up vertically and you'll see the unconfirmed transactions in that list.

    I hope this information is helpful. Please let us know if you have further questions or need more assistance.

    Maddy, Infinite Kind Support

  2. 2 Posted by tetrault on 15 Aug, 2022 08:02 PM

    tetrault's Avatar

    Moneydance 2020.2 (1929)
    I downloaded from the bank. I don't normally do that, but I was on the web site and only had to click a button.File format QFXALL is selectedNot in split mode.
    I solved the lost and incorrect data problem in a strange way. I went through the process of loading a backup archive before I tried it for real. The backup archive did not load. I switched back to my original file. When it opened, the Banking register was complete, and all errors were gone. How's that for a strange miracle?
    Gregory Tetrault

  3. Support Staff 3 Posted by Maddy on 16 Aug, 2022 09:31 AM

    Maddy's Avatar

    If you think that the problem is resolved, I'd close this discussion for now.
    Please do not hesitate to contact us again, if you need further assistance.

    Maddy, Infinite Kind Support

  4. Maddy closed this discussion on 16 Aug, 2022 09:31 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac