Moneydance+ not syncing

Bob's Avatar

Bob

05 Jan, 2023 05:24 PM

After using Moneydance+ successfully for several months, Chase and Fidelity and Elan will no longer download. All three entities blame Moneydance+. Other institutions continue to work. How do I fix this?

  1. 1 Posted by cytoc on 05 Jan, 2023 11:58 PM

    cytoc's Avatar

    I am having the same issue.

  2. 2 Posted by dtd on 06 Jan, 2023 03:19 AM

    dtd's Avatar

    just a user

    When you say "no longer download" - do you mean literally (and if so, what error message do you get), or do you mean you are not getting new transactions?

    btw - Chase is working for me, I don't have Fidelity or Elan.

  3. 3 Posted by Robert Rugur on 06 Jan, 2023 03:43 AM

    Robert Rugur's Avatar

    I am getting the following message:

    The account you've connected is being scanned and will be ready for download shortly. Please retry your download a bit later, or contact Moneydance support if it has been more than a few hours.

    Account:Fidelity Credit Card
    Account Number:XXXXXXXXXXXXX
    Additional information from the server:
    Error type: ITEM_ERROR
    Error code: PRODUCT_NOT_READY
    Item ID: z8grdBdKOotPw8kgAZdJHkPAmdYZkPUARq4N4
    Request ID: 51ImGHfXFMyyaNC
    Message: the requested product is not yet ready. please provide a webhook or try the request again later

    I have been getting this message for several days now.

    ________________________________

  4. 4 Posted by dtd on 06 Jan, 2023 10:03 PM

    dtd's Avatar

    Do you get this only for Fidelity or for all three banks. If it has been a few days, I suspect either you haven't granted third party access to plaid, or plaid is just screwed up about this account.

    If it were me, I'd disconnect this Fidelity Card and reconnect it, you may have to disconnect the whole bank (probably with Toolbox) and start that bank over. You may get the same error, but it is an action that has worked for me in other areas.

    What happens with Chase and Elan? I did have to reverify third party access for Chase a few days ago (and it was a pain because I have four separate logins to match), but once I did that, Chase is working again.

  5. 5 Posted by cytoc on 20 Jan, 2023 10:53 PM

    cytoc's Avatar

    Is there any update on this issue? I am getting the same error messages and Fidelity says that Moneydance/Plad needs to esclate the issue. How do I get that to happen?

  6. 6 Posted by dtd on 20 Jan, 2023 11:00 PM

    dtd's Avatar

    just a user - did you try any of my suggestions?

    as I say, I'm just a user - but I was waiting for an update from you, versus a general request to all for new help. But that's up to you of course.

  7. 7 Posted by Robert Rugur on 21 Jan, 2023 03:47 PM

    Robert Rugur's Avatar

    Apparently, Fidelity has implemented new security protocols and Plaid, who is the contractor that handles downloads for Moneydance+ does not support the new protocols. I don't think that Quicken does either so there is perhaps some hope that Fidelity will do something about this.

    It seems that this is a problem for Fidelity to resolve, not Plaid, since only Fidelity is still having the problem.

    Fidelity maintains that they still support downloads since you can log in to the Fidelity site and manually download account information IN CSV FORMAT! Have fun transcribing all of that into Moneydance!

    I have accounts at several different institutions and Fidelity is about to lose a couple of accounts when I simply transfer the money to corresponding accounts at Vanguard. Unfortunately, they have enough billions that they aren't terribly concerned about my few bucks.
    ________________________________

  8. 8 Posted by Htownhman on 24 Jan, 2023 07:47 PM

    Htownhman's Avatar

    Having the same problem as all of you. .. Very annoying!

  9. 9 Posted by wbbonneriii on 25 Jan, 2023 06:53 AM

    wbbonneriii's Avatar

    Team, I have noticed USAA is no longer working with Moneydance+

    Is anyone else having a similar issue in that they are not able to download any transactions from USAA using Moneydance +? The issue started happening about a week ago.

    Thx

  10. 10 Posted by Bruce Alexander on 25 Jan, 2023 07:33 PM

    Bruce Alexander's Avatar

    I have been having the same problem between Moneydance+ and Fidelity & Chase Bank. I get messages from Plaid that my accounts are connected and followed by a Plaid screen showing a downloading “Progress bar” indicating success. I return to MD and click on the download button. However, no transactions.

    I've also been trying to resolve this with MD support. I'm not sure that they are aware that other customers are having this same problem.

  11. 11 Posted by Michael McGrego... on 25 Jan, 2023 08:47 PM

    Michael McGregor's Avatar

    Same issue for both Chase and USAA. Thanks everyone!

  12. 12 Posted by r lee on 25 Jan, 2023 09:40 PM

    r lee's Avatar

    Same here, both Chase and USAA seem to have stopped working in the last few days. Any words from Support?? TIA

  13. 13 Posted by dtd on 25 Jan, 2023 11:06 PM

    dtd's Avatar

    just a user

    I cannot speak to Fidelity as don't have accounts there. I can only work through others when/if they respond.

    As to Chase and USAA, I can report that both continue to work for me, with two caveats.

    With USAA, I still use direct connect, due to the immediacy of response - if direct connect can be used (and yes, I know it is evaporating for many banks), you should endeavor to do so, as it is always better than an aggregator (for the reason stated in the next paragraph).

    As for Chase (and maybe other banks), that works for me as well, but I have found that the delay time to get transactions has lengthened for Chase. There has always been a delay of 2-5 days for most banks using MD+/Plaid, due to the methodology of grabbing data. That seems to have lengthened recently, say to 3-7 days, for two reasons: pending charges are lingering longer than I expect at Chase, and the data gathering method for Plaid seems to list them as pending yet even longer.

    So, although I'm sure you are finding things "not working" - and indeed you may be encountering an error I am not, may I suggest a couple of tests to observe your situation.

    Knowing Plaid says the bank is connected, bring up Moneydance, open help/console window, click on one of the accounts in question, and click Online/download just that account/bank.

    Observe the bottom status line carefully, it should start with Downloading Transactions, then - what? - nothing? Or something like "Zero new transactions (of X downloaded) blah blah blah"

    If you get an error message rather than the above - yes, there is a problem. If you get nothing after Downloading Transactions, yes, there is a problem. If you get the "Zero new of..." - then you ARE connecting to MD+/Plaid and getting 'something' downloaded.

    Check the console window you have open - see what happened in more detail. If your Chase account is acting like mine are (not saying it is) - then you may find a lot of "pending transactions still pending, and dismissed". If so, you just have to say "ok, it's working, but it is xxxx slow."

    And if so, it is slower than it has been.

    If you get different results, report that, as detailed information will help either users or MD to help figure out your problem versus simply hearing "stopped working", as for others (like me, another user) at least I know Chase is still working for me. (Again, I use direct connect for USAA, and don't use Fidelity - but try this same test for both as well)

    Hope that helps.

  14. 14 Posted by Bruce Alexander on 25 Jan, 2023 11:53 PM

    Bruce Alexander's Avatar

    To: dtd,

    Thanks for your explanation as to what is going on with MoneyDance+
    I thought that Plaid was providing real time downloads of bank transactions NOT 2-5 days!!
    I feel that’s next to useless. I’ll likely cancel my subscription to it.

    Again, thank you
    Bruce Alexander

  15. 15 Posted by dwg on 26 Jan, 2023 12:14 AM

    dwg's Avatar

    I think it is important to note that no aggregator provides on demand end to end data downloads, not Plaid, not Yodlee, not Saltedge.

    They all work on a retrieve and store basis. When they download can involve many factors for example:

    - Load on their systems
    - Data demand for that particular institution
    - Agreements with institutions around access windows
    - How they schedule downloads

    etc

    If this sound like old school Mainframe batch processing to you, it does because it is essentially batch processing.

    The only on demand factor is when you retrieve whatever data the aggregator has.

  16. 16 Posted by dtd on 26 Jan, 2023 12:39 AM

    dtd's Avatar

    just a user - also, the banks are pushing this, as they want to get away from serving their customers and asking aggregators to do this instead. Money is involved.

    I can understand (in some way) banks trying to streamline and save money. What I abhor is that I haven't found ONE SINGLE BANK contact their customers and tell them that a change is coming. Not One. (My banks) USAA, Schwab, Chase (and others) - not a single one said this change was coming.

    With USAA, Stuart (Mr. Toolbox) and hleofxquotes - figured out how to get direct connect back. Sean made Schwab work "one more year" - but it has been a slippery slope in realizing banks were moving away from direct connect to "batch processing" (thanks dwg, love that concept) with aggregators - and not caring about their clients and what the response would be...

  17. 17 Posted by dwg on 26 Jan, 2023 12:49 AM

    dwg's Avatar

    I casted my mind back many years to working on IBM Mainframes and MVS/TSO for that one as well as VMS. Batch processing though still has a place and it widely used for certain tasks that is can handle very efficiently.

    Des

  18. 18 Posted by cytoc on 26 Jan, 2023 08:09 AM

    cytoc's Avatar

    Moneydance+/Plaid has generally been working fine for all of my accounts except those associated with Fidelity, which stopped working back in December. Most accounts are updated with same day transactions, though some may be 1 or 2 days behind. I was able to figure out how to get my Direct Connect (OFX) back for Fidelity, but that took some investigation and the use of the Advanced Toolbox to get Direct Connect to even show up as an option. Still can't get the Fidelity credit card account to work either way and am noe downloading transactions manually from the website. All in all, I am disappointed in the lack of any real answers for exactly what the problem is between Plaid and these banks/brokers, and who, if anybody, is actually working the problem, and if or when it will be resolved. I have yet to hear anything concrete from Moneydance or Plaid. Fidelity says it’s a Plaid and/or Moneydance issue and wants to wash their hands of the issue altogether.

  19. 19 Posted by dtd on 26 Jan, 2023 10:54 PM

    dtd's Avatar

    just a user

    @cytoc
    Since you seem to only accept a direct response from MD/IK as concrete, versus user information, I won't respond about my investigations, but leave it to MD/IK to answer or not.

    This response, to me, said a lot:
    https://infinitekind.tenderapp.com/discussions/online-banking/25332-moneydance-not-syncing#comment_57644392

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac