Error 2000 from Wells Fargo

Greg K's Avatar

Greg K

27 Jun, 2015 03:38 AM

I suddenly started getting an error saying 'your software isn't supported' when trying to connect to Wells Fargo to download transactions on my Mac. It worked a couple of weeks ago. I called them and they suggested updating MoneyDance. No Joy. I tried the 'disable' and 'add new connection' workaround. Still no joy. Ugh. Do I have to buy Quicken? I don't want to.....

- Greg

  1. Support Staff 1 Posted by Ethan on 27 Jun, 2015 11:49 AM

    Ethan's Avatar

    Hello Greg,

    We've updated our connection information for your bank, so you should be able to connect now. You will need to disable your current connection to your bank and then recreate it using the New Connection button on the Online Banking Setup screen. To do so, you can follow these steps:

    1) Open your bank account register by clicking on it in the left sidebar in Moneydance
    2) Select Online->Setup Online Banking from the menu bar
    3) Click the Disable button. If you don't see a disable button, continue to step 5.
    4) Select Online->Setup Online Banking from the menu bar (again)
    5) Click the New Connection button and select your bank from the list of available institutions that pops up. Hit OK
    6) Continue with the setup process, entering your username/password
    7) Repeat steps 1-6 for any additional accounts from this bank

    Make sure you pick new connection in step 5, even though your bank is still one of the connection choices after you disable it. Choosing your bank in this way will force Moneydance to download the updated information, which should then allow you to connect. It was unclear from your message if you had done this when resetting your connection.

    Please let me know if you continue to have connection problems after recreating your connection.

    Moneydance Support

  2. 2 Posted by Greg Kroetch on 27 Jun, 2015 10:21 PM

    Greg Kroetch's Avatar

    I did what you said below (yesterday, before asking for help and again
    today), creating a new connection to Wells Fargo Bank. I get Error 2000
    as soon as I enter a password.

    - Greg

  3. Support Staff 3 Posted by Ethan on 27 Jun, 2015 10:43 PM

    Ethan's Avatar

    Hello Greg,

    Just to make sure, when recreating your connection, it's critical to use the New Connection button to reconnect to Wells Fargo. If you just select it from the dropdown, you will not get updated information. That's a very common step for people to miss in resetting a connection.

    If that still doesn't work, you'll need to force clear the current connection information for your bank in Moneydance. I'm attaching a file called (or if you are using Moneydance 2014 or earlier) that will help do that. Before proceeding, please back up your Moneydance data set, just in case something goes wrong. You can use these instructions to create a backup:

    except copy your data set instead of moving it, in order to create a backup. So far, this hasn't caused any problems, but better safe than sorry!

    To use the file, first save it to your computer and then follow these steps:

    1. In Moneydance, click on the Extensions Menu and choose the Manage Extensions option.
    2. From the list of available extensions, choose the Python Interface extension, then click Install to download the extension and finish to complete the installation.
    3. Close the Manage Extensions window.
    4. Again, click the Extensions menu. This time, choose the Python Interface option.
    5. In the python window, click the read from file button and load the file from whereever you saved it. You will be asked to select which connection you want to clear. Choose your bank, and click OK. You'll get a confirmation message when the connection has been removed. Close the window when done.
    6. Set up the connection to your bank like normal. Since all of your settings have been cleared, you should get the most recent connection information for your bank.

    Hopefully, that will work. If it doesn't, let me know and we'll continue troubleshooting.

    Moneydance Support

  4. 4 Posted by pierson949 on 28 Jun, 2015 03:17 AM

    pierson949's Avatar

    I am having the same problem, except I can't even create the new connection because it gets to a window which asks to select which account to use for online banking, but all choices are greyed out so I cannot continue. Please help. I am unable to download my transactions.

  5. Support Staff 5 Posted by Ethan on 28 Jun, 2015 12:27 PM

    Ethan's Avatar

    Hello pierson949,

    In that case, please try the python script steps that I outlines in post 3 on this thread.

    Moneydance Support

  6. 6 Posted by Greg Kroetch on 28 Jun, 2015 02:52 PM

    Greg Kroetch's Avatar

    This did resolve my issue. Thanks!

    - Greg

  7. 7 Posted by pam on 28 Jun, 2015 06:23 PM

    pam 's Avatar

    I'm running 2015.5 (1225) on my Yosemite 10.10.3 iMac and am experiencing this problem. I have tried many permutations of the "re-connection" steps you identify above to no avail. When I try the python script, I receive the attached syntax error. Please advise.

  8. 8 Posted by Pam on 28 Jun, 2015 06:57 PM

    Pam's Avatar

    As far as the python script goes, I noticed my mac added a "webloc" extension so I deleted that but it still failed to run. Ultimately I entered it line by line at the command line and it successfully executed. The script resolved the problem.

  9. Support Staff 9 Posted by Ethan on 28 Jun, 2015 07:44 PM

    Ethan's Avatar

    Hi Pam,

    We have heard that some Macs have been adding that extension at the end of the file for some reason, which often means your browser is saving a web link to the file, rather than downloading the file itself. I'm glad to hear that you managed to figure it out.

    Moneydance Support

  10. 10 Posted by Pam Shields on 28 Jun, 2015 07:54 PM

    Pam Shields's Avatar

    I was able to rename the file to a .py file but alas it still did not work but the command line did. Thank you!

  11. Support Staff 11 Posted by Ethan on 28 Jun, 2015 08:00 PM

    Ethan's Avatar

    Remaining the file probably wouldn't be enough. What your web browser was saving was probably just a link to the file, or perhaps the file in an incorrect format. Right-clicking on the link and choosing "save link as..." (or whatever the similar sounding equivalent option is depending on which browser you use) probably would save the file in the correct format. In any case, I'm glad you figured out a way to make it work.

    Moneydance Support

  12. 12 Posted by pierson949 on 12 Jul, 2015 08:53 PM

    pierson949's Avatar

    This comment was split into a new private discussion: Wells Fargo error: can't select account


    I finally found enough time to try the python script. It doesn’t help. I’m still getting the problem that it has all the choices greyed out when it asks for an account to use for online banking, so I can’t go any further. Screenshot below.

  13. Ian L closed this discussion on 14 Jul, 2015 12:03 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac