Unable to online download Fidelity Investments investment account transactions.

Rsmed's Avatar


23 Mar, 2018 06:19 AM

I am hoping to switch from Quicken to Moneydance. I am working with the trial version 2017.6 and I need to know if I will be able to download transactions from accounts with Fidelity Investments as I can currently with Quicken. So far I am unable to do online updating of Fidelity Investments investment accounts.
I go through the Online---Set up Online Banking screens: first highlighting the account in Moneydance with the register showing, then clicking on New Connection, then selecting Fidelity Investments then clicking Next then receiving: Retrieving financial institution profile… then seeing a screen showing Account: and the name I gave to the account then I click on Next and am presented with a screen asking for Broker ID and Account Number. I give the login ID and account number, the same used in Quicken and the same that Fidelity says I should use, (Note that Fidelity says the accounts do not need to be “activated” in order for Quicken to use online update) and then I click on Next and receive a new screen saying, “Moneydance now has most of the information needed to connect to your financial institution for this account. Click the 'Finish' button below to complete the process.”. I click on Finish and the screen disappears. It should be noted that at no time was I asked for, nor did I give the password needed by Quicken(and Fidelity) to access the account.
Now the Online button on top in Moneydance shows on the drop down list: Download (name of investment account) Transactions but will not let me click on it(ctrl D does nothing by the way). I’ve done this for each of 6 Fidelity brokerage accounts. If I click on Online---Download All Accounts, then at the bottom of Moneydance appears “There are no accounts to be downloaded” and an orange ball of sorts goes back and forth on the bottom right and then after a few seconds the orange ball disappears as does the “There are no accounts to be downloaded”, and no new downloaded transactions are downloaded for the file in question nor for any of the other 5 Fidelity Investment accounts that I set up in Moneydance.

  1. 1 Posted by Ian O on 23 Mar, 2018 11:02 AM

    Ian O's Avatar


    Sorry to hear of the issue you have encountered when connecting with your Fidelity Investment account. I can confirm I have encountered issues when testing the connection. I have reported this to our lead developer and he is currently investigating this. I'll let you know as soon as I have further information.

    Please accept my apologies for the inconvenience.

    Ian O
    Infinite Kind Support

  2. 2 Posted by david on 24 Mar, 2018 02:42 AM

    david's Avatar

    I am having the same issue. I had a problem downloading from Fidelity since yesterday, March 22, 2018. I disabled and tried to set up online banking again. I am having the same issues as the original poster.

  3. 3 Posted by Alan on 24 Mar, 2018 02:49 AM

    Alan's Avatar

    Same here. I've been downloading Fidelity Investment accounts into Moneydance for years, but it stopped working a day or two ago. Hopefully just a temporary issue.

  4. 4 Posted by dwg on 24 Mar, 2018 04:20 AM

    dwg's Avatar

    I'm a fellow customer

    The change log shows that the Fidelity problem has been addressed in the latest Monerdance preview release - 2017.7 build 1670

    If you currently have Moneydance 2017 and purchased it through the Moneydance website, then you can download the preview from:


    For users that purchased Moneydance 2015 directly this should be a free upgrade, Users of earlier versions of Moneydance can upgrade at a 50% discount.

  5. 5 Posted by david on 24 Mar, 2018 11:37 AM

    david's Avatar

    Thank you. The preview took care of the connection issue with Fidelity.

  6. 6 Posted by Rsmed on 24 Mar, 2018 11:32 PM

    Rsmed's Avatar

    Thanks so much for all the comments and help in this matter.

    Thanks especially to dwg. the preview 2017.7 allows me to do what I want: online download of Fidelity Investments investment account transactions.

  7. 7 Posted by jesmail on 25 Mar, 2018 01:32 AM

    jesmail's Avatar

    Thanks for the fix, I thought at first it was them. But found quicken still downloaded fine.

  8. 8 Posted by Mark on 14 Apr, 2018 12:46 PM

    Mark's Avatar

    Currently running 2017.7.2 (1672) on a Mac (10.11.6) and am having problems logging in to Fidelity again. Don't know if it's the same problem or not. I had previously had problems connecting to Fidelity, then installed the update and everything worked again. Until today.

    Could be a temporary Fidelity problem, but am posting just in case it's prevalent across the Moneydance community.

  9. 9 Posted by david on 14 Apr, 2018 01:40 PM

    david's Avatar

    I am still on 2017.7.1 (1671) and can download from Fidelity.

  10. 10 Posted by Mark on 14 Apr, 2018 01:59 PM

    Mark's Avatar

    Update to my previous post ...

    Seems to have a problem with Fidelty NetBenefits (401k - through 401k.com).

    Regular Fidelity stuff seems to connect just fine (fidelity.com).


  11. 11 Posted by Alan on 14 Apr, 2018 02:02 PM

    Alan's Avatar

    1672 working fine with Fidelity for me. Probably just a glitch.

  12. 12 Posted by wuhl756 on 14 Apr, 2018 10:16 PM

    wuhl756's Avatar

    Confirming Mark’s experience using v. 2017.7.2 (1672). All other Fidelity accounts download fine but not Fidelity Net Benefits. Behavior started a couple of days ago and continues today. The program prompts for a password, then reports:

    The given customer ID or PIN is not valid. For more information, contact your financial institution.

    Additional information from the server:
    Error occurred logging in

    But when logging in directly to the account on the internet, no problems with the user ID or password.


  13. 13 Posted by wuhl756 on 14 May, 2018 02:29 PM

    wuhl756's Avatar

    Hi, this problem is still ongoing after an update to preview build 1674. Seems to be limited to Fidelity Net Benefits accounts. I've attached a screenshot of the error message. Can Support please acknowledge that they are looking into this? Otherwise i will post it as a new request. Thanks.

  14. 14 Posted by cgrinds on 14 May, 2018 09:59 PM

    cgrinds's Avatar

    Same for me - here's what the console log shows:

    connecting to: https://nbofx.fidelity.com/netbenefits/ofx/download with
    method: POSTConnecting to nbofx.fidelity.com
    acceptable protocols:  TLSv1  TLSv1.1  TLSv1.2
    TRUSTMGR: checking cert chain: CN=nbofx.fidelity.com, OU=FTG EI, O=Fidelity Investments, L=Boston, ST=Massachusetts, C=USTRUSTMGR: returning accepted issuers
    Connecting with https headers:
    POST /netbenefits/ofx/download HTTP/1.1
    Content-Type: application/x-ofx
    Host: nbofx.fidelity.com
    Content-Length: 699
    Connection: close
    User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/52.0.2743.116 Safari/537.36 Edge/15.15063Accept: application/x-ofx, */*
    Accept-Language: en
    Cache-Control: no-cache
    ---end headers
    HTTP/1.1 400 Bad Request
    Date: Mon, 14 May 2018 21:47:47 GMT
    Server: Apache
    X-Frame-Options: SAMEORIGIN
    fsreqid: <removed>
    connection: close
    content-length: 186
    Content-Type: application/x-ofx; charset=iso-8859-1
    fscalleeid: https-nbofx.fidelity.com-15640
    fselapsedtime: 176365
    set-cookie: JSESSIONID=<removed>; path=/netbenefits/ofx/; secure; httponlyP3P: CP="UNI DEM GOV FIN STA COM NAV PRE INT ONL CUR ADM DEV PSA PSD CUSi IVDi IVAi TELi CONi TAI OUR OTRi"
    Unrecognized cookie parameter: httponly ->
    HTTP response headers:
    date: [Mon, 14 May 2018 21:47:47 GMT]
    server: [Apache]
    content-length: [186]
    set-cookie: [JSESSIONID=<removed>; path=/netbenefits/ofx/; secure; httponly]fsreqid: [<removed>]
    x-frame-options: [SAMEORIGIN]
    fscalleeid: [https-nbofx.fidelity.com-15640]
    connection: [close]
    content-type: [application/x-ofx; charset=iso-8859-1]
    fselapsedtime: [176365]
    p3p: [CP="UNI DEM GOV FIN STA COM NAV PRE INT ONL CUR ADM DEV PSA PSD CUSi IVDi IVAi TELi CONi TAI OUR OTRi"]Reading message from https://nbofx.fidelity.com/netbenefits/ofx/download>>>>>>>>
    <HTML><HEAD><TITLE>Bad request</TITLE></HEAD><BODY>cvc-minLength-valid:
    Value '' with length = '0' is not facet-valid with respect to minLength
    '1' for type 'PasswordType'.</BODY></HTML>java.io.IOException: HTTP
    Error:400 Bad Requestat com.moneydance.apps.md.controller.olb.ofx.OFXConnection.sendMessage(-
    OFXConnection.java:2740)at com.moneydance.apps.md.controller.olb.ofx.OFXConnection.sendMessage(-
    OFXConnection.java:2565)at com.moneydance.apps.md.controller.olb.ofx.OFXConnection.getTransacti-
    ons(OFXConnection.java:976)at com.moneydance.apps.md.view.gui.OnlineManager.downloadTransactions(O-
    nlineManager.java:554)at com.moneydance.apps.md.view.gui.OnlineManager.downloadTransactions(O-
    nlineManager.java:469)at com.moneydance.apps.md.view.gui.InvestAccountDetailPanel$DLTxnsRunna-
    ble.run(InvestAccountDetailPanel.java:520)at com.moneydance.apps.md.controller.BackgroundOpsThread.run(Background-
  15. 15 Posted by msumick on 17 May, 2018 04:49 PM

    msumick's Avatar

    I have had the same problem for about the last 2 months. Disabled access in Moneydance and then re-setup the account settings, still receiving the same error.

  16. 16 Posted by gtomwilby on 22 May, 2018 11:20 PM

    gtomwilby's Avatar

    I am trying to set up online banking with Fidelity. Followed al above advice, still unable to. Why doesn't support chime in here to help???? Guess it's back to Quicken!

  17. 17 Posted by wuhl756 on 28 May, 2018 05:07 PM

    wuhl756's Avatar

    For those following this discussion: See this thread.

    Apparently the Fidelity Net Benefits problem has been fixed since April 16. The advice given is to disable and then reconnect the Net Benefits online banking connection. I tried this today and it worked.


  18. System closed this discussion on 27 Aug, 2018 05:10 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac