iPhone app fails to sync

forslund's Avatar


31 May, 2010 09:40 PM

I launch MD on my Win machine and then launch it on the iPod Touch. They are both on the same LAN and subnet. It all worked just as advertised the first time. After that no more syncing. I rebooted the phone, reinstalled MoneyDance on the iPod, and tried the syncing again. MoneyDance on my desktop says there is no device to sync with. I'm running network synchronizer build 9 on MD. I can ping the iPod from the Windows machine running MD and vice-versa.

  1. 1 Posted by forslund on 01 Jun, 2010 02:12 AM

    forslund's Avatar

    I don't doubt it works in Vista. It did when I first ran the app. But both the iPhone app and MD itself have been upgraded since I had done a successful sync. There is no information as to why it fails. Each machine can see the other over the network. I can't use the adhoc connection mentioned in your help because the machine I'm connecting to is hard-wired and the description of what to do doesn't apply. What port needs to be sure that it is open?

  2. 2 Posted by Ben Spencer on 02 Jun, 2010 06:42 PM

    Ben Spencer's Avatar

    I am not sure why but it sounds like you need to add the device again to your moneydance data file. Given that you are getting the no devices found error when you click the add device button can you confirm that you have checked each of the points in the following article (minus the computer-to-computer one of course).


  3. 3 Posted by forslund on 02 Jun, 2010 08:00 PM

    forslund's Avatar

    I followed all the items in the list and they were all set as suggested. Still no connection or detection. I also enabled port 5353 for the bonjour protocol just in case.

  4. 4 Posted by Ben Spencer on 02 Jun, 2010 08:08 PM

    Ben Spencer's Avatar

    If you have a personal firewall on your desktop can you turn it off completely.

  5. 5 Posted by forslund on 02 Jun, 2010 10:34 PM

    forslund's Avatar

    Did this and there is no change. Any suggestions?

  6. 6 Posted by forslund on 26 Jun, 2010 06:29 PM

    forslund's Avatar

    Tried this all again and still can't see the iPod app to synchronize with.

  7. 7 Posted by Ben Spencer on 26 Jun, 2010 06:42 PM

    Ben Spencer's Avatar

    If you are familiar with the operation of your wireless router can you try open up the following ports:


    There was another user who had tried everything in the list and opening these ports in their router solved the problem. See this discussion http://help.infinitekind.com/discussions/iphone-ipod-touch-and-ipad...

    Ben Spencer

  8. 8 Posted by forslund on 26 Jun, 2010 07:39 PM

    forslund's Avatar

    I have no ports blocked on my wireless router.

  9. 9 Posted by forslund on 26 Jun, 2010 09:47 PM

    forslund's Avatar

    I have an app called PrinterShare running on my system that uses Bonjour if that makes any difference. It, in fact, tries to install it, but fails and says there is a later one installed on my machine. I have checked ports and updated the plugins and moneydance on the ipod all to no avail and apparently no way to diagnose the problem.

  10. 10 Posted by Brian Adler on 15 Jul, 2010 10:08 PM

    Brian Adler's Avatar


    I would try again by installing the latest version of the iphone app, the desktop app, and the extension. Completely turn off any firewall on your desktop and try again. It seems very likely that the issue is either with your wifi, router, or firewall.


    Brian Adler

    Moneydance Support

  11. 11 Posted by forslund on 23 Aug, 2010 11:41 PM

    forslund's Avatar

    I don't think so. I can ping the vista machine with Moneydance from the ipod touch without any problems. I can ping the ipod touch from the vista machine without any problems. They are on the same subnet one is .111, the other is .108. I've updated the iphone app, the network extension to no avail. Nothing shows up.


  12. 12 Posted by Ben Spencer on 24 Aug, 2010 02:26 PM

    Ben Spencer's Avatar


    In order to help us diagnose this issue further can you please install a telnet client on your PC. A free windows telnet client can be downloaded from here:


    Can you then try to telnet into the ipod while it is running the Moneydance app on port 6636.

    Let me know if you get a connection or an error message.

    Ben Spencer

  13. 13 Posted by forslund on 25 Aug, 2010 04:39 PM

    forslund's Avatar

    I get connection closed by remote host followed by network error: connection refused. At the same time I can ping the ipod touch and get a prompt response.

  14. 14 Posted by Brian Adler on 20 Sep, 2010 03:14 PM

    Brian Adler's Avatar


    Try starting MD on the desktop, open the console window under help menu. Then turn on the mobile device and try to sync. Send us any messages that appear in the console window. Give it a couple of minutes to generate messages.


    Brian Adler

    Moneydance Support

  15. 15 Posted by forslund on 05 Oct, 2010 10:19 PM

    forslund's Avatar

    I did this and nothing shows up in the Moneydance console. No indication of any communication between Moneydance on the desktop and Moneydance on the iPod over the network.

  16. 16 Posted by Dave on 06 Oct, 2010 12:01 PM

    Dave's Avatar

    I'm having a similar problem. When I launch Moneydance on my iPhone, the MD console on my Mac shows:

    Starting Moneydance 2010r3 (751)
    Settings Folder: /Users/dave/.moneydance
    OS: Mac OS X 10.6.4 x86_64
    Java: 1.6.0_20 (Apple Inc.)
    svc added: Dave�s iPhone type:_mdncsync._tcp.local.
      requested service info

    And nothing more. But I decided to experiment some...

    I have a passcode set on my iPhone Moneydance. I tried removing the passcode, and it sync-ed just fine.

    I then restored the passcode, and it still syncs. (At least something like 9 out of 10 tries.)

    Interestingly (and questionably) it syncs before I enter the passcode, which isn't a good idea since I haven't authorized the app to do anything yet. Furthermore, (at least on my slow old iPhone 3G), apparently because the app is busy syncing, it won't even LET me enter the passcode until its done.

  17. 17 Posted by forslund on 06 Oct, 2010 03:09 PM

    forslund's Avatar

    I didn't see anywhere to enter a passcode form MoneyDance on the iPod. It just comes up with a screen with a bunch of numbers/letters on it. I do have a passcode on Moneydance on my Vista desktop which I don't want to remove because it knows how to get to all my financial accounts. Is that related to this problem of not syncing?

  18. 18 Posted by gillpar on 03 Nov, 2010 02:17 PM

    gillpar's Avatar

    I had the same issue as Dave with my Mac and his solution of removing the pass code worked for me. Is there a fix for this yet?

  19. 19 Posted by Angie Rauscher on 19 Nov, 2010 02:47 PM

    Angie Rauscher's Avatar

    Forslund- I believe that when Gill referred to the passcode he meant the 4 digit PIN which you can use to add another level of security to your iPhone app. The "bunch of letters and numbers" is a key which securely connects your iPhone to your desktop app. Have you tried all of the options listed in our knowledge base?

    Gil- We are working on a new and improved sync method, but I don't have a release date yet.

    Thank you all for your patience, and please let me know if I can be of further assistance,

    Angie Rauscher
    Moneydance Support

    Check out our new blog series, Moneydance on the Road.

  20. 20 Posted by forslund on 19 Nov, 2010 03:19 PM

    forslund's Avatar

    I thought he was referring to the password I use on MoneyDance to protect my data. I have no password on the iPod. I do see a bunch of letters and numbers on the screen on the iPod when I start up Moneydance but don't see anything to do with them. Still waiting for the ability to use the iPod with Moneydance. I've tried everything in your knowledge base unless some new ideas have been added recently. I don't have time to keep looking in the knowledge base for new approaches.

  21. 21 Posted by Angie Rauscher on 23 Nov, 2010 03:20 PM

    Angie Rauscher's Avatar


    We are working on the new sync method, and will post both here and on our blog when it's ready for release. I'm sorry it's not working for you yet. Please let me know if I can be of further assistance,

    Angie Rauscher
    Moneydance Support

    Check out our new blog series, Moneydance on the Road.

  22. 22 Posted by galrozov on 03 Dec, 2010 02:10 PM

    galrozov's Avatar

    I'm having trouble adding my iPhone 4/3gs devices too, tried all the options and I'm getting Connection refused when trying to telnet the device on port 6636.
    (iOS ver 4.2.1 for both devices)

    One of the big decision points, moving to MoneyDance is the iPhone/iPad app sync.
    Hope this will resolve soon so I could continue my migration quest.

    Here is my console dump:
    Starting Moneydance 2010r3 (751)
    Settings Folder: C:\Users\Gal.moneydance
    OS: Windows 7 6.1 x86
    Java: 1.6.0_15 (Sun Microsystems Inc.)

  23. Angie Rauscher closed this discussion on 30 Mar, 2011 06:03 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac