Can't use Moneydance with new Wachovia account

michael's Avatar

michael

01 Jun, 2010 06:38 PM

I just opened a Wachovia checking account and can access it via the web with my id and password. When I try to setup online banking through Moneydance it tells me:

The given customer ID or PIN is not valid. For more information, contact your financial institution. Additional information from the server: An incorrect username/password combination has been entered.

I called Wachovia, who couldn't help me much because they don't support Moneydance. They only told me that there's no other id/pw to setup; the web logon should be the same one I use (if I were using one of the products they support, i.e. Money / Quicken.) I tried "Wachovia Bank", "Wachovia Sec-Wells Fargo Advisors", and "zWachovia" unsuccessfully. From what I could find on the forums, I think Wachovia Bank is the right one, though. Any ideas why it won't accept my id and password?

I was using the 743 build and just tried 750 - no difference.

  1. 1 Posted by Jessica Little on 02 Jun, 2010 08:33 PM

    Jessica Little's Avatar

    Hi Michael,

    Most likely, there's something wrong with your password. Try calling Wachovia and telling them that you're having password problems. Ask them to reset your password. That has cleared things up for people sometimes. Other people have reported being able to connect to Wachovia using their web password, so I'm fairly certain our connection is working. Maybe a password reset will help.

    Jessica Little
    Moneydance Support

  2. 2 Posted by Mary on 02 Jun, 2010 08:38 PM

    Mary's Avatar

    I got the same message, and the same answer from Wachovia. Resetting the password did not fix the problem.

  3. 3 Posted by Jessica Little on 03 Jun, 2010 06:06 PM

    Jessica Little's Avatar

    Hi Mary,

    Have you tried connecting to zWachovia instead of the Wachovia bank connection? Depending on who you were originally banking with before all these recent mergers happened, the zWachovia account might actually be the one you need to use.

    Jessica Little
    Moneydance Support

  4. 4 Posted by michael on 03 Dec, 2010 02:11 PM

    michael's Avatar

    I didn't use this account much so I let this go, but now I'm using it more and would really like Moneydance to work. I have reset my password and that did not help. Again, I can login via the web, download an OFX file and import it, but I can't get Moneydance to connect to the Wachovia account itself.

    I tried Wachovia and zWachovia, but neither works. zWachovia uses the "firstunion.com" URL and I use 'wachovia.com', so that one probably shouldn't work. "Wachovia Sec-Wells Fargo Advisors" gets past the name/password portion of setup, but then comes to a dialog box that says "Please choose the account you wish to use." Both "Online Banking" and "Bill Payment Enabled" checkboxes are grayed out so that I can't use either. The only option is to 'Cancel.' I'm attaching a screen shot so you can see what I mean.

  5. 5 Posted by Jessica Little on 03 Dec, 2010 03:41 PM

    Jessica Little's Avatar

    Hi Michael,

    Have you made sure that your account is activated for direct connections and not just web connections? There is a fee associated direct connection access. You may need to go to https://www.wachovia.com/enroll to make sure you are properly set up to use their Online Services through Quicken (and therefore through Moneydance).

    Jessica Little
    Moneydance Support

  6. 6 Posted by michael on 03 Dec, 2010 04:25 PM

    michael's Avatar

    Yes, I am enrolled. I went through the link you provided to double-check and it told me I was already enrolled for Online Banking and Bill Pay.

    I have Wireshark traces of Moneydance's attempt to connect. I'm just starting to look at them; let me know if they might be of any use to you. I'm seeing TCP Checksum errors and some duplicate ACKs. The payloads are encrypted, right, so I can't really see what's going on.

  7. 7 Posted by Jessica Little on 04 Dec, 2010 06:19 PM

    Jessica Little's Avatar

    Hi Michael,

    If you would be willing, could you send me the contents of your error console? Here's how to get the log in Moneydance 2010:

    1) In Moneydance, click on the Help menu and select the Console Window option. This will open the console messages window.
    2) While the Console Window is open, attempt to connect to your bank. Any error messages should be recorded to the Console.
    3) Select all of the text in the Console and use the "Copy to Clipboard" button at the bottom to copy the text.
    4) Paste the text from the message window into a text file (preferably saved with a .txt extension) and email that file directly to me at [email blocked].

    Do not attach the file to your response here, since this thread is public and the logs will contain your account information. To be safe you should redact any account info in the debug logs. Just replace it with something like "ACCOUNT NUMBER HERE" and it should be fine.

    Jessica Little
    Moneydance Support

  8. 8 Posted by Jessica Little on 07 Dec, 2010 07:21 PM

    Jessica Little's Avatar

    Hi Michael,

    Hmm, strange indeed. What kind of account did you open with Wachovia? Was it just a regular checking account, or is it related to investments in any way?

    The error message says that you're using the wrong username and password combination still. It's odd that you can get into the Securities-related server though. If you set up your Moneydance account as an Investment-type account and try connecting it to Wachovia Securities, do you see anything?

    Jessica Little
    Moneydance Support

  9. 9 Posted by michael on 08 Dec, 2010 02:34 PM

    michael's Avatar

    Just a plain-vanilla checking at a plain-vanilla Wachovia branch.

    I can't find a way to change the "type of account". So, I set up a new "investment" account and I get the same thing as the screen capture I included before: an account selection dialog box that doesn't let me select anything but 'Cancel'.

  10. 10 Posted by michael on 08 Dec, 2010 03:18 PM

    michael's Avatar

    Not sure if it helps, but this branch used to be First Union. I noticed that the one that fails uses Wachovia / 4309 but the one that works uses First Union / 4307. However, they both use the same URL. I tried using the Manual set up method, but when I enter all the values, it comes up "Wachovia Sec-Wells Fargo Advisers" again and the same thing happens - no accounts can be selected.

  11. 11 Posted by Jessica Little on 08 Dec, 2010 06:41 PM

    Jessica Little's Avatar

    Hi Michael,

    If the branch you opened your account at used to be a First Union, then it could be that you need to use the zWachovia connection. They never fully integrated the two systems, so it could be they're still creating accounts on the old First union servers. What happens when you try to connect to zWachovia?

    Jessica Little
    Moneydance Support

  12. 12 Posted by michael on 11 Dec, 2010 04:09 PM

    michael's Avatar

    I tried zWachovia before, but I did it again to capture the console messages. I'll email it to you (I tried it for both my checking and savings account.)

    It completes the setup OK, but never tries to connect. After setting it up, when I try to download transactions I get "customer ID or PIN not valid." See attached screenshot.

  13. 13 Posted by Jessica Little on 13 Dec, 2010 06:07 PM

    Jessica Little's Avatar

    Hi Michael,

    I noticed a few strange things in your logs that make me think you're connection data isn't quite up-to-date for so\me reason. It's seems like Moneydance is getting the wrong information for some reaosn. To fix this, you'll need to force clear all of your current connection information in Moneydance. I'm sending a file called "remove_all_services.py" that will help do that. Before proceeding, please back up your Moneydance file, just in case something goes wrong. So far, this hasn't caused any problems, but better safe than sorry!

    To use the file, first save it to your computer and then follow these steps:

    1) In Moneydance, click on the Extensions Menu and choose the "Add..." option
    2) In the window that pops up, make sure the "From Internet" option is selected and then click next.
    3) From the list of available extensions, choose the "python scripting interface" extension, then click Next to download the extension and finish to complete the installation.
    4) Again, click the Extensions menu. This time, choose the "Python Interface" option.
    5) In the python scripting window, click the "read from file" button and load the file from whereever you saved it. You won't get any confirmation of anything happening, but you also shouldn't get any error messages. Close the window when done.
    6) Set up the connection to your bank like normal. Use the Wachovia connection and not the other (we'll test those next if Wachovia doesn't work). Since all of your settings have been cleared, you should get the most recent connection information for your bank.

    Hopefully, that will work. If it doesn't, let me know and we'll continue troubleshooting.

    Jessica Little
    Moneydance Support

  14. 14 Posted by Jessica Little on 12 Feb, 2011 01:54 PM

    Jessica Little's Avatar

    Hi Michael,

    It will, but if your connection is already working you should be able to reconnect to Chase without any problems. To be on the safe side, back up your Moneydance file. if for some reason you can't connect to Chase again after this, you can just revert to your old file. It shouldn't be a problem though.

    Jessica Little
    Moneydance Support

  15. 15 Posted by michael on 12 Feb, 2011 02:02 PM

    michael's Avatar

    Quick reply! I kinda figured, and it didn't really matter anyway...

    Yay! This worked. I used 'Wachovia' and it worked right away. Thanks!

  16. 16 Posted by Jessica Little on 12 Feb, 2011 02:02 PM

    Jessica Little's Avatar

    No problem. Thanks for using Moneydance!

    Jessica Little
    Moneydance Support

  17. Jessica Little closed this discussion on 12 Feb, 2011 02:02 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

25 May, 2024 04:18 PM
25 May, 2024 03:46 PM
25 May, 2024 11:31 AM
25 May, 2024 09:30 AM
25 May, 2024 08:59 AM