Moneydance 2010 very slow to enter transactions

Nathan Bohlmann's Avatar

Nathan Bohlmann

08 Aug, 2010 07:32 PM

Hi,
I am switching from Quicken to Moneydance. I was running Quicken on Windows and am running Moneydance on Mac OSX. I have successfully imported from Quicken though I've had to do some updating of data to get things correct. I am trying to enter transactions currently to bring things back up to current and I find that it usually takes 15 or 20 seconds after pressing the Enter key for the transaction to get entered (and the cash register sound is played). This should take 1 or 2 seconds at the most.

This is Moneydance 2010r3 (751)

  1. 1 Posted by Ben Spencer on 09 Aug, 2010 03:18 PM

    Ben Spencer's Avatar

    Hi Nathan,

    I recall a user having a similar problem last year. In that case the they had inadvertently entered a transaction with a date of 01/01/0009 when they had the networth graph at the top of the screen turned on the graph was trying to plot data for the last 2000 years. Please try turning off the networth graph by selecting View->Hide Status Graph. If the performance improves with the status graph hidden select Tools->Graphs and Reports. and run a "transactions" report for "All accounts" and "All dates" to see if there are any transaction with highly incorrect dates.

    Sincerely
    Ben Spencer
    Moneydance Support

  2. 2 Posted by Nathan Bohlmann on 09 Aug, 2010 10:48 PM

    Nathan Bohlmann's Avatar

    Hi Ben,
    I should have mentioned that the state of the system is such that I've just imported my Quicken data which goes back to 2002. I've just been entering a few transactions and they take 15 seconds each. I also note that updating a transaction that is already in the register is instantaneous. I turned off the Status Graph to no avail. New transactions continue to take 15 seconds

  3. 3 Posted by Ben Spencer on 10 Aug, 2010 07:26 PM

    Ben Spencer's Avatar

    Please run a transactions report as described above to see if there are any outlier transactions.

    Ben

  4. 4 Posted by Nathan Bohlmann on 10 Aug, 2010 11:07 PM

    Nathan Bohlmann's Avatar

    There are no outlier transactions in any account. On the transaction report however, each account had a Beginning Balance with a date of 1/1/1970. This does not appear in the account itself however. I believe this is an artifact of the Quicken import though I have no evidence for that.

  5. 5 Posted by Ben Spencer on 11 Aug, 2010 06:30 PM

    Ben Spencer's Avatar

    Could you create a new .md data file by selecting File->New. Make sure that your existing data files is saved before creating a new one. Once in the new empty can you try creating a new transaction and see if the performance problem is still present. You can switch back to your other data file by selecting File->Open.

    Ben

  6. 6 Posted by Dina on 31 Jul, 2011 02:09 PM

    Dina's Avatar

    I was experiencing the same thing - 15 seconds per transaction, and the same amount of time when trying to reconcile. Selecting "Hide Status Graph" didn't help... until I restarted the program.

    Now it is instantaneous. I don't have any outliers, but it is a big data file (from 1998). There might be an issue with the updating of the graph. (I am running MD2001 791).

  7. 7 Posted by Jon Hoover on 04 Aug, 2011 09:24 PM

    Jon Hoover's Avatar

    Dina,
    Do I understand that the issue is resolved then?
    Sincerely,
    Jon Hoover, Moneydance Support

  8. 8 Posted by Dina on 04 Aug, 2011 10:03 PM

    Dina's Avatar

    This wasn't my problem - but I was experiencing the same thing with same issues -- no outliers, but a 10-15 sec pause between transactions. Once I turned off the graph and restarted the program, it was instantaneous between transactions.

    I tried turning the graph back on, and the program slowed way down again.

    So it is resolved for me (I don't know about the original poster), but you might want to consider having the net worth graph be handled differently since it is not immediately apparent that just showing the graph could cause that level of slow down.

  9. 9 Posted by Ben Spencer on 05 Aug, 2011 02:33 AM

    Ben Spencer's Avatar

    We are working on putting the calculation of the net worth graph in a low priority background thread so that the responsiveness of the user interface is not affected by it.

    I am sorry for the trouble this has caused you.

    SIncerely
    Ben Spencer
    Moneydance Support

  10. System closed this discussion on 31 Mar, 2015 03:30 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

19 Apr, 2024 08:57 PM
19 Apr, 2024 08:44 PM
19 Apr, 2024 08:33 PM
19 Apr, 2024 08:30 PM
19 Apr, 2024 07:52 PM