Import from OFX imports only first item

Michele's Avatar


26 Jun, 2009 12:15 PM

I have three OFX files I downloaded from my bank, but when I import it into Moneydance only the first item is imported. What should I do?

  1. 1 Posted by Ben Spencer on 26 Jun, 2009 01:57 PM

    Ben Spencer's Avatar

    Hi Michelle

    Please open the ofx files in a text editor and verify that they each contain more than one transaction.

    If you are willing you could attach one of the problem OFX files to this discussion and I will attempt to import it and see if I can reproduce and resolve the issue. And I understand if you are unwilling to do this for privacy reasons.


    Ben Spencer

  2. 2 Posted by Michele on 26 Jun, 2009 03:54 PM

    Michele's Avatar

    Hi Ben,

    I had already checked and the file had more than one entry (which I could import without any issue with iBank). I've now created a sample for you (basically I limited it to two entries and changed the values) which Moneydance can't import.

    I really like Moneydance, but I can't start using it if this isn't fixed.

    Thanks for your help! :)

    • Michele
  3. 3 Posted by Ben Spencer on 26 Jun, 2009 09:10 PM

    Ben Spencer's Avatar

    Hi Michele

    The problem is that the FITID (Financial Institution Transaction ID) field in the ofx file is set to 0 for both transactions. The FITID is the unique ID that the bank is supposed to assign to each transaction. it lets clients eliminate duplicates. So technically this is not a correctly formatted OFX file. Moneydance checks the FITID to determine if the transactions are duplicates, this is reasonable because the OFX spec requires that these IDs be unique for each transaction. Because the FITIDs are the same for both transactions MD thinks a duplicate has occured and does not record the second transaction. I imagine that iBank does not rely on the file being to spec in order to function correctly. Which Financial Institution did you download these files from? It might be worth calling them at telling them that their files are not to spec.


    Ben Spencer

  4. 4 Posted by Michele on 30 Jun, 2009 09:11 AM

    Michele's Avatar

    Hi Ben,

    So there's no way I can work this out, right? isn't there a hidden setting to turn-off duplicate checking? Because I suspect my bank is not going to change their system to accomodate for this... ;)

  5. 5 Posted by Ben Spencer on 01 Jul, 2009 03:23 PM

    Ben Spencer's Avatar

    Hi Michele

    I am afraid there is not a hidden option to turn off duplicate checking. Checking for duplicates is an integral part of the importing transactions process and would require a rewrite of some of the program. Something that we are not inclined to do at this time.

    It is possible though unlikely that your bank will do anything about this situation. In my opinion it is still worth asking them.

    I am sorry


    Ben Spencer

  6. 6 Posted by Mark on 10 Feb, 2010 10:10 PM

    Mark's Avatar

    I am having the exact same problem. It turns out that the FITID for all of the 10 transactions in the OFX file downloaded from my bank have the exact same value.

    I haven't looked up the standard for OFX, but will shortly to ensure what Ben is stating is correct (that they should be unique for each transaction and not just the time the file was created).

    In the meantime, I have edited the file to ensure that each FITID was unitque and all 10 transactions did make it through.

    I used textpad and the following search/replace parameters:

    searched for (the value for all 10 FITID entries):


    Using regular expressions, replaced with the following (since I only had 10, this worked fine, but could be adjusted more characters to the left and changing the first number after \i( to accomodate):


    Hitting replace all will set each FITID to a unique value. Since the first part of the value is probably some sort of HASH code, it's not likely you'll get the same FITID values in subsequent downloads of newer transactions (but it is possible).

    Hope this helps.

    I also notice that there hasn't been a post on here since July 2009, has this been somehow corrected?

  7. Angie Rauscher closed this discussion on 24 Jul, 2011 07:25 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac