cannot change splits

Robert Shwery's Avatar

Robert Shwery

26 Feb, 2011 06:30 PM

This issue just started this week. There were updates to Linux recently but don't know if these would cause this problem or not. I have Kubuntu 9.10. I am running Moneydance 2010r3 (751). Java version is 1.6.0_24.

Problem: I have a number of memorized recurring transactions (Reminders) and just now cannot change any of the splits in them. I can delete and/or add a split but just cannot change an existing split. I then created a new transaction in an account and found that the same problem happens in any transaction with splits. I can add or delete a split but cannot change a split. When I select a split it does highlight. When I double click a split the highlight is gone, same as before when it is ready for me to change it but I am unable to select any field within the split to change it.

Please help.
Thanks,
Robert Shwery

  1. 1 Posted by Ben Spencer on 28 Feb, 2011 04:33 PM

    Ben Spencer's Avatar

    Can you give me a little more detail to clarify the problem.

    Are you saying that you see the split window and when you double click on a split line in that window the line does not become editable? I have not been able to reproduce this problem. Could you take a screenshot of what happens when you double click on split line? Press the print screen button on your keyboard to take a screenshot.

    Could you also open the console window. Select Help->Console Window. Then reproduce the problem and paste any console output to this discussion.

    Sincerely
    Ben Spencer
    Moneydance Support

  2. 2 Posted by bt on 28 Feb, 2011 10:00 PM

    bt's Avatar

    Yes, you do describe the problem. Seems the problem is not consistent. When I
    first open a transaction for editing it seems to sometimes let me edit the
    amounts, etc. in a split but after closing the split window and reopening, or
    just opening another transaction split I am only able to open the split window
    and look at the splits but not edit. Usually one click on a split in the split
    window will highlight that split and a double-click will enable editing of
    that split. Usually I just double-click right on the amount block since that
    is what I want to edit and the split is enabled for editing with the amount
    highlighted.

    Attached is a screen clip of the splits window of one transaction. When
    MoneyDance first started up I opened this transaction and was able to edit the
    splits. But after closing the split window and then reopening the splits
    window I was unable to do anything other than just look at it. It does not
    seem to matter if I save or exit the transaction in between attempts to edit
    the splits. The attached screen clip was taken when I had reopened the
    transaction split and double-clicked on the amount of second split ($3).
    Normally the amount would be highlighted since that is where I double-clicked
    but as you see the split is not highlighted anywhere, the cursor is in the
    Description block but not flashing as it should. After this I closed the window
    and exited the transaction and then tried again and sometimes I could edit and
    sometimes not edit the splits.

    Also attached is the console results. I cleared the console, then opened the
    split window and double-clicked on a split to edit but no edit allowed, then I
    closed the split window and then copied the console result to a txt file.

    Just to contrast I also took a screen clip of the same splits window when it
    was working (moneydance error 02 working.jpeg). The amount is highlighted and
    the cursor line is flashing in the amount block.

    Hope this helps find a solution.

    Thanks,
    /bob

  3. 3 Posted by Jessica Little on 01 Mar, 2011 04:29 PM

    Jessica Little's Avatar

    Hi Bob,

    Thanks for the screenshots. So far I haven't been able to duplicate this bug on Ubuntu 10.10 using Java 1.6.0_24. You said you attached your console logs, but I don't see them attached to the message. Could you please send those? I think they will be very helpful in figuring out what the problem is.

    Jessica Little
    Moneydance Support

  4. 4 Posted by Btpctchr on 01 Mar, 2011 04:46 PM

    Btpctchr's Avatar

    I have kubuntu 9.10.
    There should have been 3 attachments on my email. The txt file is the console output. Was that missing?
    I'll check when i get home since that is where i have that stuff
    Thanks.

    Jessica Little <[email blocked]> wrote:

  5. 5 Posted by Jessica Little on 01 Mar, 2011 06:35 PM

    Jessica Little's Avatar

    Hi Bob,

    Yes, the txt file was missing. If you could send that when you get a chance, that would be great.

    Jessica Little
    Moneydance Support

  6. 6 Posted by bt on 01 Mar, 2011 10:18 PM

    bt's Avatar

    Attached is the txt file named moneydance error console 01.txt

    Let me know if this doesn't go through.

    I checked my previous sent message and this file was included but evidently
    didn't pass through one of our email systems.
    /bob

  7. 7 Posted by Jessica Little on 02 Mar, 2011 02:32 PM

    Jessica Little's Avatar

    Hi Bob,

    Unfortunately, the file still didn't come through for some reason. Could you please try emailing it to me directly at [email blocked]?

    Jessica Little
    Moneydance Support

  8. 8 Posted by bt on 02 Mar, 2011 10:58 PM

    bt's Avatar

    Changed the filename to see if this will allow it to pass through. When you get
    it change the name back to .txt to open/read it.

    Thanks,
    /bob

  9. 9 Posted by Jessica Little on 03 Mar, 2011 04:17 PM

    Jessica Little's Avatar

    Thanks Bob, got it that time. Though, interestingly enough, only the .sav file showed up on the forum, though the txt file came through on my email.

    I've passed the log file on to our developers, so hopefully we can track down the problem. I have also filed a bug ticket for this, so we can make sure it gets fixed. Thanks for reporting this bug, and I'll let you know when we've fixed it.

    Jessica Little
    Moneydance Support

  10. System closed this discussion on 31 Mar, 2015 03:34 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

19 Apr, 2024 08:44 PM
19 Apr, 2024 08:33 PM
19 Apr, 2024 08:30 PM
19 Apr, 2024 08:18 PM
19 Apr, 2024 07:52 PM