Associate with a file in Ubuntu Linux

Lawrence's Avatar

Lawrence

28 Jul, 2009 01:25 AM

I'd like to download ofx files from my bank and have them opened by Moneydance automatically. When I do this, I get this error:

Error reading file: java.lang.NullPointerException

But I can open the file through file>import in Moneydance. I probably have the wrong executable file associated with OFX files in my operating system. I don't really know which file in which folder has to be associated with OFX for this to work. At this time, the file I have associated is called MoneyDance. (no extension) and it is located in /usr/local/MoneyDance. This probably is the wrong file.

Can someone give me a hint?

  1. 1 Posted by Ben Spencer on 28 Jul, 2009 06:39 PM

    Ben Spencer's Avatar

    Hi Lawrence

    I just tried associating ofx files with the moneydance start up script. This is indeed the file you are refering to i.e usr/local/Moneydance/Moneydance. When I then double click on the ofx file Moneydance opens and presents me with the OFX import window.

    What version of Moneydance are your running? I am running build 640.

    Are you sure this particular file can be imported if you select File->Import->OFX? Perhaps there is a problem with this particular file.

    Would you be willing to attach this file to this discussion such that I can see if the problem is with the file?

    Sincerely

    Ben Spencer

  2. 2 Posted by Lawrence Lile on 28 Jul, 2009 06:53 PM

    Lawrence Lile's Avatar

    Re: Associate with a file in Ubuntu Linux [Problems]

  3. 3 Posted by Ben Spencer on 28 Jul, 2009 06:57 PM

    Ben Spencer's Avatar

    Hi Lawrence

    your last post contains no text, would you please post again. Perhaps there is a problem with our server I am not sure.

    Ben

  4. 4 Posted by cmorf2000 on 30 Jul, 2009 05:07 PM

    cmorf2000's Avatar

    I am having the same problem ... actually seems part of a larger issue that MD isn't recognized as an application by either Ubuntu or the user interface. If I try to start MD from the desktop icons, get the message that "File type is unknown" or "No application is known for this file type." Have to go to actual folder to run application. Similarly, when I try to associate imported QFX files w/ an application in order to open them upon download (instead of saving), MD is not listed as an application in drop-down menu.

    I am new to Linux, so I'm sure that's part of the problem. Also still using trial version of MD, if that makes a difference.

    Cindy

  5. 5 Posted by cmorf2000 on 30 Jul, 2009 05:25 PM

    cmorf2000's Avatar

    Was able to associate imported QFX files w/ MD using Firefox's downloader. Still no luck w/ startup.
    Cindy

  6. 6 Posted by Ben Spencer on 30 Jul, 2009 09:35 PM

    Ben Spencer's Avatar

    Hi Cindy

    I successfully associated a QIF file with moneydance on ubuntu linux doing the following.

    Right click on your QIF file and select properties.

    Click the "Open With" tab.

    Selet what ever aplication is currently in the open with lis and click the remove button.

    Click the add button.

    Click "> Use custom command"

    Click the Brows button.

    Locate your moneydance folder. By default it is in usr/local/Moneydance though this might be different depending on how you installed moneydance.

    Inside your moneydance folder there is a file called "Moneydance" without the quotes it has not extension. This is the Moneydance startup script. Select this file and click ok.

    Click Add

    Now when you double click a qif file Moneydancee will run and present you with the qif import screen.

    Sincerely

    Ben Spencer

  7. 7 Posted by cmorf2000 on 13 Aug, 2009 04:05 PM

    cmorf2000's Avatar

    Ben,
    Sorry to be so late responding. I used your method above to solve the start-up issue and it worked perfectly. Thanks!
    Cindy

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac