Having trouble creating split transactions

Gandalf99's Avatar

Gandalf99

31 Jul, 2009 07:50 PM

My recollection is that in order to create a split transaction, you have to click on the category to open the list & "split" is at the top. I looked for instructions in help & did a search here & couldn't find anything about it. What's happening for me is that when I go into the category list, another category is appearing at the top of that list. You'll notice in the attached screen capture a line at the very top, as if there's a second window. There are up/down arrows but they don't work. In this screen capture I've actually scrolled to the bottom, but it doesn't make any difference.

  1. 1 Posted by Ben Spencer on 02 Aug, 2009 08:51 PM

    Ben Spencer's Avatar

    Hi Gandalf

    I haven't seen that particular problem before. What version of Moneydance are you using?

    Until we diagnose and fix the problem you can use the hot key command-L to open the split edit window for a transaction when you are entering the transaction.

    Sincerely

    Ben Spencer

  2. 2 Posted by Gandalf99 on 16 Aug, 2009 03:58 AM

    Gandalf99's Avatar

    Ben-

    Sorry to take so long to respond--life happens. I am using MD 2008r4 #641 (the latest, I believe). It happened again today. I went to an already existing xaxn & changed from one entry to a split. I then went to do another & instead of the "split" button at the top it showed one of my accounts. I quit MD & reloaded & could then enter the split. (I forgot to try the Command-L you suggested.)

  3. 3 Posted by Ben Spencer on 18 Aug, 2009 02:44 PM

    Ben Spencer's Avatar

    Hi

    Can you tell me which version of OS X you are running and which version of Java you are using. Also if you could post the contents of the error log that might be helpful. It is located here:

    ~/.moneydance/errlog.txt

    Thanks

    Ben Spencer

  4. 4 Posted by Gandalf99 on 18 Aug, 2009 03:55 PM

    Gandalf99's Avatar

    10.5.8, although I think I was running 10.5.7 when I first noticed the problem.
    The list of installed Java versions is attached; first on the list is 6, 64 bit version. According to "Java Preferences" apps start at the top when looking for a version.
    My error log is blank (0 bytes).

  5. 5 Posted by pabigot on 23 Aug, 2009 08:44 AM

    pabigot's Avatar

    This isn't just an OS X issue; I have the same problem on Vista 64. It seems to be consistent for a given transaction that it either does or does not display the split button. When the split button is missing, most (all?) of the time Ctrl-L does not work either (nothing pops up). In some accounts, the same issue arises with new transactions.

    Naturally, all my paycheck transactions imported from MS Money have inaccessible split information.

    MoneyDance 2008r4 (640), Java 1.6.0_13 on Vista 64-bit.

  6. 6 Posted by Ben Spencer on 23 Aug, 2009 01:20 PM

    Ben Spencer's Avatar

    Hi pabigot

    I am excited that you are able to consistently reproduce this problem as I have not been able to. Would you be willing to create a data file that demonstrates this problem and attach it to this discussion. Perhaps create a backup of you data file and delete all transactions and accounts from the backup except the transaction that causes this problem. If we are able to reproduce this problem we can step through the code with a debugger and see exactly what is causing it.

    Ben

  7. 7 Posted by pabigot on 23 Aug, 2009 03:32 PM

    pabigot's Avatar

    OK, attached is a reduced data file in MoneyDance XML format, which I've sanitized and made sure still exhibits the problems, at least in my environment. Go to the register in Brokerage. There are two transactions: one paycheck, one transfer. Neither of them display the "split" button in the categories pop-up, nor do they recognize Ctrl-L.

    While I was at it, I left in one of the downloaded transactions, which should match against the transfer, but doesn't. It's one day off; days apart is set to the default of 30.

  8. 8 Posted by Ben Spencer on 24 Aug, 2009 03:14 PM

    Ben Spencer's Avatar

    Hi pabigot and Gandalf

    pabigot in your example the transaction in question is a transfer coming from an investment account. I checked in with the developer about this and he said this:

    "one issue is that you can only split transactions in the register in which they were entered. That is a structural result of how MD works and isn't likely to change anytime soon. The other issue is that transactions in investment registers are already split: 1) security split, 2) transfer split, 3) fee split, 4) income/expense split It would be difficult to let the user edit the "additional splits", but I can see that possibly being a part of a future interface"

    So currently it is a limitation of the software that prevents users from adding additional splits to transfers coming from an investment account.

    Gandalf, I am not certain that you are experiencing the same thing. Can you confirm that the missing split button is for transfers from investment accounts in your situation?

    I am sorry for any inconvenience this is causing you.

    Sincerely

    Ben Spencer

  9. 9 Posted by Gandalf99 on 24 Aug, 2009 06:04 PM

    Gandalf99's Avatar

    Ben-

    You're right, it's not in investments; it's in checking account transactions. And I have not been able to identify what causes it. As I said previously, the last time it happened, it was ok for one transaction but the next time I tried to do a split, I couldn't. I wish I could be more help.

  10. 10 Posted by amk5667 on 28 Nov, 2009 10:09 AM

    amk5667's Avatar

    I have been having the same problem when trying to enter split transactions.
    While I am entering an item in a chequing account and want to split the transaction, the split button does not appear when I go into the category list. The category list looks as though there is one list appearing on top of another.
    By accident I found that the button is actually in the middle of the top row on the My Finances line in the category list which looks as though it is underneath another one. The split button is not visible until you click on it (even though you can't see it) then it appears as a blue button with Split... written on it.
    The split button will continue to show as long as I am in that account. When I switch accounts it will not be visible until go through the process of clicking on the invisible button.

  11. 11 Posted by Ben Spencer on 30 Nov, 2009 03:32 PM

    Ben Spencer's Avatar

    HI

    We suspect this is a bug is the version of java that ships with Snow Leopard. Until a fix is released you can use command-L to bring up the split window when you are editing a transaction.

    I am sorry for the inconvenience.

    Sincerely

    Ben Spencer

  12. 12 Posted by EK on 01 Dec, 2009 02:25 PM

    EK's Avatar

    I am using MD 2008r4 and OS Mac 10.6.2. When I open a split in the Checking Account, I can only input one line of data. In other words, I cannot split the data 2 or 3 ways as I can only input on one line.

    Thanks...EK

  13. 13 Posted by Ben Spencer on 04 Dec, 2009 06:55 PM

    Ben Spencer's Avatar

    To add more lines to the split click the '+' button at the bottom of the split window.

    I am sorry fo rthe confusion.

    Sincerely

    Ben Spencer

  14. 14 Posted by Elena Kissick on 04 Dec, 2009 07:21 PM

    Elena Kissick's Avatar

    Thanks...it worked.

  15. 15 Posted by diane.franklin on 01 Jan, 2010 03:57 AM

    diane.franklin's Avatar

    I just downloaded and paid for MD 2010 for the Mac. My OS is Snow Leopard 10.6.2. I am unable to get any arrows for split transactions.

    I have just downloaded the transactions from one of my credit cards and am trying to recategorize them correctly. For each transaction, I am right clicking, choosing Batch Transaction, then choosing Category. I then scroll to the category I want. But there are no arrows or no other ways to be able to record a category as a split transaction.

    If I click Command L sometimes I get nothing and other times I get a calculation screen that seems to have nothing to do with transaction categories. I also get a screen on the bottom asking me to accept a specific category with no option not to choose accept.

    This is a pretty big deficit of the program. Are there any workarounds, or am I doing something wrong in the process of trying to categorize transactions?

    Thanks,
    Diane

  16. 16 Posted by pabigot on 01 Jan, 2010 08:14 AM

    pabigot's Avatar

    On 12/31/2009 8:57 PM, Diane Franklin wrote:
    > // Add your reply above here
    >

  17. 17 Posted by fortepno on 07 Jan, 2010 06:43 PM

    fortepno's Avatar

    Mac OS 10.5.8

    May I throw a related problem into the mix? I AM able to see the split button and to add categories. But I can't assign dollar amounts to the splits. Am I missing something? It would be nice if there were substantial support in the "help" menu covering issues having to do with splits, since that's one of the primary ways in which one can individualize the program.

  18. 18 Posted by Diane Franklin on 07 Jan, 2010 06:51 PM

    Diane Franklin's Avatar

    Actually, I have figured this out. If you have already created your
    transaction, you can double click on it to open it. Then you click on the
    arrow beside the category field to see the Split button. Click on that, and
    it shows your transaction. Put in the first category of the split and the
    amount. Then choose New Split. Put in the second part of your transaction,
    choose a category and put in the correct amount. Then save the transaction.

    If you want to add a new split transaction, choose New Transaction, go to
    the category arrows next to the default category that has been assigned and
    choose Split Transaction. Then follow the above steps.

    Hope this helps.

    Diane

  19. 19 Posted by fortepno on 07 Jan, 2010 08:03 PM

    fortepno's Avatar

    I just emailed you. Thanks for the quick response. The problem is this: when I add a new split the program doesn't allow me to enter a dollar amount. I would assume I could do this under the "rate" column. But it's not possible. I tried the steps you suggested. In fact that's what I tried from the beginning.

    Since the rest of my email dealt with a subsequent but unrelated problem, I'll skip that here.

  20. 20 Posted by Diane Franklin on 07 Jan, 2010 08:13 PM

    Diane Franklin's Avatar

    Wish I could help further, but since I'm not having this problem, I don't
    know what to suggest. I put my dollar amount in the credit or debit column
    and it works fine.

    Maybe one of the Money Dance tech support people can help. I'm just a new
    user who is learning the program.

    DIane

  21. 21 Posted by fortepno on 07 Jan, 2010 11:00 PM

    fortepno's Avatar

    Need tech support (Mac OS 10.5.8)

    Have tried everything I can think of to add $ amounts to transaction splits. Only the first $ figure is enterable. Second and succeeding splits offer no possibility of entering a $ figure. The only way I can find to enter multiple payments to the same payee seems to be entering each as a separate transaction. What's the point of having split transactions? Please help.

  22. 22 Posted by Angie Rauscher on 21 Jan, 2010 09:29 PM

    Angie Rauscher's Avatar

    Fortnepno,

    To add second and succeeding splits, click the "New Split" button in the split window. Then you can edit the payment and deposit columns.

    Please let me know if I can be of further assistance, and thank you for your interest in Moneydance.

    Angie Rauscher
    Moneydance Support

  23. Angie Rauscher closed this discussion on 24 Jul, 2011 07:18 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac