Changing Current Price makes security disappear from Home Page

kwbear's Avatar

kwbear

01 Jun, 2011 08:38 PM

In a previous (closed) discussion in this Forum there are the words "Indeed the intended method of manually editing the current price of a security is as you described i.e. change the price in the "Current Price" field of the "Currency / Security History" window and then clicking "New"."

I have two money market funds for which Yahoo! lists the Yield but not the Price. MD 2011 downloads the yield as the current price. Try as I might I cannot correct the Current Price to the correct value - which is always $1.00

I find if I do as suggested in my first paragraph the listings of the MMFs in the lower right of the Home Page disappear. I can restore those MMFs by again using Quotes & Exchange Rates. If I do, the incorrect price (7-day yield) is then displayed as the current price. The ticker symbols of these two funds are SWVXX and SWSXX. If you want to check them out.

How can I change the current price in MD 2011?

  1. 1 Posted by -Kevin N. on 01 Jun, 2011 09:25 PM

    -Kevin N.'s Avatar

    Hi kwbear,
    First thing I would do is to 'uncheck' the two tickers for the MM funds in the Quotes & Exchange Rates Updater so that it no longer attempts to download the quotes for them. Since the NAV is alway $1.00 there is no need for them to be downloaded.

    Open the Currency / Security History form for the MM fund. Scroll down to the bottom entries. 'Remove' any entries that are not 1.00.
    Make sure that the number 1 is entered in the 'Current Price' field. If not, do so and click 'New'.

    Click the 'Edit' button in the upper right-hand corner. In the resulting 'Edit Security' form, make sure there is a checkmark next to 'Show on the Home Page'.

    Check to make sure the Price in the graph in the 'Securities Detail' for the MM fund is a straight line at 1.00.

    HTH -Kevin N.

  2. 2 Posted by kwbear on 01 Jun, 2011 10:07 PM

    kwbear's Avatar

    Hey Kevin:

    Once again, thanks for the fast response. I tried to follow your directions and as soon as I click "New" that MM Fund disappears from the"Stock Prices" listing on in the lower right on the Home Page. And, since the MMF isn't listed in the "Stock Prices" on lower right on the Home Page I can't tell if "Show on Home Page" is still checked. That disappearance is what has been vexing me all along.

  3. 3 Posted by -Kevin N. on 01 Jun, 2011 10:45 PM

    -Kevin N.'s Avatar

    Hi kwbear,
    Let's try this another way. From the Menu bar, click on Tools > Securities. In the resulting form, sleect the MM fund from the list and click 'Edit'. This will open the Currency / Security History form for the MM fund. Click the 'Edit' button in the upper right-hand corner of the Currency / Security History form. This will open the 'Edit Security' window for the MM fund. Make sure the checkbox is marked for 'Show on the Home Page'. See the attached screenshot.
    HTH -Kevin N.

  4. 4 Posted by -Kevin N. on 01 Jun, 2011 11:01 PM

    -Kevin N.'s Avatar

    Hi kwbear,
    I must apologize. Upon adding 'Stock Prices' to my Home Page, I can now reproduce the behavior that you describe.
    I'll try toying around with it some more and get back to you.
    HTH -Kevin N.

  5. 5 Posted by -Kevin N. on 01 Jun, 2011 11:53 PM

    -Kevin N.'s Avatar

    Hi kwbear,
    I will have to yield to the Moneydance Support Staff to resolve this issue.
    Sorry I couldn't help you with this.
    -Kevin N.

  6. 6 Posted by Ben Spencer on 02 Jun, 2011 02:41 PM

    Ben Spencer's Avatar

    This behaviour is actually intentional though perhaps misguided. The intention being not to show securities or currencies with a rate/price of 1 on the home page to save space. I have filed a bug ticket for the issue.

    Ben Spencer
    Moneydance Support

  7. System closed this discussion on 31 Mar, 2015 03:34 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

29 May, 2024 07:01 AM
29 May, 2024 06:26 AM
29 May, 2024 12:43 AM
28 May, 2024 11:59 PM
28 May, 2024 11:10 PM