Moneydance Current Price Problems

John's Avatar

John

16 Jul, 2011 04:55 AM

Today, 16 July 2011 I updated my prices by clicking on "Stock Quote Synchronizer" and received some greatly inflated stock and mutual fund prices. In the "Currency/Security History Window" for my Vanguard VFIAX the current price is 503147584, but in the lower part of this window where it says: Date, Price, Volume, High, Low, the correct price for Vanguard VFIAX is listed at $121.32.

How do I fix the current price so it displays the actual current price and not some 10 digit number?

I have Moneydance 2011 (791)

John

  1. 1 Posted by anthonywarnold on 16 Jul, 2011 09:11 PM

    anthonywarnold's Avatar

    I witnessed the same problem today and did not save my file so it would not be permanent. I re=opened the file and download prices again. The stocks with erroneous prices were not consistent with the first download.

    This could be a Yahoo problem and not the app, but the user cannot tell. I did check Yahoo website quotes and prices were correct. I am running MD 2011 791.

    The Stock Quote Synchronizer application downloaded prices correctly the morning of 7/15.

  2. 2 Posted by juliana on 16 Jul, 2011 09:40 PM

    juliana's Avatar

    Same problem this morning. Manually entered correct prices and it looks ok now. will not use stock quote synchronizer till I know it's fixed.

  3. 3 Posted by Bruce on 16 Jul, 2011 10:04 PM

    Bruce's Avatar

    I encountered a similar problem, today. Two stocks came across (after sync) with wildly incorrect Current Values. When checking the History on these stock in MD, the share prices appear to be ok, but there are very large numbers listed in the Volume fields (previously, the Volume field only indicated zero). The program appears to be using the Volume figure to multiply against the number of shares, rather than the actual Share Price. In History, MD will not allow me to remove the Volume numbers. I am using Moneydance 2011 (790). Unfortunately, I saved the file before noticing this and now seem to be stuck with these incorrect numbers. I cannot figure out how to remove them.

    Update: after going back into MD and manually entering the Current Share Price (via History) for July 15, the Total Current Value becomes correct. However, the Volume numbers still appear in the History window and there does not seem to be anything that can be done about that.

  4. 4 Posted by Jessica Little on 16 Jul, 2011 11:28 PM

    Jessica Little's Avatar

    Hi John,

    Sorry for the trouble. After a little bit of testing, it looks like Yahoo is randomly returning incorrect results for some stocks. We're working on figuring out what's wrong and fixing it. We've disabled further downloads of the extension until then. I would recommend that anyone currently using the extension disable it until we can release an update. We'll try to get this resolved as quickly as possible.

    Again, I'm very sorry for the inconvenience. When we have more information, we'll update everyone on this thread: http://help.infinitekind.com/discussions/md2010-beta/227-stock-pric...

    Jessica Little
    Moneydance Support

  5. 5 Posted by anthonywarnold on 17 Jul, 2011 03:14 PM

    anthonywarnold's Avatar

    Most software companies do not even offer this type of support, well alone such quick and accurate responses.

    MD and InfiniteKind are far superior in their support system. Thx to all of you.

    Also, when problems occur with MD software (sometimes not their fault - ref Yahoo here), there is always an easy work around. I used Quicken for about 15 years. When things went wrong, there was rarely an easy work around or correction.

    Speaks volume about the underlying, simplicity first, design methods of the MD developers. I have a much praise for the MD developers as a former developer of code.

    Tony

  6. 6 Posted by pfkalina on 17 Jul, 2011 03:44 PM

    pfkalina's Avatar

    For the record, I just noticed this problem too. I think the quotes updater runs upon start up, however I noticed a problem that may be related to this:
    When I look at the security history Current Price field, it doesn't show the LATEST price. I can't say this is the case with all my securities, but the few I checked had this problem. As a result, the account value total was inaccurate. When I ran the synchronizer manually, I noticed the inflated values on two of my accounts, as described above. (Not all the securities but just a few had huge inaccurate values).

    Count me in on Tony's comments. Thanks guys and gals.

  7. 7 Posted by -Kevin N. on 17 Jul, 2011 04:13 PM

    -Kevin N.'s Avatar

    Hi pfkalina,

    Until the issue is resolved, as a work-around, you might want to try disconnecting your machine from the internet (so the prices can't update). Open MD, turn off the option for the updater to run at start up, close MD, Save the changes and then reconnect to the internet.

    Here, here. Tony.

    HTH -Kevin N.

  8. 8 Posted by Egil on 23 Jul, 2011 01:27 AM

    Egil's Avatar

    I'm having the same problem. Joining up now so I can get Jessica's update(s).

  9. 9 Posted by briandbrennan on 23 Jul, 2011 11:06 AM

    briandbrennan's Avatar

    Hello,
    I'm having a similar problem. I've reverted to a backup and disabled updating.

    Thanks for the help.
    Brian

  10. 10 Posted by anthonywarnold on 23 Jul, 2011 11:30 PM

    anthonywarnold's Avatar

    Any feedback from the MD team on when this problem will be corrected. Updating prices manually in MD is not the the most efficient process, especially if you have a lot of different symbols to update. One thing that might be added to the improvement list.

    Thx,

    Tony

  11. 11 Posted by -Kevin N. on 23 Jul, 2011 11:39 PM

    -Kevin N.'s Avatar

    Hi All,
    Are you all using the latest build of the Quotes & Exchange Rates extension? (Currently ver. 73)
    From what I understand the new version scrubs the errant quotes coming out of Yahoo Finance.
    I'm finding that due to the recent problems at Yahoo Finance that I need to run the new Q&ER extension multiple times at the end of the market in order to get a complete update of stock quotes.
    HTH -Kevin N.

  12. 12 Posted by -Kevin N. on 24 Jul, 2011 12:17 AM

    -Kevin N.'s Avatar

    Hi anthonywarnold,

    Any feedback from the MD team on when this problem will be corrected.

    Look to post # 32 from MD Support Staffer Jessica Little from the following thread:
    http://help.infinitekind.com/discussions/md2010-beta/227-stock-pric...
    HTH -Kevin N.

  13. 13 Posted by anthonywarnold on 24 Jul, 2011 02:10 AM

    anthonywarnold's Avatar

    thanks for the upgrade to v73 nudge. Had not done that. Definitely corrected the crazy price and share number issue.

  14. 14 Posted by jendahl on 25 Jul, 2011 01:19 PM

    jendahl's Avatar

    I'm seeing this problem as well, upgrade to v73 of Quotes & Exchange Rates, and there has been no change for me.

    --> John

  15. 15 Posted by Jessica Little on 28 Jul, 2011 01:22 PM

    Jessica Little's Avatar

    Hi All,

    It looks like Yahoo has fixed the problem on their end finally. A number of folks have said this is working for them again. Can you all confirm?

    Jessica Little
    Moneydance Support

  16. 16 Posted by -Kevin N. on 28 Jul, 2011 01:47 PM

    -Kevin N.'s Avatar

    Hi Jessica,

    Can you all confirm?

    Zero errors for the last few days. Phew!
    -Kevin N.

  17. 17 Posted by jendahl on 28 Jul, 2011 02:25 PM

    jendahl's Avatar

    Jessica,

    Seems to be working properly for me now as well. Too bad, I sort of liked having an account worth in the hundreds of billions!

    Maybe someday.... :-)

    --> John

  18. 18 Posted by anthonywarnold on 30 Jul, 2011 08:19 PM

    anthonywarnold's Avatar

    It does appear to be working but on my home page display many securities or
    money funds have excessively large number of decimal places showing. This
    did not occur until the problems with the stock updater. I don't know how
    to correct this issue either.

    Tony

    On Thu, Jul 28, 2011 at 8:22 AM, Jessica Little <
    [email blocked]> wrote:

  19. 19 Posted by Egil on 30 Jul, 2011 08:31 PM

    Egil's Avatar

    Sorry to check in late (I only have time on weekends) but mine is also back to normal. For a while there I thought the Nigerian lottery had invaded me.

  20. 20 Posted by Noname on 30 Jul, 2011 10:33 PM

    Noname's Avatar

    I am still getting 1 error the first time the update runs. Unfortunately, because I have the extension set to run when I open the program I am unable to determine which security has the error. If I run the extension a second time I get no errors. I tried running in test mode but no errors show there either once the extension has run at program's open.

  21. 21 Posted by Julia and Sheld... on 30 Jul, 2011 10:41 PM

    Julia and Sheldon Borg's Avatar

    why don't you try to set it up not to update on start up- then do it
    manually?

  22. System closed this discussion on 31 Mar, 2015 03:36 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac