Moneydance freezes on entering investment transactions

helen.m.simpson's Avatar


04 Aug, 2011 04:50 PM

I use Moneydance 2010 with Windows 7 64-bit. It was fine until a few days ago but now it freezes almost every time I try enter an investment transaction into the register and I have to close it down using Task Manager and restart. Occasionally I manage to enter one transaction (but it does not ring) and then the second one freezes the system - usually I then have to restart the computer before it works again.

  1. 1 Posted by Ben Spencer on 05 Aug, 2011 02:39 AM

    Ben Spencer's Avatar

    Can you select Help->Console Window... and copy and paste the output to this discussion.

    How large is your data file? You can see this if you look at the file in a file browser.

    If you wait while does the transaction eventually enter or does it never enter.

    Ben Spencer
    Moneydance Support

  2. 2 Posted by Helen Simpson on 05 Aug, 2011 08:29 AM

    Helen Simpson's Avatar

    Hi, thanks for your response. The data file (on HD) is 562 kb and the console window is
    Starting Moneydance 2010r3 (751)
    Settings Folder: C:\Users\Helen.moneydance
    OS: Windows 7 6.1 x86
    Java: 1.6.0_26 (Sun Microsystems Inc.)

    I went to try again to see if it eventually would enter, and perversely it is working OK this morning! I'd still be glad of any advice in case the problem recurs.


  3. 3 Posted by Ben Spencer on 05 Aug, 2011 08:44 AM

    Ben Spencer's Avatar

    Hi Helen

    Your current license key will give you a free upgrade to MD2011. Please try downloading MD2011 from the link at the top of and let me know if the problem persists.

    Ben Spencer
    Moneydance Support

  4. 4 Posted by Sal on 06 Aug, 2011 03:03 AM

    Sal's Avatar

    I have the same exact problem except I'm entering banking transactions. The problem comes and goes, but it is a huge time killer to keep killing the Moneydance process and then restarting only for it to freeze up again. It's actually happening to me right now so I'm going to reboot to see if that helps.

    Starting Moneydance 2010r3 (757)
    Settings Folder: C:\Users\SRVolpe.moneydance
    OS: Windows 7 6.1 x86
    Java: 1.6.0_26 (Sun Microsystems Inc.)

  5. 5 Posted by Sal on 06 Aug, 2011 03:30 AM

    Sal's Avatar

    Rebooting did not fix anything. I had 5 transactions to enter and had to enter a transaction, save the file, close Moneydance, reopen Moneydance and repeat 4 more times. Incredibly frustrating. Between researching this issue and having to enter 5 measly transactions, I've been at this for an hour now.

    I've been using Moneydance for over 2 years now (a convert from Quicken) and aside from this problem, I've been very pleased with the software.

  6. 6 Posted by Ben Spencer on 06 Aug, 2011 08:29 AM

    Ben Spencer's Avatar


    Do you have the net worth graph enabled? If so please try turning it off. Select View->Hide Status Graph to turn it off.

    If that doesn't help can you tell me how large you data file is?

    Ben Spencer
    Moneydance Support

  7. 7 Posted by Sal Volpe on 06 Aug, 2011 03:19 PM

    Sal Volpe's Avatar


    I did have View | Show Budget Status selected, but not View |Show Net Worth
    Graph. As per your instruction I have now selected View | Hide Status Graph.
    The problem remains.

    Everything was working flawlessly Thursday night, but on Friday and now
    today (Saturday), Moneydance completely freezes up upon entering a second
    consecutive transaction. My only recourse is to kill the Moneydance process
    from the task manager. Curiously enough, as the original poster reported,
    after entering the first transaction, that action does not trigger the
    "ring" that signifies a successful entry. So if you don't save the file
    before attempting to enter the second transaction, you lose both
    transactions. So it seems like the first one is not being successfully
    committed, but the software doesn't crash until attempting a second

    My data file is 1.96 MB (Windows reports 2,011 KB).

    I have become very dependent on Moneydance to manage my family's finances so
    it's very important that this be resolved as quickly as possible. Thank you
    for your attention in this matter and always, your quick responses.

    Sal Volpe

  8. 8 Posted by -Kevin N. on 06 Aug, 2011 03:26 PM

    -Kevin N.'s Avatar

    Hi Sal,
    Just a hunch. Have you tried turning off the 'ring'?
    To do so, File > Preferences > General tab > deselect 'Beep when Transactions Change'.
    HTH -Kevin N.

  9. 9 Posted by Sal Volpe on 06 Aug, 2011 03:54 PM

    Sal Volpe's Avatar


    Unbelievable! Your hunch was dead on right! As soon as I disabled the beep,
    I was able to enter a number of test transactions without MoneyDance
    crashing. When I re-enabled the beep, MD crashed after attempting to enter
    the 2nd transaction. Disabling the beep once again, I was again able to
    enter several transactions successfully without MD freezing up. Thank you
    very much for your help in this matter.

    I do like the beep, because it nice to have an audible confirmation, but if
    it's going to cause MD to crash, then I'll leave it disabled until the issue
    is fixed. Is a fix planned for this problem?

    Sal Volpe

  10. 10 Posted by -Kevin N. on 06 Aug, 2011 05:02 PM

    -Kevin N.'s Avatar

    Hi Sal,
    Glad to hear that you're up and running. It's always nice when it's an easy fix.
    I can't say as to when a permanent fix would be in place as I am but a user like yourself.
    Hopefully Ben Spencer will read through the thread and pick up on it.
    -Kevin N.

  11. 11 Posted by Ben Spencer on 07 Aug, 2011 01:04 AM

    Ben Spencer's Avatar

    Select Help->Console WIndow... let me know the version of Java you are running.

    It might be that getting the latest version of Java fixes the problem.

    Ben Spencer
    Moneydance Support

  12. 12 Posted by Jim D on 07 Aug, 2011 02:07 PM

    Jim D's Avatar

    Don't have the freezing problem but now when I try to enter a Buy transaction for a security the Security/Category column auto completes with a another security that starts with the same letter. Nothing I do overrides it. When I hit the up/down arrows I get a list that does not include the security I'm trying to enter. However if I go to Tools>Securities the one I'm trying to enter is listed there. I turned off Auto complete in preferences and that doesn't help. Using MAC OS X 10.6.8

  13. 13 Posted by jim D on 07 Aug, 2011 02:24 PM

    jim D's Avatar

    OK. Now I can't delete a transaction. No matter how many times I highlight-hit delete and answer yes it doesn't go away. Maybe this is the freezing problem everyone else is talking about.

  14. 14 Posted by -Kevin N. on 07 Aug, 2011 02:49 PM

    -Kevin N.'s Avatar

    Hi Jim,
    Having a security listed under Tools > Securities does not necessarily mean that the security is included as an investment in a particular account, it must be specifically added to the account.
    To add a security to an investment account, go to the 'Securities Detail' view of the account. In the upper right-hand quadrant, click the 'Add Security' button. In the resuting form, select the security from the drop-down list. Click OK.
    This will add the security to the investment account. You should now be able select the security from the drop-down list of txns in the register.
    For the 'stuck' txn, try restarting MD. If it asks if you want to save the changes click NO.
    If you have the 'kerching' sound effect enabled, disable it. File > Preferences > General tab 'Beep when Transactions Change'.
    HTH -Kevin N.

  15. 15 Posted by Jim D on 07 Aug, 2011 03:02 PM

    Jim D's Avatar

    I see how it works now. That's exactly what happened. That particular security was new to that account even though it worked for me in another account. All is good.
    The other problem seemed to go away too. Back on track. Once again, the quick response is great. One reason I switched to MD.

  16. Ben Spencer closed this discussion on 08 Aug, 2011 09:34 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac