reflecting new security purchase in investment account

fredtung's Avatar


09 Aug, 2011 07:55 PM

I just bought shares in a company I had not owned before. Everything looks great in the register, but the numbers in Portfolio and Securities Detail are just plan wrong!

1000 shares at a $5 price with a $7 fee. So under Amount in the register, it correctly shows 5,007, and below that, the fee of 7 (in gray).

But when I look at security detail,
(a) the mini-register shows the same purchase twice; and (b) on the right side, it shows 1001.4 shares, a current value of 5,007.00, cost basis of 5,021.00, and a % change of -0.27. These right-side figures also show up in Portfolio View.

I'm mystified.

  1. 1 Posted by Jon Hoover on 09 Aug, 2011 08:18 PM

    Jon Hoover's Avatar

    Hi Fred,
    That does sound a bit odd. Could we trouble you by asking for a screenshot of your portfolio view, register, and securities detail? I think that will help us understand a bit better what may be up.
    Jon Hoover, Moneydance Support

  2. 2 Posted by -Kevin N. on 09 Aug, 2011 08:28 PM

    -Kevin N.'s Avatar

    Hi Fred,
    I created an Investment Account with a $5007.00 initial balance.
    I then created a Buy order txn. for 1000 shares XYZ @ 5.00 with a 7.00 commission
    I've attached two screenshots to show how it should look.
    HTH -Kevin N.

  3. 3 Posted by -Kevin N. on 09 Aug, 2011 08:34 PM

    -Kevin N.'s Avatar

    Hi Fred,
    I see that Jon Hoover has already replied to your post but since I've created my screenshots I figured I'll throw them up for you.

    I created an Investment Account with a $5007.00 initial balance.
    I then created a Buy txn for 1000 shares of XYZ @ $5.00 a share with a $7.00 commission.

    HTH -Kevin N.

  4. 4 Posted by fredtung on 09 Aug, 2011 09:02 PM

    fredtung's Avatar

    On Tue, Aug 9, 2011 at 4:33 PM, kmnugent <
    [email blocked]> wrote:

    Hi Guys:

    Thanks for jumping on this so quickly. I've attached 3 screen shots. It's
    the last transaction in the register.

    Best, Fred

  5. 5 Posted by Jon Hoover on 09 Aug, 2011 09:19 PM

    Jon Hoover's Avatar

    Wow, that's a bit weird!
    I know this doesn't really solve things but could you try deleting all that and seeing what happens?
    I'm curious, if you delete the transaction in the register view do the double transactions disappear from the securities detail register? If not, delete them both.
    So after you delete everything and re-enter it, does this problem still happen?
    Jon Hoover, Moneydance Support

  6. 6 Posted by fredtung on 09 Aug, 2011 09:34 PM

    fredtung's Avatar

    On Tue, Aug 9, 2011 at 5:18 PM, Jon Hoover <
    [email blocked]> wrote:

    Hi Jon:

    If I delete from the register, it also disappears from the Portfolio View
    and Securities Detail, though on the upper right box of Securities Detail,
    the security still exists, indicating the original price ($5), and all the
    rest zeroes.

    Also if I undo the register delete that I just performed, it shows back up
    in the register, and when I hit return (so I hear the cash register sound),
    the Register is fine, but the new security doesn't show up in the Portfolio
    view, it doesn't change the upper right box in Securities Detail, but the
    double transactions come back in the mini-register at the upper left of
    Securities Detail.

    Also if I try to delete one of the 2 identical transactions that show in the
    mini-register with Securities Detail, they both go away, as does the
    original register entry.

    Thanks for your help.

    Best, Fred

  7. 7 Posted by -Kevin N. on 09 Aug, 2011 10:59 PM

    -Kevin N.'s Avatar

    Hi Fred,
    Is the issue resolved?
    If not try deleting the txn, then close your data file and Save the changes. This way the txn is no longer in the 'Undo' memory.
    Then open Moneydane and re-enter the txn.
    This is the first time I've ever seen this happen.
    Let us know how it works out. OK?
    -Kevin N.

  8. 8 Posted by fredtung on 09 Aug, 2011 11:45 PM

    fredtung's Avatar

    On Tue, Aug 9, 2011 at 6:58 PM, kmnugent <
    [email blocked]> wrote:

    It worked! When in doubt, unplug it!


  9. 9 Posted by -Kevin N. on 10 Aug, 2011 12:04 AM

    -Kevin N.'s Avatar

    Hi Fred,
    I'm glad to hear that it worked out.
    As for why it happened I can not say.
    There was another user who was experiencing some odd behavior which was resolved after I suggested that he disable the 'kerching' sound effect. His was an issue of the program freezing. If your issue occurs again it might be worth a shot.
    If you want to turn off the sound effect, go to File > Preferences > General tab, de-select 'Beep when Transactions Change'.
    HTH -Kevin N.

  10. 10 Posted by fredtung on 10 Aug, 2011 02:08 AM

    fredtung's Avatar

    Super! Thanks again.

  11. Tom Freeman closed this discussion on 11 Aug, 2011 08:28 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac