Lockups in 2011r2 for Linux

Bob's Avatar


30 Oct, 2011 09:53 PM

I updated yesterday to the new Linux 2011r2 version with java version 1.6.0_23, OpenJDK 64-bit server VM 20.0-b11, mixed mode, OpenJDK runtime environment (IcedTea6 1.11pre) 6b23~pre10-0ubuntu5 and have a serious issue. The program locks up regularly. Here's how to duplicate on the transaction screen:

1) select a transaction that needs to be reconciled
2) The unconfirmed-transaction-actions panel opens
3) Now change the check Description and Category manually. It doesn't seem to matter whether you use a memorized description or a new one.
4) Tab to another field. It doesn't consistently matter what field that you end in.
5) Hit Enter to accept the changes made
6) The program locks up.

The only way out at this point is to End the program abnormally with the System Monitor or from the terminal. If you end the program right away, all previous session changes are lost. If you wait long enough, Moneydance autosaves the change to that transaction.

This happens constantly. Reconciling takes forever. I'm tempted to return to the previous version with which worked fine, but I thought that I'd try this forum first. Thanks for any help that you can provide.

  1. 1 Posted by james f on 31 Oct, 2011 05:27 AM

    james f's Avatar

    You need to switch from OpenJDK to Oracle's JDK.
    You can find the official release of JDK 6, 64 bit for Linux at the following:

  2. 2 Posted by Bob on 31 Oct, 2011 02:55 PM

    Bob's Avatar

    Thank you, james. I tested it by reconciling a different account and it seems to have worked. I found a great HOWTO for installing Oracle's JDK 7 in 64-bit Ubuntu at: http://www.webupd8.org/2011/09/how-to-install-oracle-java-7-jdk-in.... . I didn't use the repository, but downloaded and ran the script manually. Worked like a charm. Thanks again!

  3. Jessica Little closed this discussion on 31 Oct, 2011 03:05 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac