Text File Importer failing with a Java error

bonnie's Avatar


11 Jan, 2012 05:37 PM

I was hoping to finish my Moneydance evaluation this week. From testing results to-date I've decided to do my accounting in two separate databases. I decided not to import much Quicken data, instead will load the past few years of banking data from my credit union as CSV files using Text File Importer.

I finished testing the first database file I had been working on this week. Extension->Text File Importer working fine. When I went to run test loads on a newly created MD database, Text File Importer did nothing -- no import, no messages.-

Tried removing Text File Importer and reinstalling. Now when invoking Text File Importer, it does not start up, receiving an "Error" message box "java.lang.NullPointerException".

Tried uninstalling and reinstalling Moneydance. Text File Importer is permanently broken with the "java.lang.NullPointerException" error.

Reproducible - Hoping to finish my testing, and also checking to see if I could reproduce the error, I did a new install on my Windows XP Home laptop. Created a new MD database file, installed the extension "Text File Importer". Same problem, Text File
Importer does not start, receiving same message of "java.lang.NullPointerException"

I was planning on using the Text File Importer for uploading most of my data, along with Find and Replace, as then I had complete control of assigning categories.

Is it possible to download a different (or older) version of Text File Importer?

Windows XP Pro, Moneydance2011.791, Java 6 update 23, with extensions "Find and Replace" and "Text File Importer" at current versions.

  1. 1 Posted by -Kevin N. on 11 Jan, 2012 06:04 PM

    -Kevin N.'s Avatar

    Hi bonnie,
    For starters, I would first update to the latest build of Moneydance. (currently build 803)
    You can download the installation file from here:
    If that doesn't resolve the issue, post back and we can try some other things.
    HTH -Kevin N.

  2. 2 Posted by -Kevin N. on 11 Jan, 2012 06:30 PM

    -Kevin N.'s Avatar

    Hi bonnie,
    I've been able to reproduce your "java.lang.NullPointerException" problem by installing the latest ilk (version 8) of the Text File Importer.

    I've attached version 7 of the Text File Importer.

    When you download the txtimport.mxt file, it may or may not download as txtimport.zip. If it does download as a .zip file, DO NOT unzip it, just rename it txtimport.mxt.

    To install it, run the Extensions Manger in Moneydance but clcik the 'Add From File' button at the bottom of the Manager. Navagate to the txtimport.mxt file that you just downloaded.

    HTH -Kevin N.

  3. 3 Posted by -Kevin N. on 11 Jan, 2012 08:03 PM

    -Kevin N.'s Avatar

    Hi bonnie,
    I've attached a v.8 of the Text File Importer that works.
    Follow the same installation instructions as for v.7
    HTH -Kevin N.

  4. 4 Posted by bonnie on 11 Jan, 2012 08:45 PM

    bonnie's Avatar

    Hello Kevin,

    I updated Moneydance to the newest version (build 803). Added your most
    recent v8 version of Text File Importer. It runs OK in that it asks all
    the questions, but it fails to load anything.

    I then downloaded v7 of Text File Importer and it works fine :-)

    Thanks, Bonnie

    p.s. If you are working on v8 of Text File Importer, it would be nice if
    you could default "Fields" 9-15 to "Ignore" instead of "Date". Every
    time I run Text File Importer I'm forced to make Fields 9-15=Ignore.
    I've learned the hard way you never want any of these fields = Date when
    they SHOULD be ignored.

  5. 5 Posted by -Kevin N. on 11 Jan, 2012 09:48 PM

    -Kevin N.'s Avatar

    Hi bonnie,
    If I understand you correctly, unless you actually need fields 9-15, they can be removed from the Text File Importer by clicking the 'Less Fields' button on the 'Fields' screen.
    HTH -Kevin N.

  6. 6 Posted by bonnie on 11 Jan, 2012 10:40 PM

    bonnie's Avatar

    This works, I didn't notice when you click on "Less Fields" only one
    field goes away at a time. But 1/2 dozen quick clicks and then they're
    gone. Thanks, Bonnie

  7. 7 Posted by -Kevin N. on 11 Jan, 2012 11:27 PM

    -Kevin N.'s Avatar

    Hi Bonnie,
    You're welcome.
    I created a bug report for the original java.lang.NullPointerException in the Bugs forum.
    You can close this thread if you want.
    -Kevin N.

  8. bonnie closed this discussion on 11 Jan, 2012 11:35 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac