Moneydance will not open and equities update doesnt work

tmstiles's Avatar


11 Jul, 2018 12:46 PM

Its been months now and apart from one or two responses in that time i get almost no feedback. Using the quotes and exchange rates addon I can't get the rates to update properly. It is downloading JSE data and it stores the current day's prices correctly but then forces all the history prices to 1/100th of the correct value. If i change the multiple i get it reversed. I was told awhile ago to try a test build and it never worked, being trying every test build since that and it still doesn't work.
In addition to this problem, i cannot get any build after 2017.7.1682 to work, i have tried every version but it will start up, tell me my file is in a shared drive (dropbox) then ask me for my password and then it disappears, nothing on the task bar, however in the task manager, it does show up, and uses a lot of resources. but other than that nothing shows up.

I reinstall 2017.7.1682 and at least i can get access again.
Any suggestions

  1. 1 Posted by derekkent23 on 11 Jul, 2018 01:57 PM

    derekkent23's Avatar

    I am not support staff, just a user.

    Let’s, take this one step at a time.

    The first thing to do is move your data set from Dropbox to the data set default location on your hard drive. In Moneydance click on HELP – SHOW DOCUMENT FOLDER. This should open your file finder in the default data set location. Close Moneydance. move your data set from Dropbox to the default location. Your data set is a folder not a file and contains other folders and file. Its naming convention is yourdatasetname.moneydance.

    Open Moneydance, it should open in the Welcome to Moneydance window with your data set listed on the right-hand side. Check all your accounts look OK. Do a FILE - EXPORT BACKUP. I recommend using Dropbox as the backup location for this and automatic backup under FILE – PREFERENCES – BACKUP in case your hard drive fails.

    Now close Moneydance update Moneydance to latest build.

    Report back and if all is well we can look at your next problem. For that can you confirm the build of the Q & ER extension you are running under EXTENSIONS – MANAGE EXTENSIONS. When you talk about JSE (Johannesburg Stock Exchange) is your base currency the rand (ZAR) and if so which currency exchange rates are you looking for GBP, USD, EUR?

    Hope this helps

  2. 2 Posted by tmstiles on 12 Jul, 2018 09:20 AM

    tmstiles's Avatar

    Hi, Thanks for the response,

    I have tried that, its is now on the local drive, however the problem persists, i update to build 1687 and the ones after 1682 and it installs just fine. However when i click to run it asks for my password, i put that in and then the screen disappears. in Task manager i see it listed there for a while using 80-100% CPU, then after a while it settles down to 0% CPU and about 1Gb memory use. but will not show up in the task bar or let me alt tab to it.

  3. 3 Posted by derekkent23 on 12 Jul, 2018 10:05 AM

    derekkent23's Avatar

    I am not support staff, just a user.

    When it asks for your password, click Cancel.
    This should open the Welcome to Moneydance window. Click "Open other" and navigate to your data set you moved from Dropbox to your hard drive and click on that.

    If this still does not work the next step is to find and restore a backup

    Hope this helps

  4. 4 Posted by Billy on 16 Sep, 2018 03:58 AM

    Billy's Avatar

    There is definitely a problem with Moneydance updates. The last update that works on my Windows 7, 64bit, computer is Version 2017.7.1 (1671). Updates since that version will not load the existing database. And as a result I have reverted back to this version. As for the security price updates, I can make them work by playing around with the source of the update and not just using the default.

  5. 5 Posted by sth on 16 Sep, 2018 09:18 PM

    sth's Avatar

    @Billy, this seems sort of unrelated to this thread. if you have a new problem, you should probably start a thread instead of trying to resurrect a discussion on another topic from a while ago.

  6. System closed this discussion on 16 Dec, 2018 09:20 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac