Security History: price updates via extensions are not saved to history

joe.bachofen's Avatar


29 Jul, 2018 06:29 PM

I am running MoneyDance 2017.8 on Linux Mint 17.3 Rosa.
Security History and the two extensions that update it were working and changes were saved until I updated from MoneyDance 2017.7; it appears the updates to "Quotes and Exchange Rates" from either of the two extensions are no longer being saved when I close my file.

I installed 2017.8 on 25 July 2018 and none of the daily updates since then have been saved.
The attached file shows the simple test I ran to verify the problem which consisted of opening a file, updating it, closing it and opening it again. The update worked fine but the changes were not saved.

My workaround is simple; I run the update extension each time I open my file but I would prefer that the changes were saved.
Let me know how I can help and thank you for your help in the past.

  1. 1 Posted by derekkent23 on 29 Jul, 2018 07:52 PM

    derekkent23's Avatar

    I am not support staff, just a user.

    If you manually add exchange rates for the 25 and 26 and manually update the current price, close and open Moneydance are they remembered then?

  2. 2 Posted by joe.bachofen on 30 Jul, 2018 05:22 PM

    joe.bachofen's Avatar

    Surprisingly, a manual update of each stock price (with phony prices since I don't know the real ones) followed by a real update using the extensions DID save the stock prices as it should when the file was closed, then, reopened. This was done over the weekend when markets were closed.

    Today (Monday 30 July) an update using the extension was NOT saved when the file was closed and reopened. Manual entry of the stock prices followed by an update using the extension FAILED to store the updated prices when the file was closed and reopened.

    A simple test verified the problem:
    1.1. I recorded the time stamp on files "processed.dct" and "trunk" while closed.
    1.2. I opened the file, ran the stock update extension, then, closed the file.
    1.3. I recorded the time stamp on files "processed.dct" and "trunk".
         NO CHANGE: the stock price update was not recorded.
    2.1 I recorded the time stamp on files "processed.dct" and "trunk" while closed.
    2.2 I opened the file, changed a single transaction in one account, then, closed.
    2.3 I recorded the time stamp on files "processed.dct" and "trunk" while closed.
         Time stamp changed on both files as expected.
    See attached jpeg.

    I can only speculate why a manual price entry followed by the extension update while the markets are closed IS saved and I don't care; that is NOT the way it used to work and it is NOT acceptable but I will use it as workaround until the problem is solved.

  3. 3 Posted by derekkent23 on 30 Jul, 2018 05:57 PM

    derekkent23's Avatar

    I am not support staff, just a user.

    Strange behaviour.

    I no longer use the Q & ER to update security prices or exchange rates, for me it does not give good results, so have not seem your problem.

    I use a free stand-alone program to obtain prices and then import them into Moneydance.

    If you want to try this method see post 236 in this thread

    If you do try it and have any problems just post.

    Hope this help.

  4. 4 Posted by ralph on 03 Aug, 2018 06:12 AM

    ralph's Avatar

    I am also seeing this problem.

    I upgraded via apple app store to version 2017.8 about a week ago, since that time neither Stock prices nor exchange rate data that I enter manually daily has been stored.

    The entries prior to the upgrade have been stored and are still visible.

  5. 5 Posted by ralph on 04 Aug, 2018 06:46 AM

    ralph's Avatar

    If no-one from infinite kind is looking at this I need help to revert back to the previous version of moneydance for OSX. Ive already lost a over a weeks worth of data and im getting tired of having to record the exchange rates on little pieces of paper.

    It is a simple issue to reproduce. Response with a time scale to fix the issue please.

  6. 6 Posted by eric.griffith on 06 Aug, 2018 11:30 PM

    eric.griffith's Avatar

    I'm having the same issue since updating to 2017.8.

  7. 7 Posted by derekkent23 on 07 Aug, 2018 09:25 AM

    derekkent23's Avatar

    I am not support staff, just a user.

    Older builds of 2017 can be found at

    If that helps

  8. 8 Posted by ralph on 07 Aug, 2018 10:45 AM

    ralph's Avatar

    Thanks for trying to help derekkent23 but as I purchased my copy through the apple App Store, and therefore update via that mechanism, its not easy to update (or even revert) via a direct download. None of the files listed on the URL you indicated see to be targeted to OSX.

    I am very surprised that no-one from infinite kind has responded on this thread my previous queries have been answered very rapidly. Maybe they're all on holiday?

  9. 9 Posted by derekkent23 on 07 Aug, 2018 11:06 AM

    derekkent23's Avatar

    I am not support staff, just a user

    I know this does not help you as you purchased through Apply but I see a file called in the 2017.7.1_1671 directory. Not being a Mac user I can be sure this is the download that would be needed.

    Sorry I could not really help.

  10. 10 Posted by ralph on 07 Aug, 2018 12:22 PM

    ralph's Avatar

    You were right the ‘.zip’ version was for an OSX machine but, as expected it comes up in demo mode. buying through the app store doesn’t get you a registration number so I’m stuck until a new corrected version is released.

    Thanks for trying to help

  11. 11 Posted by derekkent23 on 07 Aug, 2018 01:30 PM

    derekkent23's Avatar

    I am not support staff, just a user

    Sorry that did not help.

    When 2019 is available end 2018 start 2019 if you want to upgrade probably better to purchase direct. Next major upgrade free, from then on 50% discount. Preview version available to.

  12. 12 Posted by eric.griffith on 07 Aug, 2018 01:45 PM

    eric.griffith's Avatar

    This is a pretty big bug. I would hope we're not stuck with this until the
    next major release.

  13. 13 Posted by MarciaG on 14 Aug, 2018 09:30 PM

    MarciaG's Avatar

    I am also seeing this issue.

  14. 14 Posted by ralph on 15 Aug, 2018 06:47 AM

    ralph's Avatar
  15. System closed this discussion on 14 Nov, 2018 06:50 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac