2010 and linux 64bit

harty83's Avatar


08 Dec, 2009 03:05 AM

I can't seem to get Money 2010 to work under linux 64 bit. Moneydance 2008 works without a glitch. 2010 will ask me for my password and that's it. It never goes beyond that. Any ideas? I've tried with JRE, without, and generic linux versions.


  1. 1 Posted by Scott M. on 09 Dec, 2009 02:46 AM

    Scott M.'s Avatar

    I'm using it with 64bit Ubuntu. Used the tarball without Java, extracted it into my Home folder and manually created a menu icon. (That won't be acceptable for converts but I read a debian installer is in the works)
    Did you install Sun Java from the software center or synaptic?

  2. 2 Posted by harty83 on 09 Dec, 2009 03:03 AM

    harty83's Avatar

    I have 32bit and 64 bit javas installed which were installed via synaptic. I've tried using them all.

  3. 3 Posted by Scott M. on 09 Dec, 2009 04:03 AM

    Scott M.'s Avatar

    Ok maybe these are worth a try.

    Wherever you are running Moneydance from, try deleting (or renaming to be safe) the java or jre folder, I forget what it's called. Maybe it's conflicting with your other java installs?

    Try deleting or renaming the hidden folder in your Home folder called .moneydance

    Restart Moneydance and let it rebuild it. Note: that's where all your settings and prefs are so you might want to hang on to it.

    What you think?

  4. 4 Posted by harty83 on 09 Dec, 2009 05:20 AM

    harty83's Avatar

    That did it! I renamed my .moneydance folder and moneydance 2010 opened right up. Guess it didn't like some of the old settings. Thanks!


  5. 5 Posted by harty83 on 09 Dec, 2009 05:35 AM

    harty83's Avatar

    Well, I thought I was good. Problem is that every time I set my preferences, MoneyDance won't open. I have to delete the folder again??

  6. 6 Posted by harty83 on 09 Dec, 2009 05:39 AM

    harty83's Avatar

    Okay seems to be related to changing the template. If I keep it at the default "Metal," all is good. If I change it to something else, save, and close MoneyDance won't open until I remove the .moneydance folder.

  7. 7 Posted by Scott M. on 09 Dec, 2009 05:57 AM

    Scott M.'s Avatar

    Nice bit of troubleshooting there. Maybe they'll get if fixed in the next update. Looks like you'll have to stick with Metal until they get it done. I've never changed the template so I never saw the issue. What distro are you using BTW?

  8. 8 Posted by harty83 on 09 Dec, 2009 06:03 AM

    harty83's Avatar

    Ubuntu Karmic

  9. 9 Posted by Raimund Buchhol... on 09 Dec, 2009 09:31 PM

    Raimund Buchholz's Avatar

    Hi all!

    The problem regarding different L&F prohibiting MD 2010 from showing it's main screen (see error.log) is solved with build 722 and above -
    if you are still using MD 2010 721 you may delete the according entry in config.dict, e.g.

      "look_and_feel_class" = "com.sun.java.swing.plaf.nimbus.NimbusLookAndFeel"

    this resets L&F to the working one (Metal)
    new MD builds still can be found here


  10. Raimund Buchholz closed this discussion on 09 Dec, 2009 09:31 PM.

  11. Scott M. re-opened this discussion on 10 Dec, 2009 12:54 AM

  12. 10 Posted by Scott M. on 10 Dec, 2009 12:54 AM

    Scott M.'s Avatar

    OK thanks Raimund.

    Alan, Karmic for me too.

  13. Support Staff 11 Posted by Sean Reilly on 10 Dec, 2009 01:28 AM

    Sean Reilly's Avatar

    These issues are also now fixed in a subsequent build of Moneydance. If you re-download the latest build from http://moneydance.com/other and are running build 722 or later (723 is the latest) this problem (along with a few other bugs that were in the initial release) is solved.

  14. Raimund Buchholz closed this discussion on 10 Dec, 2009 11:12 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac