New "Account Type is Invalid" Error

Steve Forker's Avatar

Steve Forker

05 Sep, 2018 06:18 PM

I have been using moneydance for years, mostly without incident but a few days ago an account stopped downloading, giving the following errors:

There was an error communicating with your financial institution. The details of this error are below.
Bank Name: First Tech Federal Credit Union
The error code reported by the server was: 2000
Account Type is Invalid.

 After unsuccessfully searching for solutions to the same problem on the Moneydance discussion board and on Google, I purchased a new upgrade (2017.8) today. This did not fix the problem. Then I tried manually exporting transactions as a OFX file from the credit union's website and imported them successfully. In the past when I had a problem with an account that stopped downloading this somehow "jumpstarted" the account back to downloading successfully. However, this time it did not fix the problem. Lastly, I tried creating a new account in Moneydance and tried to set up Online Banking for it. During setup after logging into the account it gave the same error.

Another strange thing about this is another account I have at the same institution has no problem downloading.

Any suggestions or help would be appreciated.


  1. 1 Posted by sth on 06 Sep, 2018 12:40 AM

    sth's Avatar

    It may that your credit union changed the OFX data for the account type and it is some random name that MD can't handle. Look at the contents of the OFX file to see what the data says for the account type.

    Second look at the errlog.txt file.
    (Mac OS) Library/Containers/com.infinitekind.MoneydanceOSX/Data/Library/Application Support/Moneydance/errlog.txt
    Press the option key and use the "Go" menu in the finder to access the Library folder.
    Or open a finder window, press Shift-Option-G and paste in this path
    Library/Containers/com.infinitekind.MoneydanceOSX/Data/Library/Application Support/Moneydance
    (Windows) C:\Users(yourusername).moneydance\errlog.txt

    And post a copy or check it yourself to see what the issue is.

    Lastly when you reset the online banking make sure that you call it a "New institution" and force a new download of the connection data from IK.

  2. 2 Posted by Steve Forker on 06 Sep, 2018 06:43 PM

    Steve Forker's Avatar

    Thank you for reminding me where MacOS puts the errlog.txt file.

    Interestingly, this error (see my earlier message) generates nothing in errlog.txt. I can generate the error by attempting to download the account from the Online menu and I can also generate the same error by attempting to set up a new account for online banking as I described before (whether selecting from the Financial Institution pull-down menu or creating a New Connection and selecting from the list that follows). However neither of those actions causes any change to the errlog.txt file. Is there some way to make monedance verbose where everything gets dumped to a log file?

    Usually when a download actually works there is still something in errlog.txt like "Unhandled transaction: <DTSTART>...etc" or something about calculating cost basis or cookie errors, depending on the account downloaded. The fact that absolutely nothing is added to errlog.txt even though an error was displayed as a popup is pretty confusing.

  3. 3 Posted by sth on 07 Sep, 2018 02:29 AM

    sth's Avatar

    According to there are only 4 account types. If you can download the OFX file you might see that it is not one of them?
    Other than that call your credit union?

  4. 4 Posted by Alex on 08 Sep, 2018 04:12 AM

    Alex's Avatar

    I'm seeing the same thing. Is there any debug options/python script we can turn on to log the response?

  5. 5 Posted by jerry_k_wagner on 10 Sep, 2018 04:50 AM

    jerry_k_wagner's Avatar

    Seeing exactly the same thing with First Tech. I deleted my online access from MD to all my First Tech accounts and tried to re-establish a connection for one of the accounts and I got the same error. I am on MD version 2015.6.
    It won't communicate with Chase or AMEX either, but the errors are slightly different. I didn't try deleting and re-establishing those connections.

  6. 6 Posted by Alex on 10 Sep, 2018 03:07 PM

    Alex's Avatar

    I believe First Tech has changed its output. Can dev helps us here by providing a way to log its output?

  7. 7 Posted by Charles Hamilto... on 10 Sep, 2018 04:40 PM

    Charles Hamilton's Avatar

    i'm getting the same error as the OP for checking, savings, and credit card accounts.

    Bank Name: First Tech Federal Credit Union
    The error code reported by the server was: 2000
    Account Type is Invalid.

  8. 8 Posted by Sam Doe on 11 Sep, 2018 02:01 AM

    Sam Doe's Avatar

    I have had the same issue for several weeks now with First Tech accounts. using latest build and version of Moneydance.

    very frustrating. can someone root cause the issue?

  9. 9 Posted by Alex on 11 Sep, 2018 01:50 PM

    Alex's Avatar

    I used some python ofx library to call the First Tech OFX endpoint outside Moneydance and I hit the same errors for all account type.

    This must be an issue in First Tech OFX server. We should all contact the bank and push them to fix it.

  10. 10 Posted by Sam Doe on 11 Sep, 2018 02:06 PM

    Sam Doe's Avatar

    Alex, I had called them 10 days ago and they said they are aware of issue related to this and that a fix was coming mid-last week. That didn't happen. Clearly they are being lazy

    If all of us called First Tech today, registered our complaint, ask to speak to IT department (preferably), we may have better luck. maybe post responses we got here so we have better idea of where we go from here.

  11. 11 Posted by jerry_k_wagner on 11 Sep, 2018 06:26 PM

    jerry_k_wagner's Avatar

    When you call First Tech, do you tell them you are using Quicken or Money Dance?  I have called places before regarding downloading and mentioned Money Dance and they have no clue what I'm talking about.

        On Tuesday, September 11, 2018, 8:06:09 AM MDT, Sam Doe <[email blocked]> wrote:

  12. 12 Posted by Sam Doe on 11 Sep, 2018 06:51 PM

    Sam Doe's Avatar

    I say quicken. More popular and better known and MD and quicken use same exact ofx protocol

  13. 13 Posted by Sam Doe on 15 Sep, 2018 01:04 AM

    Sam Doe's Avatar

    Have people called. They are bullshitting around. I got a long email from a rep saying issue is known, they are working hard, but for how long? it has been 3-4 weeks.

    would be nice if more people called with a little more stern messages to change bank if they don't deliver on this basic service other banks do.

  14. 14 Posted by jerry_k_wagner on 15 Sep, 2018 05:10 AM

    jerry_k_wagner's Avatar

    I will email them tomorrow. Thanks for the update.  Disappointing. You'd think they'd take notice. It's so easy to change banks these days and there are always bonuses  for moving your money to a new bank.

        On Friday, September 14, 2018, 7:04:28 PM MDT, Sam Doe <[email blocked]> wrote:

  15. 15 Posted by Sam Doe on 21 Sep, 2018 02:10 AM

    Sam Doe's Avatar

    All, Looks like they finally fixed it and it works now. Had to send them another nasty message after waiting too long. I was just about getting ready to dump and switch my bank. Glad I didn't have to.

  16. 16 Posted by jerry_k_wagner on 21 Sep, 2018 05:05 AM

    jerry_k_wagner's Avatar

    Sam, I saw that they were down last weekend for updates and I was hoping that was a fix. Did you have to do anything special to get it to work, other than establishing a new connection? I am still getting the same error. I am, however, on an old version of MD (2015.8 (1372)).

  17. 17 Posted by jerry_k_wagner on 21 Sep, 2018 05:42 AM

    jerry_k_wagner's Avatar

    Just updated to the most recent version of MD and I'm still having the issue. Same error as in posting #7.

  18. 18 Posted by Steve Forker on 21 Sep, 2018 02:37 PM

    Steve Forker's Avatar

    I see that we're somewhere between fixed and still broken on this. I'm not sure if I should admit that I was finally able to connect to First Tech late last night or if I should say nothing so I don't jinx my good luck. Thanks for the help begging and cajoling First Tech into at least working on the problem. i had even tested with the latest build ( which supposedly fixed a similar problem for Wells Fargo customers.

  19. 19 Posted by sth on 21 Sep, 2018 03:39 PM

    sth's Avatar

    I think they were two different problems. WF had just FooBarred the OFX file format and First Tech just went their own way and defined a new type of account without regard to the OFX standard.

  20. 20 Posted by jerry_k_wagner on 02 Oct, 2018 05:51 AM

    jerry_k_wagner's Avatar

    First Tech is telling me that it's fixed and they have done internal and external tests to confirm that Quicken is functioning properly. They asked me to send a screen shot if I was still having problems.  I had been vague in my first email and didn't mention MD.  I just said the OFX downloads weren't working for me.

    Does everybody else have OFX downloads from First Tech working now in MD?  I am still getting the "2000" error when I try to re-setup the connection.  Maybe I am doing something wrong.  I'm concerned that if I send a screen shot of MD to First Tech, they will blame MD since Quicken works.

        On Friday, September 21, 2018, 9:39:11 AM MDT, sth <[email blocked]> wrote:

  21. 21 Posted by Charles Hamilto... on 05 Oct, 2018 04:44 PM

    Charles Hamilton's Avatar

    I had been having the 2000 error, but First Tech is working for me now. I had to re-enter my password. After that, the sync worked.

  22. 22 Posted by Sam Doe on 05 Oct, 2018 05:03 PM

    Sam Doe's Avatar

    I can confirm it works for me too now, Jerry. Maybe try to restart the connection (as in 'set up a new connection'). Good luck

  23. 23 Posted by Mike Bruns on 09 Oct, 2018 04:32 AM

    Mike Bruns's Avatar

    I can also confirm that it was broken at the end of August and I was just able to reconnect and sync my accounts today.

    I needed to do New Connection, then look up First Tech Federal Credit Union. There is just one entry in the list for this credit union,

    The rest was straightforward. I used my current user name and password.

    Here is an interesting observation: when First Tech launched their new online banking platform over 2 1/2 years ago we all had to get new passwords. However for all this time my Moneydance sync continued to work with my pre-2016 password. I did not report this problem but I thought it was very curious.

    Now when I did New Connection to remake the connection to First Tech, I used my current password and it worked. I guess they finally updated their servers with the new credentials after 2 1/2 years. Go First Tech!

    Seriously, though, I am in the process of moving my accounts to On Point. I feel that First Tech has long control of their information systems and my confidence is not high enough to keep all my accounts there. I have been banking there since 1990 so it's not a decision I made without a lot of consideration.

  24. 24 Posted by jerry_k_wagner on 08 Dec, 2018 10:39 PM

    jerry_k_wagner's Avatar

    I had a similar experience when they launched their new online banking platform. My new password didn't work for MD and they told me to use my pre-2016 password. At some point I switched over to my new password for MD and it worked.

    I never got the 2000 error resolved. I kept emailing FTFCU and got answers ranging from support people that were willing to call MD support (I don't know if you can...) to the last agent saying they don't support MD. Now there is a certificate error and it's being discussed on a separate thread in the MD forums. It's unclear (to me at least) whose fault it is.

    Did you make the switch to On Point? Are you happy with them and with how they are working with MD? I'm thinking of switching to a different bank and/or to Quicken. This frustration has gone on long enough.


  25. 25 Posted by avp2 on 14 Dec, 2018 10:46 PM

    avp2's Avatar

    For those not aware of it, the "Help" menu Console Window shows some things happening behind the scenes, e.g. communications messages to and from an OFX server when you do a "download" or "online bill pay".

    Note that you may have to wait for scrolling to stop to see the latest operations. The wait is minutes for me. Once the scrolling stops, you can click "clear window" to get a clean screen before triggering an OFX download.

  26. 26 Posted by ormike on 26 Dec, 2018 03:17 PM

    ormike's Avatar


    I am in the process of moving accounts from First Tech. I have been with them for 28 years so it's going to take some time to complete the process. They lost me due to a number of bugs and missteps on the technology side that caused my to lose confidence. All of the problems followed their merger with Addison Avenue credit union in 2011.

    OnPoint has been fine so far. They remind me of the level of service I got from First Tech ten years ago. They also updated their security protocols in June 2018 and I had to update Moneydance to a more recent version to be able to connect again. But that's all it took. No need to wait 60 days for someone to fix something somewhere.

    In my opinion, Quicken is not the answer. Intuit is one of the most consumer hostile, money grubbing distributors of software out there, along with Microsoft and Adobe. I really like Moneydance, even though it is closed source. I find their customer support to be good.

  27. 27 Posted by jerry_k_wagner on 27 Dec, 2018 01:52 AM

    jerry_k_wagner's Avatar

    Thanks for the info. Very good info and I'm glad to hear OnPoint is fine so far.

        On Wednesday, December 26, 2018, 8:17:13 AM MST, ormike <[email blocked]> wrote:


  28. System closed this discussion on 28 Mar, 2019 02:00 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac