Losing previous entered stock/investment prices

Trevor S's Avatar

Trevor S

13 Oct, 2018 05:45 AM

A number of times recently I have noticed that investment and stock prices I have entered previously are disappearing. I know that i have entered the values as they are still in the "Current Price" field but they are not in the historic list.

This i frustrating as for some values, I am able to recover them but for other values, they are not accessible from the sites that list the investment values.

  1. 1 Posted by dwg on 13 Oct, 2018 09:00 AM

    dwg's Avatar

    I'm a fellow user.

    To start to analyse your problem for possible causes I think we need to begin by capturing some basic information about your environment. The following instructions should give a start

    Open the console window (Menu Bar item: Help --> Console Window)

    Select and copy the first 6 lines at the top of the window and paste them in as a response in this thread.

    The information will look something like:

    Starting Moneydance 2017.9 (1694) at Sun Aug 26 19:25:31 EDT 2018 Settings Folder: /Users//Library/Containers/com.infinitekind.MoneydanceOSX/Data/Library/Application Support/Moneydance OS: Mac OS X 10.11.6 x86_64 Java: 1.8.0_162 (Oracle Corporation) Is in sandbox: true; restricted file access: false Initializing Moneydance SSL

    This example is taken from a Mac system

    This will tell us the exact version of Moneydance in use, the Operating System and version used as well as some other details.

  2. 2 Posted by Trevor S on 14 Oct, 2018 05:10 AM

    Trevor S's Avatar

    Here are the first six lines:

    Starting Moneydance 2017.8 (1691) at Thu Oct 11 11:00:59 MDT 2018
    Settings Folder: /Users/XXXXXXXX/Library/Containers/com.infinitekind.MoneydanceOSX/Data/Library/Application Support/Moneydance
    OS: Mac OS X 10.13.6 x86_64
    Java: 1.8.0_162 (Oracle Corporation)
    Is in sandbox: true; restricted file access: false
    Initializing Moneydance SSL

    I obfuscated my system user from the above lines.

  3. 3 Posted by dwg on 14 Oct, 2018 09:38 AM

    dwg's Avatar

    I am a fellow user.

    According to the change log this was a problem that was corrected in a slightly latter build of Moneydance.

    Later builds are in the preview branch.


  4. 4 Posted by Trevor S on 16 Oct, 2018 02:59 AM

    Trevor S's Avatar

    Thanks for the update. I am hoping that the "preview" release is turned into a normal release soon.

  5. 5 Posted by Ben on 16 Oct, 2018 09:32 AM

    Ben's Avatar

    Trevor, if you're not using the Security Price Entry extension, you might find it solves your problem. I had it happening with currency exchange rates but not stock/investment prices. I suspect this is because I use the Security Price Entry extension - it makes keying in a batch much quicker - and whatever bug is affecting the manual entry in the "Currency/Security History" window isn't affecting the extension.

    If you want to carry on using the Currency/Security History window, you may find that hitting enter and moving to the next line forces the entry (thanks to sth for the tip). It worked for me, but in the end I simply reinsalled 2017.7 over 2017.8 and now all seems well again.

  6. 6 Posted by Trevor S on 17 Oct, 2018 04:05 AM

    Trevor S's Avatar

    I have tried the Security Price Extension before but didn't like the UI at the time.

    I will try your suggestion for hitting "enter" after adding the new entry.

  7. System closed this discussion on 16 Jan, 2019 04:10 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac