Bad system fonts in 2019 versions later than 1860 (linux)

Bob's Avatar

Bob

09 Apr, 2019 07:17 AM

On my linux system (currently Fedora 28), for many years Monedance has used my system theme fonts and colors for the menu bar, menus, pop-up windows, etc. (or at least fonts and background colors that are very close to my linux system theme). The last version that I have where this is true is 2019 1860. Starting from 1862, all of the fonts and backgrounds in menus, pop-ups, etc. are now messed up. The background color is pure white and the fonts are ugly and hard to read, as if it's trying to use a font not installed on my system. It's bad enough that I'm sticking with version 1860 for now.

  1. 1 Posted by Bob on 09 Apr, 2019 07:24 AM

    Bob's Avatar

    By the way, I've tried up to version 1865 and the problem is still there.

  2. 2 Posted by derekkent23 on 09 Apr, 2019 09:14 AM

    derekkent23's Avatar

    I am not support staff, just a user.

    As I am not a Linux user this may be irrelevant.
    https://infinitekind.tenderapp.com/kb/linux/linux-and-hidpi-high-re...

  3. 3 Posted by Bob on 09 Apr, 2019 06:12 PM

    Bob's Avatar

    Thanks, but that's a different issue. I have a normal resolution monitor and as I mentioned, everything looked fine up until version 1862.

    Also, only the 'system' fonts (menu bar, menus, pop-up windows, etc.) are messed up now. All other fonts in the program are still fine.

  4. 4 Posted by derekkent23 on 09 Apr, 2019 07:20 PM

    derekkent23's Avatar

    I am not support staff, just a user.

    Sorry it was the wrong solution

    SUPPORT PLESE STEP IN

  5. 5 Posted by Bob on 17 Apr, 2019 05:42 AM

    Bob's Avatar

    I just tried the new 1867 version and the problem is still there. derekkent23, thanks again for trying to help but I haven't heard anything from Moneydance support yet.

  6. 6 Posted by Bob on 18 Apr, 2019 04:53 AM

    Bob's Avatar

    I just tried 1868 and it's still broken. Still no evidence that Moneydance support has even seen this conversation since there have been two new releases since I reported it and there's been response and no mention of it in the changelog.

    If I stick with Moneydance 2019, I have to stay at version 1860 to be able read things, but 1860 has QIF import problems that make me have to revert back to Moneydance 2017 (version 1701). As of right now it looks like I've wasted money upgrading to 2019.

  7. 7 Posted by Bob on 18 Apr, 2019 04:57 AM

    Bob's Avatar

    typo, that should have been: 'there's been no response and no mention of it in the changelog.'

  8. 8 Posted by Bob on 25 Apr, 2019 08:19 AM

    Bob's Avatar

    Still broken in version 1870.

  9. 9 Posted by Kevin Gable on 25 Apr, 2019 02:53 PM

    Kevin Gable's Avatar

    I'll confirm this--every version after 1860 has basically unreadable fonts in menus & popups. I've tried altering both the look-and-feel environment variable and the scaling, and nothing I've tried gives a satisfactory result. It would help if the program authors can recommend settings that might. Presumably the absence of response to this reflects that someone does not see this or think it an issue.

  10. 10 Posted by Mark Sarnov on 26 Apr, 2019 09:34 PM

    Mark Sarnov's Avatar

    Yup.. I'm experiencing the same thing using Elementary OS Juno (5) and have tried to add Java VM options for anti-aliasing to no avail.
    If you are interested in downgrading to 2019.1 (1855) you can download it here:

    https://infinitekind.com/stabledl/2019.1_1855/

    However, once I did, my Online Banking downloading transactions is messed up.. :(

    Cappy

  11. 11 Posted by Jim on 27 Apr, 2019 08:53 PM

    Jim's Avatar

    Same issue with CentOS 7.6.1810. MD 1860 works fine. Next two I tried are 1868 and 1870, both have font issues. I'm also sticking with version 1860 until this get resolved. I've attached some screenshots of the problem for IK support to review.

  12. 12 Posted by andyschmid on 30 Apr, 2019 03:59 AM

    andyschmid's Avatar

    Another linux user chiming in. This latest update also degraded the font rendering for me. Hopefully moneydance staff looks at this.

  13. 13 Posted by Kevin Gable on 30 Apr, 2019 05:38 PM

    Kevin Gable's Avatar

    Here are my screen shots.
    The 1860 is optimal on my screen; I'm using the environment variable _JAVA_OPTIONS set to "-Dawt.useSystemAAFontSettings=on -Dswing.defaultlaf=com.sun.java.swing.plaf.gtk.GTKLookAndFeel"

    1870_1 is with the same settings, build 1870. Note how the menu bar fonts have shrunk; on my laptop screen they are only legible if I have my face against the screen.

    In the others, I either turn off -Dswing.defaultlaf=com.sun.java.swing.plaf.gtk.GTKLookAndFeel

    or set -Dsun.java2d.uiScale=2; in the last one I have both the LAF and uiScale set.

    Presumably, I can fiddle with the combination of uiScale and the Preferences font size to get something usable, but it would be far more manageable to be able to pick up the GTK settings. And some documentation of how to optimize this really is needed.

  14. 14 Posted by amaxware on 11 May, 2019 12:15 PM

    amaxware's Avatar

    The settings
    -Dawt.useSystemAAFontSettings=lcd
    -Dswing.defaultlaf=com.sun.java.swing.plaf.gtk.GTKLookAndFeel

    Definitely make an improvement for my install (Fedora 30).
    One thing I have notices, no matter what preferences or options, the top menu
    File, Edit, View.... never changes.

  15. 15 Posted by amaxware on 11 May, 2019 12:22 PM

    amaxware's Avatar

    Obviously this has to do with the Java platfrom switch in recent versions from Java 1.8 to Java 11.
    Also the use of JavaFX.
    I previously used to use Fedora's built-in java from /etc/alternatives/java, but that no longer works due to seperation of JRE and JavaFX.
    Hopefully IK staff can run more testing on the Linux platform to find perhaps more customized settings to enable more use of built-in GTK fonts.

  16. 16 Posted by Kevin Gable on 05 Jun, 2019 08:05 PM

    Kevin Gable's Avatar

    Build 1874 looks much better--seems to be back to prior behavior.
    Thanks!

  17. 17 Posted by Bob on 06 Jun, 2019 08:00 AM

    Bob's Avatar

    Yes, the fonts are back to normal and are readable again, thanks IK/Moneydance!

    However, the GUI widgets for menus, text-entry boxes, etc, are now all 2-dimensional and monochrome so the environment looks less polished and less professional than the pre-1860 versions. The earlier versions appeared to use one of my linux system widget libraries (either GTK or QT) but 1874 looks like it's using homemade or maybe basic Java widgets so it doesn't integrate with the rest of my desktop.

    The fonts are a huge improvement though so 1874 is definitely usable now, thanks again.

  18. 18 Posted by amaxware on 12 Jun, 2019 02:14 PM

    amaxware's Avatar

    I just tried the preview 1876, it certainly corrected a LOT of font issues.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac