qfx download

Brian Baugh's Avatar

Brian Baugh

25 Aug, 2019 08:31 PM

My qfx downloads from bank of america have the credit and debit sides switched after downloading the file.
It used to work fine.
It has started after upgrading to 2019.03.
What do you suggest me doing so I don't have to switch every transaction in the register?

  1. 1 Posted by derekkent23 on 25 Aug, 2019 08:45 PM

    derekkent23's Avatar

    I am not support staff, just a user.

    It looks like some banks are now not following the spec for QFX/OFX files. They are labeling all transactions as debits. Looks like bank of america has recently started to make the same error.

    Do a FILE (MONEYDANCE on Mac) – EXPORT BACKUP in case the following does not work for you.

    Moneydance has added a workaround. Make sure under FILE (MONEYDANCE on Mac) – PREFERENCES – NETWORK that IGNORE TRANSACTION TYPE IN FAVOR OF AMOUNT SIGN is ticked and see if that helps.

    If your build of 2019 hasn’t got this fix update from https://infinitekind.com/preview

    Hope this helps

  2. 2 Posted by phil on 26 Aug, 2019 10:01 PM

    phil's Avatar

    On 8/25/2019 1:33 PM, Brian Baugh wrote:

    I had the same problem - it started about two months ago. After
    applying the suggested workaround, I "bit the bullet" and switched every
    entry to its proper column. It took a while but it now looks proper.
    My next scheduled QFX download is in two weeks - we shall see if it is
    effective.

    Phil Kane
    Long time MD user

  3. 3 Posted by Brian Baugh on 26 Aug, 2019 10:08 PM

    Brian Baugh's Avatar

    Phil,
    I tried downloading a different file from the bank. It looks like qif
    files work and put things in the proper column.
    Hope that helps.
    -Brian

  4. Support Staff 4 Posted by Maddy on 27 Aug, 2019 08:51 AM

    Maddy's Avatar

    Hi,

    I can see you’ve received a reply from one of our knowledgeable Moneydance customers.
    To add to this useful information I thought it is worth mentioning that if you'd feel more comfortable running the latest stable version, Moneydance 2019.3 (1880) avaialble from here, the mentioned fix was added in this build.

    The feature called "Ignore Transaction Types in Favor of Amount Signs" checkbox, in the Network tab of the settings prevents from inverting credits and debits.

    Finally, QIF files can be imported easily, but we would normally recommend you use the OFX or QFX file format, if either are available.

    OFX and QFX files contain unique transaction identifiers. If you were to accidentally download the same transaction to Moneydance more than once, the ID would be recognised. Moneydance would then ignore the duplicate transactions and not download them again.
    Unfortunately QIF files don't contain these same ID's.

    If you haven't already, I'd recommend taking a look at this article from the knowledge base that details recognising and confirming your recently downloaded data.

    I hope this information is helpful. Please let me know if you have further questions or need any assistance.

    --
    Maddy, Infinite Kind Support

  5. 5 Posted by Brian Baugh on 27 Aug, 2019 01:19 PM

    Brian Baugh's Avatar

    Thank you Maddy.
    Marking that checkbox worked. Now the QFX files work.

    I did have the 2019.3 version.

  6. Support Staff 6 Posted by Maddy on 27 Aug, 2019 02:47 PM

    Maddy's Avatar

    You are welcome Brian ! I'm very pleased to hear that.
    I'll close this discussion for now, but do not hesitate to contact us again, if you need further assistance.

    --
    Maddy, Infinite Kind Support

  7. Maddy closed this discussion on 27 Aug, 2019 02:47 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac