Reports

Ken Fish's Avatar

Ken Fish

20 Dec, 2009 07:10 PM

Hi
I am using MD 2010 on Windows Vista.
The problem manifests on all the report types, but I'll illustrate it with Income and Expenses.

On opening the report all types of all the accounts is shown. If I use edit I can choose to highlight (say) expenses and to choose just one account (say) car:petrol, so that I can isolate my spending on petrol. When I switch back to the report I see that NOTHING HAS CHANGED. Every account and transaction type is still displayed. Changing the dates does work, but I can't isolate a single spending type!

Is this how MD 2010 works or is there a fault?

  1. 1 Posted by ljb on 20 Dec, 2009 09:27 PM

    ljb's Avatar

    (This may sound odd.) Do you see 2 or 3 radio buttons on the Edit dialog for the report? The first is All Accounts. The second is Account Types. The third is Individual Accounts. If you don't see the 3rd button - and I didn't, at first, for that report - make the edit dialog wider. Then the 3rd button is available, select that and you can pick accounts. You can also use None, All above the list. When I expanded the dialog window once, the problem went away, and the dialog now comes up with all 3 buttons visible.

  2. 2 Posted by jj.walsh on 20 Dec, 2009 10:15 PM

    jj.walsh's Avatar

    I have reported the same problem. Even if I select Individual Accounts Chose None to clear all the tics and select one category I still get all categories on the Report Window. Jim Walsh

  3. 3 Posted by brandonwswanson on 20 Dec, 2009 10:20 PM

    brandonwswanson's Avatar

    What build are you using?

  4. 4 Posted by ljb on 20 Dec, 2009 10:48 PM

    ljb's Avatar

    Definitely works for me. (MD2010 build 728). Reports, Income & Expenses (the report, not the graph). Edit button, pick Invidual Accounts, click None, and pick one or a few expense or income accounts, click OK. The report shows only the accounts I selected.

  5. 5 Posted by fish.kenneth on 20 Dec, 2009 10:58 PM

    fish.kenneth's Avatar

    Hi
    All three radio buttons are visible.

    I did some experimenting and this is what I found:
    With the Individual Accounts RB filled and ALL the accounts checked I got a
    full report. When I used the NONE to deselect all accounts and then checked
    Petrol I still got ALL the accounts. I then manually dechecked all the
    accounts execpt Petrol I got what I wanted i.e. my spending on petrol.
    I then used ALL to check all the accounts but when I displayed the report
    only Petrol was showing i.e. none of the other account showed. I had to move
    to another report type and then back to Income and Expenses to get the full
    display.

    Ken Fish

    2009/12/20 ljb <
    [email blocked]<tender%[email blocked]>
    >

  6. 6 Posted by jj.walsh on 20 Dec, 2009 11:05 PM

    jj.walsh's Avatar

    I am using build (723) and the updater says this is the current stable version. Jim Walsh

  7. 7 Posted by ljb on 20 Dec, 2009 11:31 PM

    ljb's Avatar

    Build 728 is a "beta", but posts from the MD staff in these forums indicate they consider it stable enough to use.

    I just switched back to build 723 and duplicated your issue. Very weird behavior, but it looks like it was already fixed in build 728.

  8. 8 Posted by fish.kenneth on 21 Dec, 2009 08:55 AM

    fish.kenneth's Avatar

    Hi
    *MD 2010 723 downloaded 20 Dec.* (I downloaded 2010 a week or so ago. I
    uninstalled and reinstalled yesterday to try and fix the report problem)

    2009/12/21 brandonwswanson <
    [email blocked]<tender%[email blocked]>
    >

  9. 9 Posted by jj.walsh on 21 Dec, 2009 09:49 AM

    jj.walsh's Avatar

    Many thanks Kenneth. As you say it seems that the issue has already been sorted in 728. I do not usually go for Beta versions but that is my problem in this case. Jim

  10. 10 Posted by Ben Spencer on 22 Dec, 2009 09:36 PM

    Ben Spencer's Avatar

    I am sorry for the trouble this has caused. We are currently up to build 730 and this will most likely become the next stable build later tonight.

    Sincerely

    Ben Spencer

  11. 11 Posted by fish.kenneth on 23 Dec, 2009 08:44 AM

    fish.kenneth's Avatar

    Hi Bill,
    I'm sorry, but I don't really understand this email.
    How can I fix the problem that I have reported? Do I have to download an
    update, a new version of MD or what??

    Ken Fish

    2009/12/22 Ben Spencer <
    [email blocked]<tender%[email blocked]>
    >

  12. 12 Posted by ljb on 24 Dec, 2009 01:25 AM

    ljb's Avatar

    Not to speak for him, but what he is saying, and as I said above: This has been fixed in a 'stable beta' release, build 728 and higher I think. It's up to you, if you want to use it. You can get it at

    http://moneydance.com/trac/wiki/Moneydance2010Beta

    You can install it like any other release (though I don't think 'beta' releases will install via the auto-update, if you are using that). Or, if you are comfortable swapping files around, you can just download the moneydance.jar file from that same page and replace that one file to get theupdated build. Your other option is to wait for an official MD2010 update release. Hope this helps.

  13. 13 Posted by fish.kenneth on 24 Dec, 2009 02:09 PM

    fish.kenneth's Avatar

    Hi
    The report problem is fixed. Thank you every one

    Ken

    2009/12/24 ljb <
    [email blocked]<tender%[email blocked]>
    >

  14. 14 Posted by Ben Spencer on 25 Dec, 2009 02:01 PM

    Ben Spencer's Avatar

    You are welcome!
    Merry Christmas.
    Ben

  15. Ben Spencer closed this discussion on 25 Dec, 2009 02:01 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac