Won't install with Ubuntu 20.04

Esther's Avatar

Esther

22 May, 2020 06:14 PM

Hello,

I've been an avid user of MoneyDance for several years and recently I upgrade my OS to Ubuntu 20.04 and I am unable to install/run MoneyDance. I downloaded from InifiniteKind website, I tried installing from Ubuntu Software Installer but although the installation seems to appear to have gone smoothly, I can't seem to run the program. Please advise.

  1. Support Staff 1 Posted by Ethan on 22 May, 2020 06:57 PM

    Ethan's Avatar

    Hello,

    Which version of Moneydance are you trying to run?

    Can you send me your errlog.txt file? This should capture any error messages the program is generating, even if it is failing to run. If you're using Linux, it should be located at:

    /home/(yourusername)/.moneydance/errlog.txt

    Ethan
    Infinite Kind Support

  2. 2 Posted by E M on 22 May, 2020 07:15 PM

    E M's Avatar

    Thank you, Ethan, for your reply.

    Although the installation appeared to have been successful, when I searched
    for .moneydance, it does not exist. I looked for the linus executable but
    I did not find it.

    [image: Esther (With images) | Cool typography]

  3. Support Staff 3 Posted by Ethan on 22 May, 2020 08:06 PM

    Ethan's Avatar

    Hmm, ok, so it sounds like the issue is that you can't find the program itself after the installation? I believe Moneydance by default will install into /opt/Moneydance/ on Linux. Can you look there to see if you can find the program and run it from there? If that works, then we can just recreate the shortcuts to the program from there.

    Ethan
    Infinite Kind Support

  4. 4 Posted by E M on 22 May, 2020 08:41 PM

    E M's Avatar

    After downloading the installation file for Linux, the file,
    moneydance_linux_amd64.deb, was extracted and the attached file shows the
    files under opt/.

    [image: Esther (With images) | Cool typography]

  5. 5 Posted by E M on 22 May, 2020 08:45 PM

    E M's Avatar

    I will attempt revert back to Ubuntu 18.04 and try to reinstall.

    [image: Esther (With images) | Cool typography]

  6. Support Staff 6 Posted by Ethan on 22 May, 2020 08:47 PM

    Ethan's Avatar

    Ok, it looks like the program did install in that location. The program file is the one called Moneydance. It's strange that it's showing up as an unknown file type though. What happens when you try double clicking on it?

    If it doesn't work, you may need to right-click on that file, go into the file properties, and choose to allow executing the file as a program.

    Ethan
    Infinite Kind Support

  7. 7 Posted by E M on 22 May, 2020 08:54 PM

    E M's Avatar

    I did.

    ~ Esther 

  8. 8 Posted by jeff_l on 22 May, 2020 08:59 PM

    jeff_l's Avatar

    Hi Esther,

    If you are OK with using Terminal in Ubuntu you could try the following. This will either install the program or re-install it again as my screen shot attached shows. This presumes that you downloaded MD to the default Download folder.

    At the terminal prompt type :- sudo dpkg -i Downloads/moneydance_linux_amd64.deb

    Hope this helps.

    Jeff

  9. 9 Posted by E M on 22 May, 2020 09:04 PM

    E M's Avatar

    Thanks, Jeff.

    I will retry after I revert back to Ubuntu 18.04.

    [image: Esther (With images) | Cool typography]

  10. 10 Posted by sprimost on 22 May, 2020 09:36 PM

    sprimost's Avatar

    From: sprimost (not MD support)

    I tried to duplicate your  issue with a VirtualBox image of Ubuntu20.04.
    The only difference is that I installed KDE/Plasma desktop. I undestand
    that that may be a difference, since the software isntaller for 20.4 is
    more directed at "snap" packages. (MD is _not_a sanp package!).

    Anyway, I downloaded the LINUX package, started file manager (dolphin)
    and right-click/open with Software Install. The install should ask you
    for the root password, and then cleanly install. The start-up for MD is
    in the application menu: properties for application is /bin/sh
    "opt/Moneydance/Moneydance"

    I am not a fan of the Gnome desktop and definitely think otherwise of
    snap packages, so the suggestion using dpkg is more of a sure bet.

    You should be able to install Moneydance under 18.04.4 and then upgrade
    to 20.04 as an option.

    /scp

  11. 11 Posted by E M on 22 May, 2020 09:54 PM

    E M's Avatar

    I am happy to report that MoneyDance installed and is running smoothly
    after I reverted to Ubuntu 18.04 from Ubuntu 20.04. I had all the data
    backed up so getting back to the program was seamless. Thanks so much for
    your help!

    [image: Esther (With images) | Cool typography]

  12. 12 Posted by derekkent23 on 23 May, 2020 11:38 AM

    derekkent23's Avatar

    I am not support staff, just a user.
    Hi Esther,

    I am not a Linux ubuntu 20.04 expert, may be too late but this is how I installed Moneydance 2019.4(1904).

    1. Downloaded moneydance_linux_amd64.deb to Download Folder.
    2. In FILES app highlight moneydance_linux_amd64.deb - right click - if OPEN WITH SOFTWARE INSTALL is not listed highlight PROPERTIES – PERMISSION tab – tick ALLOW EXECUTING FILE AS A PROGRAM. Click OPEN WITH tab – set SOFTWARE INSTALL as default application – close window. This step is a one-time setup.
    3. Highlight moneydance_linux_amd64.deb right click then OPEN WITH SOFTWARE INSTALL
    4. The Ubuntu Software window opens with Moneydance info. Click INSTALL and if you get the AUTHENTICATION REQUIRED window enter you Ubuntu password.
    5. Once installed Moneydance icon appears under SHOW APPLICATIONS.

    I normally use Linux Mint 19.3 in preference to Ubuntu as I find it more user friendly.

    Hope this helps.

  13. 13 Posted by E M on 23 May, 2020 02:21 PM

    E M's Avatar

    Thank you, Derek. I dud exactly as you stated four times wit no avail.
    After I reverted to 18.04 LTS, MD runs well as before.

    ~ Esther

  14. 14 Posted by derekkent23 on 23 May, 2020 02:38 PM

    derekkent23's Avatar

    I am not support staff, just a user.
    Hi Esther

    Out of interest on which of the 5 steps did it fail?

  15. 15 Posted by E M on 23 May, 2020 03:01 PM

    E M's Avatar

    It didn't even install with Ubuntu 20.04 LTS.

    ~ Esther

  16. Support Staff 16 Posted by Ethan on 23 May, 2020 06:25 PM

    Ethan's Avatar

    I'm glad to hear things seem to be sorted out. When you write that it didn't install when you followed the instructions derekkent23 gave, do you remember what error message the terminal displayed? I also haven't been able to replicate this on my test system using the same operating system as you are.

    Ethan
    Infinite Kind Support

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac