Issue with 2020 version

Eugene Furtman's Avatar

Eugene Furtman

23 Jun, 2020 03:35 PM

I downloaded the 2020 update build 1914 and am unable to get any windows to appear. The Moneydance menu appears and I can select preferences but there are no other windows...no account access at all. I'm running on a Mac version 10.15.5. The previous version of Moneydance has run fine except for issues I have connecting to my bank to pay bills. I thought perhaps the new one might fix that but I clearly cannot even try. Any suggestions?

I've installed by replacing the previous version as well as reinstalled keeping both versions. The older version still works but the new one is DOA.

  1. Support Staff 1 Posted by Ethan on 23 Jun, 2020 07:50 PM

    Ethan's Avatar

    Hmm, I remember something like this happened often a few versions ago when people were trying out a beta version. Can you try resetting your Moneydance preferences and see if that fixes the issue that you're seeing? That helped in the previous situation.

    To do this, you have to rename your config.dict file. If you're using Mac OS X, it should be located at one of these locations within your Home folder:

    Library/Containers/com.infinitekind.MoneydanceOSX/Data/Library/Application Support/Moneydance/config.dict

    or:

    Library/Application Support/Moneydance/config.dict

    If you have any trouble finding your Home Library folder, open Finder and select Go>Go to Folder> and type in:

    ~/Library

    This should pull up your local Library folder.

    Once you've found your config.dict file, close Moneydance and rename it (to something like config2.dict, for example), then open Moneydance again and it will appear as though you've just installed Moneydance for the first time, so you'll have to re-enter your license key and may have to locate and open your data set again. If you run into any problems, you can simply close Moneydance and rename the original config.dict file back to config.dict and open Moneydance again to restore your original settings.

    If that doesn't work, can you send me your errlog.txt file? If you're using Mac OS X, it should be located at one of these locations within your Home folder:

    Library/Containers/com.infinitekind.MoneydanceOSX/Data/Library/Application Support/Moneydance/errlog.txt

    or:

    Library/Application Support/Moneydance/errlog.txt

    If you have any trouble finding your Home Library folder, open Finder and select Go -> Go to Folder and type in:

    ~/Library

    This should pull up your local Library folder.

    Ethan
    Infinite Kind Support

  2. 2 Posted by sth on 23 Jun, 2020 09:48 PM

    sth's Avatar

    Eugene,
    If you click and hold on the dock icon you will get a pop up window that has an option to show all windows. Does this show the missing window? This may be a way to recover a missing window that has moved off screen or thinks it is on another monitor.
    (not IK support)

  3. 3 Posted by lkeppeljunk on 24 Jun, 2020 12:45 PM

    lkeppeljunk's Avatar

    I have the same issue with version 1914 and the pop up window says No Available Windows.

    I just went back and downloaded the version 2019.3 (1880) and got back in that way. I will wait for the bug to be fixed.

  4. 4 Posted by Eugene Furtman on 24 Jun, 2020 01:50 PM

    Eugene Furtman's Avatar

    Ethan, thanks for getting back to me. I tried the rename the config.dict file and restart the app. It then showed me the startup window where I could select a file or create a new one. Selecting a file didn’t work. It seem to hang. I’ve attached the log. Creating a new file wasn’t tried yet. I was afraid of overwriting the old stuff. Should that be next?

  5. 5 Posted by pfkalina on 24 Jun, 2020 04:24 PM

    pfkalina's Avatar

    I have the very same problem upon opening version 1914, Using (MacOS 10.14.6) Mojave. I've even gone to the data file, right clicked, and opened with MD 2020. Still, no luck. I get a blank screen with Moneydance menu in the upper left corner.

    I also tried Ethan's suggestion to rename the config.dict file. This time, I do get the Getting Started... window and I can see my data file in the window to select. However, when I select it....nothing seems to happen. Well, something did happen....the window froze and I had to close it.

  6. 6 Posted by pfkalina on 24 Jun, 2020 04:39 PM

    pfkalina's Avatar

    Here's the error log I get when I fail to open my data file:

  7. 7 Posted by Eugene Furtman on 24 Jun, 2020 06:59 PM

    Eugene Furtman's Avatar

    This is what I discovered that works….

    Copy the key for the current version of Moneydance and close it.
    Rename config.dict file from the previous version.
    Start the new version of Moneydance. The welcome screen appears with the list of existing files. IGNORE THOSE FILES.
    Select the second item on the left…the one that says import a file including Moneydance files.
    Select your most recent backup.

    Everything came up fine after that. In the the upper right corner you will see where it says purchase or license. Select license and past in the key you copied to the clipboard.

    My only complaint at this point is all my extensions are gone and need to be set up again. And the font is too small and I can’t figure out how to make the balance numbers larger.

    Good luck.

  8. 8 Posted by Eugene Furtman on 24 Jun, 2020 08:10 PM

    Eugene Furtman's Avatar

    For what it’s worth I was able to successfully open the new version of Moneydance with my converted data file three time. Then it failed to open just as before. So use my suggestion carefully.

  9. Support Staff 9 Posted by Maddy on 24 Jun, 2020 08:55 PM

    Maddy's Avatar

    Thank you Eugene! We are very pleased to hear that.
    I'll close this discussion for now, but do not hesitate to contact us again, if you need further assistance.

    --
    Maddy, Infinite Kind Support

  10. Maddy closed this discussion on 24 Jun, 2020 08:55 PM.

  11. sth re-opened this discussion on 25 Jun, 2020 02:30 AM

  12. 10 Posted by sth on 25 Jun, 2020 02:30 AM

    sth's Avatar

    It appears from the error logs that something in your file caused an infinite loop and a crash. This is something the developer should certainly look at. To have two identical issues like this seems to be a bug.

  13. 11 Posted by Allison on 25 Jun, 2020 12:17 PM

    Allison's Avatar

    I am having the same issue but I noticed it only happens with encrypted password protected files.

  14. 12 Posted by Eugene Furtman on 25 Jun, 2020 12:25 PM

    Eugene Furtman's Avatar

    Yes. My files are encrypted. I actually thought it was working pretty well until I installed the extension “quote loader”. I was then unable to get the file to open correctly after that. I think I’ll ignore the new software until the bugs are fixed.

    Gene

  15. 13 Posted by Allison on 25 Jun, 2020 12:30 PM

    Allison's Avatar

    Is there a way to rollback to the older version until things are fixed?

  16. Support Staff 14 Posted by Ethan on 25 Jun, 2020 06:00 PM

    Ethan's Avatar

    Our lead developer reports that he thinks he may have resolved this in the next preview version (1915). It won't fix any file that has this issue, but it should hopefully prevent it from happening again. You'll have to restore from a backup if you had this issue. It's always a good idea to make sure you have backups of your data, especially if you are going to be testing beta software.

    If any of you who experienced this issue would be willing to share the affected data file with him, he could look into it and make sure the root problem is resolved. If you'd like to help with that, please open up a new private thread about this. Otherwise we'll implement the fix and see if this keeps happening for others.

    The 1915 build isn't out yet, but should be soon. You can always revert to the last stable version of Moneydance from http://infinitekind.com/downloads

    Ethan
    Infinite Kind Support

  17. 15 Posted by derekkent23 on 27 Jun, 2020 07:22 AM

    derekkent23's Avatar

    I am not support staff, just a user.

    I see Sean has released build 1915 for Moneydance 2020.
    As I am not a Mac user I cant confirm it has fixed the issue.

  18. Support Staff 16 Posted by Sean Reilly on 27 Jun, 2020 01:01 PM

    Sean Reilly's Avatar

    Hi all,

    If anyone still has the problem and wouldn't mind sharing your data file (or a backup of it), here is an upload-only link to share it with me via dropbox:
      https://www.dropbox.com/request/MWl0JDdufTqlKiJUQtqz

    If your file is encrypted, please send me the passphrase to open the file via the Messages app on your iPhone, iPad, or Mac to my email "sreilly(at)infinitekind.com" (replacing the (at) with @ ).

    Thanks!
    Sean

  19. 17 Posted by Dan P on 27 Jun, 2020 02:57 PM

    Dan P's Avatar

    I'm not sure if this is related, but this morning I had a very strange issue.
    Windows 10, MD build 1914.
    I had left Mondeydance open overnight. When I started my daily routine of updates, the program seemed very sluggish. When I clicked on an Investment account, I could not open the history tab on the securities detail tab.
    I closed MD and did not get the Backup dialog, so I looked at the Windows task manager and MD was consuming 15-20% of the CPU. After 10 minutes, I forced it to stop. (It acted like an infinite loop.)
    Restarting MD was uneventful, all data appears to be correct and it's running fine.
    I've since upgraded to 1915.
    I'm posting just to be sure that Sean is aware and if related to this post, it did occur in Windows 10.

    Thanks!

  20. 18 Posted by pfkalina on 28 Jun, 2020 10:56 PM

    pfkalina's Avatar

    Sean, I am one of those who had the problem opening release 1914 on a Mac. Today, I downloaded release 1915, installed it, opened the application, and things opened 'normally' (see note below). From my standpoint, it is working as intended, at this point.

    I did see some warning messages near the top of the window that references some of the extensions not being verified (see attached). I have a feeling this might be because of the security in MacOS 10.15.5 (Catalina).
    If I have any other issues, I will report them. Thanks!!

  21. 19 Posted by dwg on 28 Jun, 2020 11:15 PM

    dwg's Avatar

    I'm a fellow user.

    The messages are the result of using an older version of Quote Loader. There have been significant changes made to Quote Loader, with different components and a different installation, the older release has been retired. You should remove the old version and install the latest release. Details are in the thread:

    https://infinitekind.tenderapp.com/discussions/investments/4914-the-new-quote-loader

  22. 20 Posted by derekkent23 on 29 Jun, 2020 06:17 AM

    derekkent23's Avatar

    I am not support staff, just a user.
    Hi pfkalina

    As posted by dwg you need to update to a signed copy of Quote Loader and remove the old system as outlined in the latest release notes for Quote Loader.

    This will remove the red warnings.

    The latest build of Quote Loader also contains some great new features.

    A more direct link to the latest release notes for Quote Loader, post 38 is https://infinitekind.tenderapp.com/discussions/investments/4914-the...

    Hope this helps

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac