Moneydance window name in Ubuntu

adrian's Avatar

adrian

27 Jun, 2020 09:02 AM

As Moneydance is a java application the name of the programme displayed in Ubuntu shows up as 'com-install4j-runtime-launcher-UnixLauncher'. This is displayed on the top menu bar in Ubuntu and also means a 2nd Moneydance icon is shown in the dock once Moneydance is launched.

My Moneydance.desktop has WM_CLASS set to 'moneydance'. However it appears Moneydance is not setting this value. If there is another solution can someone advise.

  1. Support Staff 1 Posted by Ethan on 28 Jun, 2020 07:44 PM

    Ethan's Avatar

    Hello,

    I'm using Ubuntu myself, and I've never seen this displayed in the title bar. Can you clarify which version of Ubuntu you are using, and which desktop environment you are running? Does the title bar just display what you've written, or does it also display the file name after that? On my system, the titlebar simply shows: AccountName - DataFileName

    Ethan
    Infinite Kind Support

  2. 2 Posted by adrian on 29 Jun, 2020 02:40 PM

    adrian's Avatar

    Ethan,

    I’m using Ubuntu 20.04 with Gnome 3.36.2.

    Just to be clear I’m referring to what is displayed in the Gnome top bar. Also, in the dock/launcher the ‘pinned’ favourite displays ‘Moneydance’ when hovering of it. However, the icon for the launched instance displays ‘com-install4j-runtime-launcher-UnixLauncher’

    When I run xprop WM_CLASS on Moneydance I get the same result. I.e. com-install4j-runtime-launcher-UnixLauncher

    Thanks

    Adrian

  3. 3 Posted by derekkent23 on 29 Jun, 2020 04:09 PM

    derekkent23's Avatar

    I am not support staff just a user.
    Hi Adrian

    I don’t know how much help I can be as I am no Linux expert.

    However, I am running Moneydance on my Linux Ubuntu 20.04 computer.

    Downloaded moneydance_linux_amd64.deb to Download Folder.

    If not installed, install “GDebi Package Installer” in terminal
    sudo apt install gdebi

    You should now see GDebi Package Installer under “Show Application” icon in tray. Make GDebi Package Installer a favourite.
    Run GDebi Package Installer
    Use FILE dropdown OPEN to locate moneydance_linux_amd64.deb then highlight the file and click OPEN.
    After a delay the window will fill in with info on Moneydance.
    Click INSTALL PACKAGE.
    If you get the AUTHENTICATION REQUIRED window enter your Ubuntu password.
    After a delay the Moneydance should install. And the Moneydance icon should appear in the tray. If not check under “Show Application” icon in tray

    Hope this helps.

  4. 4 Posted by adrian on 01 Jul, 2020 12:53 PM

    adrian's Avatar

    Thanks, I’ve just upgraded to the latest version; 2020. (1915)

    I had the same issue before and no change. I also used the create_desktop_file.sh in the install directory to recreate Moneydance.desktop.

    I understand from the following that the only way to set the associated name is within the code

    https://stackoverflow.com/questions/55472843/override-install4j-unixlauncher-wm-class-property?noredirect=1&lq=1

    Therefore I’m interested if no one else observes the problem why it shows up on my system.

  5. 5 Posted by derekkent23 on 01 Jul, 2020 02:43 PM

    derekkent23's Avatar

    I am not support staff, just a user.
    Hi Adrian

    I am no Linux expert, but all I can say is I installed Moneydance 2020(1915) on my Linux Ubuntu 20.04 as outlined in my post. I did not have to do anything else to get it to work. Did you try the process I posted?

    Hope this helps

  6. 6 Posted by adrian on 02 Jul, 2020 12:32 PM

    adrian's Avatar

    Hi Derek,

    Just to be clear, Moneydance works perfectly. There’s just this irritating label in the top bar.

    I’ll try reinstalling over the weekend.

    Thanks

  7. 7 Posted by derekkent23 on 02 Jul, 2020 02:35 PM

    derekkent23's Avatar

    I am not support staff, just a user.
    Hi Adrian

    Is the irritating label part of the Moneydance window or something external to Moneydance and what does it read.

  8. Support Staff 8 Posted by Ethan on 02 Jul, 2020 06:48 PM

    Ethan's Avatar

    Perhaps sending a screenshot would also help us understand what you are seeing? If you're not sure how to take a screenshot, please see http://www.take-a-screenshot.org/

    Ethan
    Infinite Kind Support

  9. 9 Posted by adrian on 04 Jul, 2020 03:15 AM

    adrian's Avatar

    Hi,

    I've tried reinstalling - no difference. Screenshots attached showing:

    1) The launder - as expected
    2) Top gnome bar - showing 'com-install4j-runtime-launcher-UnixLauncher'
    3) Launcher and instance icons - instance shows as 'com-install4j-runtime-launcher-UnixLauncher'

  10. 10 Posted by derekkent23 on 04 Jul, 2020 08:11 AM

    derekkent23's Avatar

    I am not support staff, just a user.
    Hi Adrian

    The screen shots were helpful.

    I get the same results as you.

    It does seem redundant for there to be two icons in the Dock when Moneydance is open. The first icon which give the message “Moneydance” when you mouse hover over it should include the red dot when moneydance is open. No need for a second icon with the hover message com-install4…..
    I guess I don’t find the second icon intrusive as under the app SETTINGS – APPEARANCE I have set AUTO-HIDE THE DOCK.

    Also, in the ACTIVITIES bar it would make more sense when Moneydance is open for it to read Moneydance not com-install4……

    One for Sean the Moneydance developer.

    I also run Linux Mint 19.3 which I prefer to Ubuntu 20.04
    Within Mint with Moneydance open I don’t get a second icon; the icon is simply underlined with a small screen image of the Moneydance window when you hover over the icon. There is no equivalent of the Activities bar, or at least the way I have things set up and with the dock set to hide Moneydance window fill the whole screen, no distractions, full use of the screen.

  11. 11 Posted by adrian on 04 Jul, 2020 12:48 PM

    adrian's Avatar

    Derek,

    Thanks for verifying. I guess it’s the WM_CLASS setting for Gnome that I mentioned in an earlier reply.

    It’s no the biggest issue just clutters up an otherwise clean UI.

  12. 12 Posted by sprimost on 04 Jul, 2020 03:16 PM

    sprimost's Avatar

    From: sprimost

    The task manager setup (properties) seem to be odd, even for a GNOME
    desktop, becuase the right-click of the icon has the wrong application
    (althugh you can start MD that way)..

    It (properties) should read:
      (General) is "Moneydance" and the location should be
    /usr/share/applications. (It is a desktop configuration file as file type.
      (Permissions) I have set up as "root" for user and group (typical for
    desktop icons
      (Application) I have the setup as /bin/sh "/opt/Moneydance/Moneydance"

    I think the last tab is your problem. While you _could_ start Moneydance
    with the java CLI, every installation I have done (and I have gone
    through almost every flavor of LINUX), I have used the bash shell script
    in order to strt MD because it does set up the env's correctly.

    Hope this helps....

    /scp

  13. 13 Posted by adrian on 05 Jul, 2020 02:22 AM

    adrian's Avatar

    Hi,

    My Moneydance.desktop is attached. It's in /usr/share/applications. It was created from the shell script after installation. It doesn't Exec with /bin/sh, but I have also tried that; no difference.

    I've had this issue with Moneydance for as long as I can remember, but lived with it. I don't have the same issue with other java applications e.g. Eclipse.

    Moneydance shows up correctly in the application menus as per the desktop file.

    if I run xprop WM_CLASS I get with Moneydance

    WM_CLASS(STRING) = "com-install4j-runtime-launcher-UnixLauncher", "com-install4j-runtime-launcher-UnixLauncher"

    and for Eclipse I get

    WM_CLASS(STRING) = "Eclipse", "Eclipse"

  14. 14 Posted by sprimost on 05 Jul, 2020 02:31 PM

    sprimost's Avatar

    From: sprimost

    Interesting. I have not seen a .desktop file like this, at least not on
    an Ubuntu install.

    For your reference, here is my .desktop file and then your .desktop
    file. I think if you take out the "TERMINAL" entry, it might make a
    difference. I did a reference back to the GNOME specification, and it
    seemed to indicate (at least tome) that it might be "title" control.

    Hope this helps
    --> Mine
    #!/usr/bin/env xdg-open
    _[Desktop Entry]__
    __Type=Application__
    __Name=Moneydance_
    _Exec=/bin/sh "/opt/Moneydance/Moneydance"__
    __Icon=/opt/Moneydance/.install4j/Moneydance.png_

    --> Yours
    _[Desktop Entry]__
    __Name=Moneydance_
    Comment=Powerful, private, personal finance software
    _Exec="/opt/Moneydance/Moneydance"_
    Terminal=false
    _Type=Application_
    _Icon=/opt/Moneydance/resources/moneydance_icon128.png_
    Categories=Office;Finance
    StartupWMClass=moneydance
    Keywords=money,budget,budgeting,finance,finances,accounting,investing,investment,stocks,exchangerates,prices,quicken

  15. 15 Posted by adrian on 06 Jul, 2020 12:31 PM

    adrian's Avatar

    sprimost,

    The contents of your .desktop file are exactly the same as the default one in /opt/Moneydance. I've tried that one and no difference.

    My one is the result of running create_desktop_file.sh

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac