MoneyDance won't start

Gary Johnson's Avatar

Gary Johnson

02 Jul, 2020 11:45 PM

I have a new Win 10 machine. I moved MoneyDance as per your instructions. It's been running fine for 4 or 5 days now. Today I went to it (it was still up from last night) and it was locked up. I closed it, and now it won't start. Error attached.

  1. Support Staff 1 Posted by Ethan on 03 Jul, 2020 02:27 PM

    Ethan's Avatar

    Can you send me your errlog.txt file? From your screenshot, it looks like you're using Windows, so it should be located at:

    C:/Users/(yourusername)/.moneydance/errlog.txt

    Ethan
    Infinite Kind Support

  2. 2 Posted by Gary Johnson on 03 Jul, 2020 02:37 PM

    Gary Johnson's Avatar

    Attached. thanks.

  3. 3 Posted by Gary Johnson on 03 Jul, 2020 06:03 PM

    Gary Johnson's Avatar

    Just checking to confirm you got the file on my earlier email.

    Thanks

  4. 4 Posted by sth on 03 Jul, 2020 06:15 PM

    sth's Avatar

    Gary,

    A quick read of the beginning of the Error Log shows that the data file is corrupted.

    opening last file: C:\Users\16303\OneDrive\Documents\MoneyDance\Current file\Personal Finances-20171110-2209-20171114-1944.moneydance ??g?????m?Error reading processed transaction file state reading trunk data tiksync/trunk java.io.IOException: javax.crypto.BadPaddingException: Given final block not properly padded. Such issues can arise if a bad key is used during decryption.

    This can happen when you store the data file on a network drive which it appears you did. It is STRONGLY encouraged to not store your data file on a network driver such as One Drive. MD has a file structure with thousands or tens of thousands of transaction files which causes corruption when a network drive tries to synchronize with the cloud.

    My guess is that your file is corrupted and you need to go to a backup. Hopefully you are using the automated backup option and have some older copies. The preferences will show you where your backups are stored and the Help->Show Backup Folder will also open that folder if it is the default.
    (NOT IK support)

  5. 5 Posted by Gary Johnson on 03 Jul, 2020 06:18 PM

    Gary Johnson's Avatar

    Thanks for the input. I'm not on a network so that's not the issue. Also,
    I can't get the app to open, even though I've tried to go to my backups.

  6. 6 Posted by Gary Johnson on 03 Jul, 2020 06:35 PM

    Gary Johnson's Avatar

    I think I've got it going from a backup. Thanks

  7. 7 Posted by sth on 03 Jul, 2020 07:06 PM

    sth's Avatar

    Good. It seems that the User directory for that machine is on Microsoft One Drive which is a network, cloud synchronization system. It appears that the entire User Account 16303 is network synchronized. This may be a corporate decision and attempts to be invisible to the user, but it can have consequences.

    Maybe it is just an unfortunate naming setup of the system you are on. Hard to say but it looks suspicious.

  8. 8 Posted by Gary Johnson on 03 Jul, 2020 07:13 PM

    Gary Johnson's Avatar

    Yeah, I get what you mean now. It's a One Drive which Microsoft does
    everything they can to push you to it and hide what they're doing, so it
    got backed up there inadvertently.

    Thanks for your help.

  9. 9 Posted by sth on 03 Jul, 2020 07:28 PM

    sth's Avatar

    Glad it is all worked out. You obviously realize the importance of backups! These are usually valuable financial data and a lot of effort went into accumulating things. Having multiple backups and some off site is a very very good thing!
    Stay safe, stay sane.

  10. Support Staff 10 Posted by Ethan on 03 Jul, 2020 09:02 PM

    Ethan's Avatar

    I'm glad to hear things have been sorted out before I could respond again! Thanks sth for your suggestions.

    I definitely second the recommendation not to store your data file in a location that is used for cloud-based syncing. That was almost certainly the cause of this error. If you want to sync with other systems you can find setup instructions at https://infinitekind.tenderapp.com/kb/syncing-and-sharing-data/. It's fine to have backup file sent to a syncing service, since they are just created once, not consistently written to like active data files.

    Ethan
    Infinite Kind Support

  11. 11 Posted by dwg on 03 Jul, 2020 09:25 PM

    dwg's Avatar

    I'm a fellow user.

    The name of the data set also suggests that you have restored from backup on a couple of previous occasions but have not taken the extra steps to rename the file to something more friendly. While this may not be a problem now we have seen instances of users that have done this over time and have exhausted the length that a file name can be. This can cause some interesting problems which are not immediately obvious as to the cause.

  12. 12 Posted by Gary Johnson on 03 Jul, 2020 09:27 PM

    Gary Johnson's Avatar

    so when you choose "export backup" you can/should choose a user-friendly
    name?

  13. 13 Posted by dwg on 03 Jul, 2020 10:30 PM

    dwg's Avatar

    I'm a fellow user,.

    No not on the export. When you create the backup you want a name that really distinguishes the backup, Moneydance does this by appending date and time stamp information as appropriate. This is a good approach as you can have a series of backups and see exactly the point in time they were made.

    When you do a restore in Moneydance it uses this name to create the new data set hence it avoids overwriting any data set that you have on disk again this is a good thing.

    To get a better name requires human intervention so it needs deliberate action, and being deliberate requires intention. Moneydance is doing what is can to avoid accidents so it does not provide this capability within the software, so to do on Windows you would use something like Explorer to rename the data set.

    For more information see:

    https://infinitekind.tenderapp.com/kb/file-locations-and-changes/renaming-files

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Already uploaded files

  • moneydanceerror.docx 24.4 KB

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac