Find and Replace doesn't find known Tags

shiner03's Avatar

shiner03

20 Sep, 2020 12:05 AM

Here is a screenshot of 2 transactions in 2010 with the Tags: Cleaning:Soaps, Laundry, Clean, etc (see screen shot)
 I copied these Tags to make sure they were exact, then pasted them into the FREE TEXT area of the Find and Replace, Nothing found (see screen shot). Then I pasted the Tags into the TAGS area of the Find and Replace. Again, nothing found (see screen shot). Using Moneydance 2020.1 (1928) for Mac. Why isn't the Find and Replace not finding these transactions?

  1. 1 Posted by mhoggie on 20 Sep, 2020 01:23 AM

    mhoggie's Avatar

    just a user,

    I think your problem is searching for "Cleaning:Soaps, Laundry, Clean, etc" in both the Free text field and Tag (also noted Tag search is not checked). Reset Find and Replace, then only paste your search string ( Cleaning:Soaps, Laundry, Clean, etc ) in the Tags section with Tags checked. (click None to clear, then paste)

  2. 2 Posted by shiner03 on 20 Sep, 2020 03:00 AM

    shiner03's Avatar

    Well, that's how I started out. Find and Replace still shows NONE. Here's the screenshot

  3. 3 Posted by mhoggie on 20 Sep, 2020 03:23 AM

    mhoggie's Avatar

    just a user,

    When I first read your post, I thought the problem was with the colon or comma in the Tag. Those characters are commonly use as delimiters and I thought that was the problem. But when I used your Tag "Cleaning:Soaps, Laundry, Clean, etc", it did work within the Find and Replace program to find the transactions I Tagged like yours. But it may differ with the OS. I'm on Win10 64 bit. MD build 1928. I did notice when I check the Tag drop down, that your Tag was delimited by the comma. So I see "Cleaning:Soaps" "Laundry" "Clean" and "etc" as separate tags. You might try replacing the commas with a dash and see if that changes search results.

  4. 4 Posted by dwg on 20 Sep, 2020 03:38 AM

    dwg's Avatar

    I'm a fellow user

    The structure of "Cleaning:Soaps, Laundry, Clean, etc" suggest this may be a category rather than a tag.

    I may help if we can see what one of the transactions looks like.

  5. 5 Posted by shiner03 on 22 Sep, 2020 06:52 PM

    shiner03's Avatar

    dwg,
    The 1st image in this thread shows a copy of 2 transactions with the Tag, "Cleaning:Soaps, Laundry, Clean, etc" Is there more detail I should screenshot to show what the transactions looks like?

  6. 6 Posted by dwg on 22 Sep, 2020 09:25 PM

    dwg's Avatar

    Sorry. I missed seeing that screenshot.

    I've tried it in a test data set on Moneydance 2020 build 1928 and I cannot reproduce the problem if I select tags and highlight the tag I want found. Free text does not work, but I did not expect it to as it should not look at the tag field.

    While I cannot reproduce the problem I do see an issue with tags like this. In tags a comma is the delimiter so by definition Laundry Clean and etc are all separate tags.

  7. 7 Posted by shiner03 on 22 Sep, 2020 11:08 PM

    shiner03's Avatar

    When I did a Find & Replace on the Merchant, "Ace," using Free Text, Ace clearly shows 2 transactions with those tags, "Cleaning:Soaps, Laundry, Clean, etc." (see screen 1st shot).

    To test if the comma effected the search, I used Find now for only the single words from within this tag, Cleaning:Soaps, Laundry, Clean, etc, to see if I would get any results. I searched using only "Cleaning" (see screen shot) and again using only "Soaps" and again using only "Laundry" but still nothing. (see remaining screenshots).

    Originally, I was trying to eliminate this lengthy tag and was able to successfully Find multiple other transactions with this comma-delimiter tag, "Cleaning:Soaps, Laundry, Clean, etc" and delete those so I knew it worked. But when Find could not find any more of these, I expected the Tags list to not have any more of these in it. But it was still there. The only way I found the "Ace" transactions with this tag was using the search box in the upper right corner of the transactions register page. Interesting that this search box found the comma-delimiter tag but the Find and Replace found many, initially, but did not find the last ones, some within the "Ace" transaction. This casts doubt that Find may not be 100% reliable. Is this a bug?

  8. 8 Posted by dwg on 22 Sep, 2020 11:19 PM

    dwg's Avatar

    As you can see I was not able to reproduce the problem, it suggests something that is local to your system is causing the issue. I am not thinking it is anything to do with the Operating System or in Moneydance or even the extension, the most likely thing I think is that it is something that is in the text string, and is possibly hidden from view. It certainly does appear to be limited to those specific transactions.

    I'm reaching but there is nothing standing out that explains it.

  9. 9 Posted by shiner03 on 22 Sep, 2020 11:21 PM

    shiner03's Avatar

    Well thanx anyway, Glad that at least the search box found these. I'll just delete them manually.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Already uploaded files

  • Transactions.jpg 101 KB
  • Free_Text.jpg 128 KB
  • Tags.jpg 131 KB

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac