chromeos linux deb install

JY's Avatar

JY

14 Jun, 2021 12:09 AM

Hi

I am trying to get Moneydance to work on chromeos, I have enabled linux. After installing the deb, the MD icon spins with nothing happening.

I tried running the Moneydance script in opt/Moneydance and I get

No suitable Java Virtual Machine could be found on your system.
The version of the JVM must be at least 14.
Please define INSTALL4J_JAVA_HOME to point to a suitable JVM.

Then installed JVM. And set the INSTALL4J_JAVA_HOME and nothing is helping.

Any ideas?

Thanks

  1. 1 Posted by dwg on 14 Jun, 2021 03:58 AM

    dwg's Avatar

    I'm a fellow user.

    Moneydance comes with its own version of Java embedded so any system Java is not used.

    Perhaps the message about Java 14 is a clue, what version of Moneydance have you installed?

  2. 2 Posted by JY on 14 Jun, 2021 04:02 AM

    JY's Avatar

    Thanks for replying. I downloaded the latest debian package on the moneydance download page.

    The install works fine, but when I click the icon it spins endlessly. There is no error or anything, just endless spinning.

    Thats what prompted me to poke around in the linux terminal and that is where i found the error message I copy pasted.

  3. 3 Posted by dwg on 14 Jun, 2021 10:34 PM

    dwg's Avatar

    Moneydance 2021.1 build 3069 bundles Java 15.0.1 so I do not see where a Java 14 message is coming from

    You can see the include Java under /opt/Moneydance/jre/bin and run java itself there to get the version.

    All I can say is that kit installs and works under Linux.

  4. 4 Posted by JY on 14 Jun, 2021 11:56 PM

    JY's Avatar

    Hi

    Well it does not work for me.

    And running java -version in /opt/Moneydance/jre/bin does not work.

    I have removed linux on the chromebook and re-enabled it and tried a few times. All other apps I try to install via apt or flatpak are working fine. Only Moneydance is not working. I have tried all of the debian versions on the site. Most recent, 2020, 2017.

    Will someone from infinitekind chime in? As a user of moneydance on windows for many years, I do not want to lose it. This is literally the only issue I have with my chromebook.

    Thanks

  5. 5 Posted by smith.greg on 15 Jun, 2021 01:25 AM

    smith.greg's Avatar

    I am a fellow user, and for what its worth, I have also experienced this problem, with Moneydance 2021.1 linux deb release running on the Chromebook linux environment. Install completes, but when opening Moneydance the app spins.

  6. 6 Posted by tgilbert666 on 15 Jun, 2021 05:12 AM

    tgilbert666's Avatar

    When you say "running java -version ... does not work" could you be more explicit?

    Also, on other platforms, md writes an errlog to disk. You'll need to search the kb for the unix default location, but have you checked whether it is being written?

    And the error is not necessarily a Java 14 message. According to you it says "at least ...14" which (potentially) makes it equally a Java 15 message to my mind.
    -Tony (fellow user)

  7. 7 Posted by JY on 15 Jun, 2021 12:23 PM

    JY's Avatar

    Thanks for trying to help me out Tony. Here are two answers for you,

    running

    /opt/Moneydance/jre/bin$ java -version

    result

    -bash: java: command not found

    as for the errlog.txt, I searched the entire file system and cannot find it. It is not in the Moneydance folder or anywhere else. Even though the app is spinning.

    This is what I get if I try to run /opt/Moneydance/Moneydance

    No suitable Java Virtual Machine could be found on your system.
    The version of the JVM must be at least 14.
    Please define INSTALL4J_JAVA_HOME to point to a suitable JVM.

    Thanks

  8. 8 Posted by dwg on 15 Jun, 2021 09:16 PM

    dwg's Avatar

    I there a file named "java" in /opt/Moneydance/jre/bin ?

    If there is it needs to also be set as executable, there should be 5 files in the directory.

  9. 9 Posted by JY on 15 Jun, 2021 10:05 PM

    JY's Avatar

    Here are the contents of the directory /opt/Moneydance/jre/bin

    -rwxr-xr-x 1 root root 12808 May 20 11:16 java
    -rwxr-xr-x 1 root root 12856 May 20 11:16 jrunscript
    -rwxr-xr-x 1 root root 12824 May 20 11:16 keytool
    -rwxr-xr-x 1 root root 12824 May 20 11:16 rmid
    -rwxr-xr-x 1 root root 12824 May 20 11:16 rmiregistry

    this
    /opt/Moneydance/jre/bin/java

    returns
    -bash: /opt/Moneydance/jre/bin/java: cannot execute binary file: Exec format error

    if i do java without the full path (i am in the directory) I get
    -bash: java: command not found

  10. 10 Posted by JY on 15 Jun, 2021 10:09 PM

    JY's Avatar

    also look at this

    sudo /opt/Moneydance/jre/bin/java

    /opt/Moneydance/jre/bin/java: 1: /opt/Moneydance/jre/bin/java: ELF: not found
    /opt/Moneydance/jre/bin/java: 2: /opt/Moneydance/jre/bin/java: @H+@8: not found
    /opt/Moneydance/jre/bin/java: 3: /opt/Moneydance/jre/bin/java: Syntax error: "(" unexpected

  11. 11 Posted by JY on 15 Jun, 2021 10:26 PM

    JY's Avatar

    I am wondering if it is the CPU. This chromebook is ARM not intel.

  12. 12 Posted by dwg on 15 Jun, 2021 10:35 PM

    dwg's Avatar

    There certainly looks to be a fundamental problem there.

    I'm sitting on a Linux system (Mint) and I certainly do not get the results you are. I can only conclude that it is either a faulty Moneydance install or that there is something in the Linux subsystem that Chrome has installed that is causing this.

    I do not think there are too many people around using Moneydance under Chrome so finding someone with a machine that can trace the problem could be an issue. The developer did a test install under Chrome some time ago but I do not know if that was an owned or borrowed machine.

    Hmm an ARM cpu, you could have something there the Linux kit is Intel, normally to use Intel binaries on ARM the OS has a compatibility layer. For example on Mac Rosetta is used. On Microsoft Surface pro X WoW is used to run Intel 32 bit applications. That is how Moneydance runs on these platforms.

    Moneydance has not released an ARM Linux kit, I do not think the demand has been there to justify it.

  13. 13 Posted by tgilbert666 on 16 Jun, 2021 02:22 AM

    tgilbert666's Avatar

    Hmm, I don't have access to a chromebook myself either, but this old post

    https://infinitekind.tenderapp.com/discussions/general-questions/63...

    suggests that PERHAPS the ARM processor is not a problem in and of itself, although admittedly you may be missing a required wrinkle. Have you reveiwed ALL the KB articles that mention ARM and/or Chrome? Perhaps you can glean something there?

  14. 14 Posted by tgilbert666 on 16 Jun, 2021 02:39 AM

    tgilbert666's Avatar

    Also, perhaps this is off-topic, and I've no personal experience (yet), but I bookmarked it recently for when I get around to trying Moneydance on my rPi4 which is ARM-based

    https://askubuntu.com/questions/1303451/how-to-run-moneydance-2021-...

    Maybe something in there will gel with your own experience?

    Apologies if it's a stupid question but Is it possible you need the ARM version of Java and have the x86 version installed? (It sounds like a stupid question. :-( sorry)
    -Tony (fellow user)

  15. 15 Posted by JY on 16 Jun, 2021 05:00 AM

    JY's Avatar

    OK great news. The steps described here worked!

    https://askubuntu.com/questions/1303451/how-to-run-moneydance-2021-on-ubuntu-20-10-on-a-raspberry-pi-4

    It took me a few attempts to get everything (I am new to linux so I had to google everything basic like how to use vim).

    Anyway it worked! Moneydance was very small but I seemed to fix that with the "use low density" option.

    I havent copied over my old data yet, but at least the app launches.

    Thanks

    PS too bad nobody from infintekind addressed this at all.

  16. 16 Posted by Stuart Beesley ... on 16 Jun, 2021 05:41 AM

    Stuart Beesley - JUST A FELLOW USER and Toolbox ‘guy’'s Avatar

    Nice fix. In simple terms, these instructions get you to download / install the correct arm version of Java and javafx and then setup up the environment to point to/use this version of Java. Lastly you modify the launch parameters for MD to include the correct javafx.

    (Not support, just a fellow user)

  17. 17 Posted by smith.greg on 16 Jun, 2021 10:43 AM

    smith.greg's Avatar

    Great work- I suspect this is also the problem I have, as I'm trying to run on an ARM based Chromebook. Could I please ask for the specific commands you used- I to am a Linux newbie;)

  18. 18 Posted by JY on 16 Jun, 2021 11:34 AM

    JY's Avatar

    I will add some details later after I move over all my data and see if it works.

    One thing I can add is that although the program launches, it does not look anywhere near as nice as on a mac or a pc. It looks like an old java app if you know what I mean. And there are strange visual artefacts that come and go. Weird lines on the screen, etc.

    I guess it is the jdk and javafx. I am using jdk16 that I downloaded manually. And whatever jfx apt gave me.

    Does the company still support this app? I upgraded on Oct 23 2020 and have been a customer for many years. But there doesn't seem to be any support.

    I will try this out for a while but might switch to something if I get annoyed by the display issues that come and go.

    Thanks

    J

  19. 19 Posted by dwg on 16 Jun, 2021 09:47 PM

    dwg's Avatar

    Moneydance looks slightly more workman like on Linux than it does on Windows with some screens but it still works the same, looks don't bother me all that much, I'm more about functionality.

    TIK have shown that Moneydance installs on ChromeOS in the Linux subsystem but I believe that is with an Intel based system, I have never seen a published official support position on ChromeOS so I regard what they have done as a Proof of Concept, it will be up to Sean how far he wants to support the OS. In this instance you have cobbled together an install on ARM using a separately installed Java that Moneydance is not build round on an architecture that they do not provide a kit for (Moneydance 2021.1 uses java 15.01 FWIW) so I think you will be a bit on your own with the setup you have created.

  20. 20 Posted by JY on 16 Jun, 2021 11:39 PM

    JY's Avatar

    yes but someone from TIK could have piped in to say what you just said, even without providing a solution,. Instead, they completely ignored my post.

  21. 21 Posted by dwg on 17 Jun, 2021 12:45 AM

    dwg's Avatar

    I would personally like t see a greater level of support involvement in the forums than what I am today.

    All I can really suggest you do is bring it to the attention of the company's owner.

    In the case of Moneydance that means Sean Reilly and his email is

    sreilly (at) infinitekind (dot) com

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac