Unable to install Money Dance in Ubuntu Linux

cje.maths's Avatar

cje.maths

19 Jul, 2021 04:26 PM

I've been using Moneydance for over 10 years on Windows and iPhone. Would like to migrate onto my new Linux box, but when I try to install I get:

"Failed to install file: not supported"

I am running Ubuntu Linux version 20.04 (and I've checked that I have the up to date version)

I have tried to install Moneydance 2019.0.0.1814 from the Ubuntu Software Center

I get the same problem if I try downloading directly from the Infinite Kind website.

From a quick browse, others have had problems - at least in the past.

Any advice or suggestions? I'm Linux literate but don't have in depth knowledge.

  1. 1 Posted by sprimost on 19 Jul, 2021 06:13 PM

    sprimost's Avatar

    From: sprimost (not IK support)

    Somebody may correct me if I am wrong but I do not see a version 2019
    off of the previous versions of Moneydance older versions download page
    (https://infinitekind.com/previous-versions-of-moneydance) although I am
    running 2019.3 with no problem under the LTS version of Ubuntu.I loaded
    that version to update from 2017 a number of years ago. It is my
    understanding that 2020 version is a free upgrade to a purchase of 2017.
    I would not recommend getting the software from the Ubuntu software
    Center. It sounds like it is a bad "deb" file. Better to go to the IK site.

    I would re-check the file that you are using, as it may not be correct
    for Ubuntu. While 32-bit does work at the time I did an initial install,
    I always use the 64-bit version since there is a lot of emphasis on
    supporting on 64-bit LINUX/Ubuntu.

    I am running 2020 with 64-bit and having no issues on either Ubuntu or
    Manjaro. So t might just be a matter of getting the correct file or
    using one of the three ways to install "deb" files.

    I have been most successful with using Gdebi application for installing
    deb packages with dependencies under Ubuntu. You did not mention the
    desktop environment used (I have KDE). Gdebi works under all desktop
    environment.

    Also, one thing to note....lots of recommendations on the forum that one
    should use the same version of MD on all systems, especially if planning
    to sync.

    Hope this helps.

    /scp

  2. 2 Posted by cje.maths on 19 Jul, 2021 08:11 PM

    cje.maths's Avatar

    Thanks - I suspect that, as you say, its a question of getting the correct file.

    I'll look into your suggestions tomorrow.

    cje

  3. 3 Posted by cje.maths on 22 Jul, 2021 12:34 PM

    cje.maths's Avatar

    Problem solved.

    I decided to upgrade to the current version (with discount for existing licence). Paid my fee, ran download - once again the install failed.

    Now, I realised that when I clicked on the download icon on the website I was accepting the default option of using the Ubuntu (?) Software Installer. So I downloaded again, but this time specifying "save as file". Double clicked on the deb file, and all went well.

    I am up and running. Now just need to import the old data file, reset the syncing for the new machine, and (per scp's recommendation) upgrade to the current version of MD on other devices.

    OK to close this call. Maybe a note on the download page recommending to save as file when you download?

    cje

  4. Support Staff 4 Posted by Ethan on 25 Jul, 2021 09:48 PM

    Ethan's Avatar

    I'm glad to hear things have been sorted out. What you describe is very strange. It sounds like perhaps you only partially downloaded the installation file before opening it, or perhaps your browser tried to open it before the download had completed. Those are the only things I can think of that would have lead to that result. I remember that happening quite a bit several years ago with Apple users browsing with Safari, but I don't remember ever seeing this on a Linux distribution.

    Ethan
    Infinite Kind Support

  5. 5 Posted by sprimost on 25 Jul, 2021 09:55 PM

    sprimost's Avatar

    From: sprimost

    Just a thought...although you did not mention which browser is being
    used, the browser has its own set of associations. I think you got
    caught in that tangle.

    A note to the future....probably a good idea to get to the CLI (Konsole,
    if use KDE) and use "sudo dpkg -i package_file.deb". YOu will have more
    control of what happens.

    Glad to hear....

    /scp

  6. Maddy closed this discussion on 27 Jul, 2021 03:21 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac