Summary Page Net Worth and Toolbox

rkmt's Avatar

rkmt

02 Nov, 2021 05:02 PM

I have been trying to use the Toolbox extension (in advanced mode) to exclude a couple of accounts from the Net Worth on the summary page. I go through the whole procedure to remove an account and am finally presented with a disclaimer box (see attached screenshot).

It seems that if I change the 'NO' to a 'YES' or anything else, and press OK I always then get a message telling me I have not accepted the disclaimer so no changes made. Am I missing something obvious here that I should do to make this work?

I'm using Moneydance 2022.2 build 4060 on Windows 10

Thanks!

  1. 1 Posted by dtd on 02 Nov, 2021 06:10 PM

    dtd's Avatar

    just a user - don't know why it's not showing, but you have to type

    IAGREE

    exactly like that. (no spaces either)

  2. 2 Posted by Stuart Beesley ... on 02 Nov, 2021 06:27 PM

    Stuart Beesley - JUST A FELLOW USER and Toolbox ‘guy’'s Avatar

    I agree... You should be typing 'IAGREE'
    I will check out the dialog box....

  3. 3 Posted by Stuart Beesley ... on 02 Nov, 2021 06:29 PM

    Stuart Beesley - JUST A FELLOW USER and Toolbox ‘guy’'s Avatar

    You should be seeing this... What Theme/Font/font size are you running?

  4. 4 Posted by Stuart Beesley ... on 02 Nov, 2021 06:31 PM

    Stuart Beesley - JUST A FELLOW USER and Toolbox ‘guy’'s Avatar

    ... PS - I've shortened the question for the next release ....

  5. 5 Posted by rkmt on 02 Nov, 2021 07:13 PM

    rkmt's Avatar

    Ah OK!
    Thanks so much for getting back, dtd and Stuart. I am using currently the Flat Dark theme, but I did try switching to another theme to try and troubleshoot at one point. I am now thinking it is perhaps down to the fact I have my font size set at plus 4 (see attached) which works best for me on my 4k monitor. Could that be causing the dialogue to be truncated? I didn't test that, but everything else seems to be set to default.

    Thanks once again for putting me right!

  6. 6 Posted by Stuart Beesley ... on 03 Nov, 2021 07:27 AM

    Stuart Beesley - JUST A FELLOW USER and Toolbox ‘guy’'s Avatar

    Could you try font+1 just as a test and let me know?

  7. 7 Posted by rkmt on 03 Nov, 2021 10:54 AM

    rkmt's Avatar

    Hi Stuart. I just tried at font size +1 but it was still truncated exactly as in my original screenshot. I am wondering now if it could possibly be something to do with my monitor set up. I have one 4k main monitor and two HD monitors, used mainly for a recording studio set up. The Windows display size is set to what Windows recommends which is 100 per cent for the HD monitors and 150 per cent for the 4k one (see attached).
    I tried opening the toolbox window on both resolutions of monitor with the same result.

  8. 8 Posted by Stuart Beesley ... on 03 Nov, 2021 10:56 AM

    Stuart Beesley - JUST A FELLOW USER and Toolbox ‘guy’'s Avatar

    OK, thanks... Try this version...

    Download from:
    https://github.com/yogi1967/MoneydancePythonScripts/raw/master/tool...

    Unzip.
    Make sure the enclosed is called toolbox.mxt
    With MD open, double click the .mxt to install
    Accept the unsigned warnings,...

    Let me know?

  9. 9 Posted by rkmt on 03 Nov, 2021 11:19 AM

    rkmt's Avatar

    Excellent Stuart!
    Apart from the 'unsigned extension' warning bar on the top of the summary page, this one worked with all text visible at fontsize +4.

    Well done and thanks :) Will this be the new version?

    Richard

  10. 10 Posted by Stuart Beesley ... on 03 Nov, 2021 11:23 AM

    Stuart Beesley - JUST A FELLOW USER and Toolbox ‘guy’'s Avatar

    It will eventually make its way through to being the official signed version, but I will wait for more features/changes before pushing it through.

  11. 11 Posted by rkmt on 03 Nov, 2021 11:31 AM

    rkmt's Avatar

    That's great to know.
    Meanwhile thanks again both for your help in sorting my problem and more importantly writing such a really useful extension in the first place!
    Richard.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Already uploaded files

  • Screenshot_2021-11-02_164319.png 24 KB
  • Screenshot_2021-11-02_165848.png 11.3 KB

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac