Moneydance/MD+ is not downloading ... it hangs

Jason Bryan's Avatar

Jason Bryan

13 Nov, 2021 04:28 PM

I have been using Moneydance for years. I started using MD+ about a month ago. It has been working great. However, this morning it is not downloading transactions ... neither for MD+ nor for accounts that I already had setup (like Chase Visa that isn't configured to use MD+). I am getting errors in the errlog.txt relating to checking MDPlus license and polling MD+ status. I've included the errlog.txt file. I also tried to download the "Toolbox" extension, and its progress bar has just been going back and forth now for about 25 minutes. Every now and then, I'll see a message in the status bar of the app saying that it is downloading transactions for another of the accounts connected through MD+. I can only assume that each attempt has a really long timeout, and then the app moves to the next one. I have exited the program. The main window went away and the normal dialog that comes up for a few seconds on every exit did come up. After that, though, another dialog came up saying Downloading transactions for Checking. Again, I assume that was because a thread or something was running that timed out and went to the next account. I let it sit for a few minutes and finally killed the app from the command line. I restarted the application, and the same thing is happening. Something is definitely not right. Any help would be greatly appreciated.

I have a good internet connection.
I am running the latest Moneydance.
I am on Ubuntu 20.04.

  1. 1 Posted by Stuart Beesley ... on 13 Nov, 2021 04:59 PM

    Stuart Beesley (Mr Toolbox)'s Avatar

    Hmmm. Md+ is crashing and probably that’s causing the other issues. It’s interesting that QL runs OK before md+ crashes.

    What do you have setup in MD/File/Preferences/Network? Any settings at all set for proxy etc?

    Are you running a VPN, Proxy or anything like PiHole?

    Can you run MD from Terminal with the -d parameter and then try to install toolbox again, and then try download and then post that console errlog.txt ?

  2. 2 Posted by Jason Bryan on 13 Nov, 2021 05:12 PM

    Jason Bryan's Avatar

    Thanks for the quick reply. I'm away from my computer at the moment. I'll
    try what you ask when I can. To answer your questions: I have not added any
    proxy settings, I'm not running a proxy nor VPN, and I am running PiHole.
    If that is causing an issue, why would it work for the past 3 to 4 weeks?

    ____________
    Jason Bryan

  3. 3 Posted by Stuart Beesley ... on 13 Nov, 2021 05:18 PM

    Stuart Beesley (Mr Toolbox)'s Avatar

    Thanks have no idea, but PiHole sometimes interferes with OFX too. What happens if you disable it and try again (as a test)?

  4. 4 Posted by Jason Bryan on 13 Nov, 2021 05:22 PM

    Jason Bryan's Avatar

    I'll give it a shot when I can. I am also looking through logs for any
    blocked requests that may look legitimate.

    ____________
    Jason Bryan

  5. 5 Posted by Jason Bryan on 13 Nov, 2021 09:10 PM

    Jason Bryan's Avatar

    It looks like the same thing happens with PiHole disabled. I reopened the app normally just to make sure it wasn't some network issue this morning. Same result. I then verified the settings in app (no proxy or anything). I exited (and had to kill since the dialog never went away after the main window closed). I ran again from command line with the -d option. Things look the same. I tried to install "Toolbox", and let it sit for about 10 minutes. It never did anything but show the progress bar going back and forth. I've included the command line output. PiHole disabled the whole time.

  6. 6 Posted by Jason Bryan on 13 Nov, 2021 09:58 PM

    Jason Bryan's Avatar

    I uninstalled and reinstalled the latest .deb file. No change. I downloaded the Toolbox extension and installed it from the file. It runs, but I really don't know what it does or if it will help.

  7. 7 Posted by Jason Bryan on 13 Nov, 2021 10:05 PM

    Jason Bryan's Avatar

    Well, I don't know if just running the Toolbox extension did something, but while I was typing my last message, errlog.txt started scrolling tons of stuff. I just had everything running in the background (with PiHole enabled). All of my transactions started downloading. Maybe it was an issue with Plaid and MD+? I don't really know. If this is something that needs to be debugged further, please let me know. After I finish this session, I will exit the app and restart to see if the app starts up and behaves normally with no delays.

  8. 8 Posted by Jason Bryan on 13 Nov, 2021 10:35 PM

    Jason Bryan's Avatar

    So that last run of the app downloaded all transactions for accounts using MD+, with exception of the first one, and my "old way" download of Chase Visa. I did what I needed to do and exited. I restarted the app, and it is back in the state of not being able to download and just timing out connections. After a few minutes, I'll see the "next" account attempt to download. It seems that it may be a problem on the Plaid side (maybe??). Maybe in that last run, something finally worked after the initial attempt to download for the first account and it downloaded all but the first. I don't know. I am caught up for the day. I'm going to hope it is something wrong on the Plaid side. I'll try again in a day or two.

  9. 9 Posted by Stuart Beesley ... on 13 Nov, 2021 10:39 PM

    Stuart Beesley (Mr Toolbox)'s Avatar

    No Toolbox would not have made any difference or fixed/changed anything. It’s bombing connecting to IK servers/Plaid….

  10. 10 Posted by Jason Bryan on 14 Nov, 2021 02:43 PM

    Jason Bryan's Avatar

    So, this morning everything seems to be fine. I'm going to chalk it up to a server problem somewhere down the line. Sorry to bother and thanks for the help. At least I found out about the Toolbox extension and got it installed. It looks really helpful.

  11. System closed this discussion on 13 Feb, 2022 02:50 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac