Bug - new transactions on iOS (iPhone)

Dave Ashley's Avatar

Dave Ashley

19 Nov, 2021 01:40 PM

Hi

I'm noticing a bug when entering new transactions using my iPhone XR (iOS 15.1)

I'm seeing the issue about one in 3 times when creating a new transaction. Never happened before this past month in years of using the app.

Description of bug: When I click on 'Save' after entering all the transaction details nothing appears to happen and the transaction screen doesn't disappear as it should. I press 'Save' again, and again nothing appears to happen. I then close and re-open the app to find that those transactions had actually saved (I then delete the redundant entry to put my account straight).

Is this something you're aware of?

  1. Support Staff 1 Posted by Maddy on 22 Nov, 2021 01:07 PM

    Maddy's Avatar

    Hi Dave,

    We are sorry to hear about the problem you have encountered.

    Which version and build of Moneydance are you using?
    To check, open Moneydance and select Moneydance --> About Moneydance, where the version and build number will be displayed.

    Can you let me know which operating system you're running on your computer?

    Is the data on your desktop up-to-date?
    When you navigate to File --> Syncing, which syncing method do you have selected?
    Have you tried uninstalling the mobile app and reinstalling version 2.23 from the Mac App Store?

    Thank you

    --
    Maddy, Infinite Kind Support

  2. 2 Posted by Dave Ashley on 22 Nov, 2021 05:09 PM

    Dave Ashley's Avatar

    Hi Maddy

    Not sure what my desktop (Mac) has to do with the issue as the problem is limited to my iPhone and occurs randomly when I’m trying to save a new transaction, but here goes…

    Version 2022.2 (4060)

    MacOS Catalina 10.15.7

    Data on the desktop is up to date and synced

    Sync method: Dropbox folder

    I currently have version 2.23 on my iPhone

    Regards

    Dave

  3. 3 Posted by sth on 22 Nov, 2021 07:02 PM

    sth's Avatar

    @Dave, the phone is a secondary access to the synchronized data folder. The Desktop Mac is a primary access so it does matter. Especially if MD versions are wildly different and out of date. Doesn't seem to be an issue here.

    I would try completely resetting the sync.
    1. Turn off sync on your desktop (primary computer) and quit MD.
    2. Find the .moneydancesync folder in Dropbox or iCloud and delete it
    3. Open MD on the iPhone an hopefully it will show an error and no data. (it has been awhile since I tried the iPhone app and had other issues that I didn't debug)
    4. Close the iPhone app
    5. Main computer, turn on sync (Dropbox Folder seems to work the best)
    6. Wait for the Dropbox icon to show that files/folders are synced
    7. Open the iOS app and connect to the new sync system

    (hopefully someone will correct me if I have left out a step but this is the general idea to start the sync over again)

    https://infinitekind.tenderapp.com/kb/syncing-and-sharing-data/sync...

    (NOT IK support)

  4. Support Staff 4 Posted by Maddy on 23 Nov, 2021 09:17 AM

    Maddy's Avatar

    In addition to what sth suggested, from the mobile app, choose disconnect before restarting the sync process.

    --
    Maddy, Infinite Kind Support

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac