Moneydance+ merges even though Auto Merge is off

kenny's Avatar

kenny

22 Nov, 2021 11:11 PM

I am (currently) a Moneydance+ subscriber. Even though I have "Automatically Merge Downloaded Transactions" turned off, my downloaded transactions are being merged.

For me, this is unacceptable. I need to be able to manually merge downloaded transactions. When will this issue be fixed?

I have a couple other Moneydance+ related issues but will hold off on those for now and likely post to a different Subject.

  1. Support Staff 1 Posted by Maddy on 24 Nov, 2021 09:54 AM

    Maddy's Avatar

    Hi Kenny,

    We are sorry to hear about the problem you have encountered.

    Which version and build of Moneydance are you using?
    To check, open Moneydance and select Moneydance --> About Moneydance.

    Can you let me know which operating system you're running on your computer/s?

    If you haven't already, you could try upgrading to the latest preview version, as this should hopefully fix the problem for you.
    Moneydance 2022.3 (4061) is now available to download from this page.

    If the problem persists, Please can you send us your Moneydance error logs? The logs should include information about what might be causing the problem.

    They are saved on your computer as an errlog.txt file.

    You can get to your error logs as follow:

    1) navigate to Help->Console Window to show the console log in a window

    or

    2) in the Finder, press ⌘⇧G and then copy and paste ~/Library/Containers/com.infinitekind.MoneydanceOSX/Data/Library/Application Support into the field and press enter/return.

    At that point the finder will show an internal folder which contains the errlog.txt file which contains the log.

    Finally you can paste the full content to your next reply on this thread.

    Thank you

    --
    Maddy, Infinite Kind Support

  2. 2 Posted by Stuart Beesley ... on 24 Nov, 2021 10:26 AM

    Stuart Beesley - JUST A FELLOW USER and Toolbox ‘guy’'s Avatar

    There was a bug if your txns contained the cxnaction=1 tag (typically banks that send Pending txns (which MD ignores) and then sends the actual txn). MD would auto merge. This was fixed in 4061. There is however another follow-on bug where now it won't offer merge options and you get a duplicate... I know this is being worked on too.

  3. 3 Posted by kenny on 25 Nov, 2021 02:59 PM

    kenny's Avatar

    Thanks!

    (and thank you [again] Stuart)

     

    I am currently running:

     

    MD: 4060

    Mac (Bug Sur – 11.6.1)

     

    Assuming I can find pre-release 4061 for the Mac it sounds like it will fix the auto merge issue but then prevent me from manually merging.

     

    Do I have that right?

     

    I might load up 4061 and see what it looks like. If I understand the issue (with 4061) correctly then I am not sure which “situation” I’d rather be in. On the positive side, all this keeps me from getting too complacent… ☺

     

    --Kenny

     

    Expect the unexpected (or at least be ready for it...)

     

    From: Stuart Beesley - JUST A FELLOW USER and Toolbox ‘guy’ <[email blocked]>
    Reply-To: <[email blocked]>

  4. Support Staff 4 Posted by Maddy on 25 Nov, 2021 03:38 PM

    Maddy's Avatar

    Hi Kenny,
    Can you try upgrading to the latest preview version, as this should hopefully fix the problem for you?
    Moneydance 2022.3 (4062) is now available to download from this page.

    For a full list of improvements in the preview version, please refer to this page.

    I hope this information is helpful. Please let us know if you have further questions or need more assistance.

    --
    Maddy, Infinite Kind Support

  5. 5 Posted by Stuart Beesley ... on 25 Nov, 2021 07:48 PM

    Stuart Beesley - JUST A FELLOW USER and Toolbox ‘guy’'s Avatar

    It’s fixed for me in 4062

  6. Maddy closed this discussion on 26 Nov, 2021 09:08 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac