Security Price Import Screen Missing Buttons on Linux

ed.fischer's Avatar


30 Apr, 2022 06:09 PM

Currently using 2022-3 (4077) however the problem has been occurring at least since 2022-2 (4060).

This issue is running MoneyDance on Linux (MInt 20.3 Cinnamon). Windows version does not appear to be affected

Open Currency/Security History for any security and click Import.
The Import Price History window is not user sizable. The Import and Cancel buttons are all but missing from the bottom of the screen. Fortunately Import is defaulted and pressing the Enter key does activate.

See attached picture for an example

  1. Support Staff 1 Posted by Ethan on 30 Apr, 2022 09:55 PM

    Ethan's Avatar

    That's interesting. I'm using the same version of Moneydance, but on Mint 20, and I'm not seeing this issue. I notice that my line breaks seems to be different than yours though, which maybe is part of the problem (see attached).

    Can you try resetting your Moneydance preferences and see if that fixes the issue that you're seeing? This should reset things like window sizes. To do this, you have to rename your config.dict file.

    If you're using Linux, it should be located at:


    Once you've found your config.dict file, close Moneydance and rename it (to something like config2.dict, for example), then open Moneydance again and it will appear as though you've just installed Moneydance for the first time, so you'll have to re-enter your license key and may have to locate and open your data set again. If you run into any problems, you can simply close Moneydance and rename the original config.dict file back to config.dict and open Moneydance again to restore your original settings.

    Even if that doesn't work, it will still help to narrow down what may be happening.

    Infinite Kind Support

  2. 2 Posted by ed.fischer on 01 May, 2022 04:07 PM

    ed.fischer's Avatar

    I tried your test solution and the condition was still occurring with
    no change. I decided to start modifying Mint's theme settings (again
    20.3 Cinnamon).
    I found that using the rounded window corners theme Mint-Y was the
    problem. Once I changed it to Mint-X the Import window buttons appear
    as they should and exactly as your example.
    Please pass this along to your development team as a bug fix for future
    On Sat, 2022-04-30 at 21:55 +0000, Ethan wrote:

  3. Support Staff 3 Posted by Ethan on 01 May, 2022 09:26 PM

    Ethan's Avatar

    Hi Ed,

    Thanks so much for the additional testing! I've filed a bug report for our developers. It sounds like there could be a few ways to fix this. One would simply be to make the size of this window editable. I'm honestly not sure why it's not.

    Infinite Kind Support

  4. 4 Posted by ed.fischer on 03 Jun, 2022 08:05 PM

    ed.fischer's Avatar

    After applying update 2022.4-4087 this issue is still present on Linux Mint 20.3 using theme Mint-Y.

  5. System closed this discussion on 02 Sep, 2022 08:10 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac