Categories dropdown broken (datafile corruption?)

Brent Nesbitt's Avatar

Brent Nesbitt

25 Feb, 2010 01:15 AM

I have been using Moneydance on Linux for the past several years, and am very happy with it.

Normally when I enter a new transaction, I can click on the categories dropdown and get a list of all of my categories to select from - or, I can just type the first few letters of the category name, and it will autocomplete for me.

Sometime this last month, I stopped being able to click on the dropdown to view the list. I can still select the category by typing, and all the categories are there, because autocomplete works correctly.

Interestingly, if I go back and edit transactions before a certain date, the categories list will work correctly, but after a certain date, they no longer drop down. That date is different in each of my accounts, but within the past month in all of them.

Could this be due to a corrupted data file - and if so, is there a way to check the integrity of the file, or re-build it somehow?

Right now I am thinking I will need to go back and delete all of the transactions after the "affected date", and re-enter them all. Will this work?

And along the same lines, is the "best-practice" to close a datafile and start a new one every year? Right now I think my current datafile has 3 years worth of data in it.

  1. 1 Posted by ljb on 25 Feb, 2010 03:34 AM

    ljb's Avatar

    That is very, very odd. Could you post your Moneydance version and Java version from Help => About Moneydance? (They are going to ask you that anyway.)

    If you do Tools => Edit Categories, and expand all the names, do they all look OK? Same for Tools => Edit Accounts.

    (Also I suggest posting the question about archiving on the Questions forum with its own thread and subject, as I'm sure there is good advice out there.)

  2. 2 Posted by Brent Nesbitt on 25 Feb, 2010 04:09 AM

    Brent Nesbitt's Avatar

    Moneydance Version: 2010r2 (735)
    Sun Java Version: 1.5.0_19

    Accounts all look fine.
    Categories look fine - except that there was a blank category at the top. I
    removed that, but it didn't help with my problem.

  3. 3 Posted by Ben Spencer on 25 Feb, 2010 03:27 PM

    Ben Spencer's Avatar

    Hi Brent

    What distribution of Linux are you running? If java 1.6 is available for that distribution I strongly recommend upgrading to it?

    Could you also check the error console. To see the error console select Help->Console window. Try entering a new transaction with the console open and copy and paste the console output to this discussion.


    Ben Spencer

  4. 4 Posted by Brent Nesbitt on 26 Feb, 2010 02:19 PM

    Brent Nesbitt's Avatar

    Hi Ben,

    I am using Ubuntu 9.10. The following versions of java are listed under
    "update-alternatives --config java"

      Selection Path Priority Status
    * 0 /usr/bin/gij-4.4 1044 auto
      1 /usr/bin/gij-4.2 42 manual
      2 /usr/bin/gij-4.3 43 manual
      3 /usr/bin/gij-4.4 1044 manual
      4 /usr/lib/jvm/java-1.5.0-sun/jre/bin/java 53 manual
      5 /usr/lib/jvm/java-6-sun/jre/bin/java 63 manual
      6 /usr/lib/jvm/java-gcj/jre/bin/java 1042 manual

    As you see, only 4 seems to conform to the 1.x version numbering. I tried
    selecting several of these, but MoneyDance always reported the same version
    (Sun version 1.5.0_19). I believe when i installed Moneydance the package
    incuded java - perhaps it is a statically linked version?

    I opened the error console, which immediately came up with:
    Starting Moneydance 2010r2 (735)
    Settings Folder: /home/xxxxxxxx/.moneydance
    OS: Linux 2.6.31-19-generic i386
    Java: 1.5.0_19 (Sun Microsystems Inc.)

    As I entered a new transaction, nothing else was printed in the error

  5. 5 Posted by Brent Nesbitt on 26 Feb, 2010 02:47 PM

    Brent Nesbitt's Avatar

    Up until now, I thought this was just inconvenient, but this morning I
    realized that without the dropdown it is impossible to do a category
    split - which is very problematic.

    Is there some other way (ie. Hotkey) that I can do a category split in
    the meantime?

  6. 6 Posted by Brent Nesbitt on 26 Feb, 2010 02:55 PM

    Brent Nesbitt's Avatar

    Oh, one more thing that might help diagnose this - I tried right clicking on
    a transaction and selecting *Batch Change | Category* does not list any
    categories - even on the older transactions where the dropdown is still
    working. It just shows the up/down arrows with nothing alongside.

  7. 7 Posted by ljb on 26 Feb, 2010 03:56 PM

    ljb's Avatar

    I've run MD2010 on Xubuntu-9.10 with no problems at all, but I have a single version of Java: Sun's 1.6.0_16. There is a good chance that the trouble you are having is due to the Java version. Less likely is file corruption.

    You can probably rule out file corruption like this. Save your data, then use File => New and pick the Standard Account Set to create a clean database. See if you can access the categories menus from the register. If it does work, you have a data file problem. If it still doesn't work, let's try fixing Java.

    As for Java, can you tell me what this command displays from a shell prompt? Let's see if you have a good Java version, then we can try to get MD to use it.

    /usr/lib/jvm/java-6-sun/jre/bin/java -version

    We're looking for something like this:

    java version "1.6.0_16"
    Java(TM) SE Runtime Environment (build 1.6.0_16-b01)
  8. 8 Posted by Brent Nesbitt on 26 Feb, 2010 04:55 PM

    Brent Nesbitt's Avatar

    You are right, I have the same problem when using a NEW file. Therefore it
    is not file corruption. That is great to know.

    executing the java -version command you listed produces:

    java version "1.6.0_16"
    Java(TM) SE Runtime Environment (build 1.6.0_16-b01)
    Java HotSpot(TM) Client VM (build 14.2-b01, mixed mode, sharing)

    How can I specify which version Moneydance uses - since it doesn't appear to
    use the system default? That is, when I change versions using
    update-alternatives, the command java -version lists a new version, but
    Moneydance still lists 1.5.0_19 in its about dialog.

  9. 9 Posted by ljb on 26 Feb, 2010 06:12 PM

    ljb's Avatar

    Good so far.

    When I install MD on Linux, I use the "other" package, unpack it, and point a symbolic link to the Java directory. I'm not sure how the one you downloaded works, but if they use the same startup script as the 'other' package, it locates Java like this. First, it checks the Moneydance program directory for jre/bin/java and if that resolves to an executable program it uses that. Else it simply uses "java" and lets the shell find it using the PATH.

    So you should check the directory where Moneydance is installed (this will contain moneydance.jar as well as other *.jar files) and see if there is a symbolic link (or directory) called jre. This needs to point to the right Java directory. On my Xubuntu system it looks like this:

    $ cd /usr/local/lib/moneydance/
    $ ls -ld jre
    lrwxrwxrwx 1 root root 23 2010-02-02 16:28 jre -> /usr/lib/jvm/java-6-sun

    (Note that /usr/lib/jvm/java-6-sun/jre will work too - both get to the same program.)

  10. 10 Posted by Ben Spencer on 27 Feb, 2010 04:33 PM

    Ben Spencer's Avatar

    ljb is correct. By default Moneydance will use the jar in the Moneydance directory. Rename the jre folder in the moneydance directory to jre.old and the moneydance will use the version of java that is already installed on your computer.


    Ben Specner

  11. 11 Posted by Brent Nesbitt on 27 Feb, 2010 05:19 PM

    Brent Nesbitt's Avatar

    Okay, that did it - sort of.

    There was no jre link in the moneydance subdirectory, so I don't know how it
    was getting java version 1.5. However, I apparently had the "linux x86"
    version installed (the one with the uppercase Moneydance). I removed that,
    and installed the "Other Unix" files, created a jre link to Sun java 1.6,
    and the problem was fixed.

    Strangely, I tried linking back to the java 1.5 directory, and the problem
    did not re-appear, so I don't know whether the solution was replacing the
    moneydance install, or changing the java version.

    Anyhow, thanks VERY MUCH for the help in resolving this.

  12. Ben Spencer closed this discussion on 27 Feb, 2010 05:40 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac