"Investment Transactions" under GRAPHS & REPORTS cannot show Memos

jerryxe's Avatar


15 Dec, 2022 06:00 AM

Though when click the Edit button, in the popup, I can choose "Show Memos", but the result still does not show Memo field.

"Transaction Filter" works well, when I choose "Show Memos", I can see Memo field in the list

  1. 1 Posted by Dan Hanger on 18 Dec, 2022 11:56 AM

    Dan Hanger's Avatar

    Just ran into this problem myself yesterday. Any comment from IK?

  2. 2 Posted by sth on 18 Dec, 2022 04:42 PM

    sth's Avatar

    At least give the OS and version and the MD version (including build number) as a start.

    A screen shot of the report "Edit" page might also help.
    (NOT IK Support)

  3. 3 Posted by jerryxe on 19 Dec, 2022 09:58 PM

    jerryxe's Avatar

    System: MacOS Venture 13.1
    App: 2022.5

  4. 4 Posted by sth on 19 Dec, 2022 10:08 PM

    sth's Avatar

    Do you get the memos if you ask for "two line mode"? I am not sure where the memos would show up if it was not in two line mode.

  5. 5 Posted by jerryxe on 19 Dec, 2022 10:21 PM

    jerryxe's Avatar

    I do get memo if I choose 2 line mode, however, 2 line mode is not convenient for copying to spreadsheets.

    In the mean time, if I use "Transaction Filter", and choose show Memo, but not 2 line mode, I can see the Memo column

  6. 6 Posted by Dan Hanger on 22 Dec, 2022 01:37 PM

    Dan Hanger's Avatar

    Okay, did not realize I had to use 2 line mode to see the memos. Still something weird about it though since ticking/unticking the checkbox 'Show memos' makes no difference whether in 1 or 2 line mode so I don't understand what's the purpose of the checkbox.



  7. 7 Posted by sth on 22 Dec, 2022 04:06 PM

    sth's Avatar

    Good point, sounds like a UI glitch, and maybe the show memos box should be removed.

  8. 8 Posted by jerryxe on 22 Dec, 2022 07:38 PM

    jerryxe's Avatar

    The "Show Memos" box should NOT be removed, since we still need to show memos in the single line mode. This is a bug to not show memo in single line mode.

    In "Transaction Filter", we can show memo in single line mode, which is more conveninet to export to spreadsheets, than two lines mode.

  9. 9 Posted by sth on 22 Dec, 2022 08:20 PM

    sth's Avatar

    @jerryxe, it is not clear that "we" need to show memos in single line mode. I understand that is something you would like as a feature. However it is not necessarily a bug but possibly an unimplemented feature.

    It may be that "Transaction Filter" is more suited to your needs. Unfortunately there is not a possibility to customize exactly what is reported and create ones own reports.

    The bug seems to be the inconsistency between the check box and what is displayed. To fix that "bug" that inconsistency can obviously be resolved in one of two ways. That is obviously up to the developer who is aware of your preference.
    (NOT IK Support)

  10. 10 Posted by jerryxe on 22 Dec, 2022 08:50 PM

    jerryxe's Avatar

    Given both "Investment Transactions" and "Transaction filter" both have the same "Show Memos" checkbox, and it does work on "Transaction filter", I would consider this as a bug. Well, one can always glorify bugs as unimplemented feature, though I would expect this "unimplemented feature" to be implemented, if possible.

    "Investment Transactions" and "Transaction filter" are different things, the former has more investment related information, e.g. shares and price per share, while latter only has the total amount. So it's not one suites my needs than other, they serve different purposes.

  11. System closed this discussion on 23 Mar, 2023 09:00 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac