Printing Problem

David Larson's Avatar

David Larson

26 Feb, 2010 09:30 PM

I just downloaded version 743. Before downloading the update I was able to print transaction reports. Since downloading all I get is a blank page.
What happened?

  1. 1 Posted by Noname on 26 Feb, 2010 09:43 PM

    Noname's Avatar

    What system are you on? I'm running 743 and just tested printing on Mac OS X 10.5.8 Java 1.6.0_17 and the Transaction report printed without problem. I was also able to preview the report before printing and was able to see all the data.

  2. 2 Posted by David Larson on 26 Feb, 2010 09:48 PM

    David Larson's Avatar

    Says I am running Moneydance 2010r2 (743), Java Version 1.5.0_12.

    My Mac is 10.5.8

  3. 3 Posted by Noname on 26 Feb, 2010 10:12 PM

    Noname's Avatar

    Were you able to preview the report and see the data before printing? Will it print the data if you select the PDF button in the print dialogue box and save the file as a PDF and then print it out?

    When I previewed the report before printing I noticed that it said "Preview of Java Printing.pdf" at the top of the report. This makes me wonder if it's a Java problem (major disclaimer: I'm not a techie). If you want to explore if it's a Java problem you can read through these threads and see if that helps. Or maybe someone else has other ideas for you to try.

    see Post 17 (which resolved my problem) in this thread

  4. 4 Posted by David & Betty L... on 26 Feb, 2010 10:16 PM

    David & Betty Larson's Avatar

    Just gives me a header across the top, but no transactions.

  5. 5 Posted by Noname on 26 Feb, 2010 10:24 PM

    Noname's Avatar

    Is that true for both the preview mode and "save as PDF file" (i.e. when you save and then open the file there is no data there either)? The only difference between our two systems is the Java issue. You may want to explore the Java issue unless someone else has a suggestion.

  6. 6 Posted by David & Betty L... on 26 Feb, 2010 10:42 PM

    David & Betty Larson's Avatar

    Both Preview and PDF give me a blank page except for the headers. I updated
    my program with something designed by Ben. It now shows Java 1.6.0_17, so I
    can use Find & Replace. I still can not print transactions. It continues to
    print reports.

  7. 7 Posted by Noname on 26 Feb, 2010 10:50 PM

    Noname's Avatar

    I'm sorry I'm out of ideas. Hopefully MD Support or some fellow user will have further suggestions.

  8. 8 Posted by ljb on 27 Feb, 2010 01:57 AM

    ljb's Avatar

    I normally avoid Mac issues since I know zero about Mac, but I'm going to jump in here because I think you might be talking about different things. (1) Reports, via the sidebar or Tools > Reports, and pick Transaction Report. (2) Open an account's register and then use File > Print Transactions.

    I get the feeling jbnyt is taking about (1), reports, and David is trying to do (2), Print Transactions. If I'm wrong, sorry, you can stop reading.

    I just tried File => Print Transactions (this is on Linux, see) and got a java.lang.NullPointerException. It wrote a mostly empty PostScript output file and left a long Java traceback in errlog.

    How about it? jbnyt, do you also get something like this from File => Print Transaction on your Mac? (I'm running build 743, by the way.) David, is this what you were using, as opposed to the transaction report?

  9. 9 Posted by David & Betty L... on 27 Feb, 2010 02:22 AM

    David & Betty Larson's Avatar

    Will someone contact me?

  10. 10 Posted by Noname on 27 Feb, 2010 03:21 AM

    Noname's Avatar

    ljb, you are correct, I was referring to printing the Transaction Report and not from File > Print Transactions. I just tried the latter and also get an empty file (no error message though). I've never used this option before so I'm not sure if you need to select the transactions you want to print (though even when I highlighted some transactions there still was an empty report). I just went back to build 741 and tried it there as well and also got an empty file. Sounding like a bug?

  11. 11 Posted by ljb on 27 Feb, 2010 03:38 AM

    ljb's Avatar

    Yes, very good. I was worried that I got a Java error popup and he didn't, but it looks like that might be system dependent.

    I went back a few versions more and found that it works at build 735, broken at 738. We have enough to open a bug report, but I would like to hear from David that this is in fact what he was doing, rather than the transaction report. (Looks like he did a reply via email and it crossed with my message, but I assume he will catch up.)

    If he is not using the transaction report, he should try that and see if it meets his needs, until the presumed bug gets fixed.

  12. 12 Posted by David Larson on 27 Feb, 2010 01:40 PM

    David Larson's Avatar

    I am obviously new to using Moneydance. I have been printing lists of category transactions to I could edit mistakes. I was doing this task by using FILE>PRINT TRANSACTIONS. I had not discovered I could do the same thing by using the Transaction Report. It works fine. The FILE>PRINT TRANSACTION has not worked since I updated from 735 to 743.

    This has been a process of discovery. My corrections are now easier, because of this discussion. I uncovered my Java problem that prevented using FIND & REPLACE. Thanks the Ben's patch I now can use this extension.

    I will use the Transaction Report approach until you fix the bug.

  13. 13 Posted by Noname on 27 Feb, 2010 02:36 PM

    Noname's Avatar

    David, we're all learning together! I've been using MD since 2008 and never knew about the File > Print Transaction option. So this discussion has been helpful to me as well. This is why I check this forum -- I constantly find new ways of doing things.

  14. 14 Posted by ljb on 27 Feb, 2010 03:27 PM

    ljb's Avatar

    I will use the Transaction Report approach until you fix the bug.

    Clarification/disclaimer time: Blue header over posts = Moneydance staff member. All the rest of us are just regular users like you. The best we can do is report the bugs and suggest work-arounds. Fixing them is up to the blue-header people.

    Speaking of which, I haven't been able to get into Trac to open a bug report for this or two others I have. I get TICKET_CREATE privileges are required to perform this operation, but I have opened tickets in the past so I hope this is a temporary problem.

  15. 15 Posted by Ben Spencer on 27 Feb, 2010 03:29 PM

    Ben Spencer's Avatar

    Hi all

    Thanks for bringing this to attention. I can confirm that there is a bug when you select Print transactions from the file menu. I have submitted a bug ticket. Here is the link to the ticket.


    Ben Spencer
    Moneydance Support

  16. 16 Posted by ljb on 27 Feb, 2010 03:35 PM

    ljb's Avatar

    Yes, thanks, I just saw it. 2676. Also 2675. Also 2674. (Trouble with Trac maybe?)

    I have more information for the ticket, if you want it. It started at build738 (735 was OK). Also I was going to attach a Java error traceback from the error log. But since it is easily reproduced I guess you won't need that.

    This may also be the same problem reported in ticket #2642

    No connection to that one. Is that the number you meant?

  17. 17 Posted by Ben Spencer on 27 Feb, 2010 03:42 PM

    Ben Spencer's Avatar

    Indeed trac has been less than responsive this morning. I inadvertently submitted the ticket 3 times. I have resolved the duplicates. Thanks for pointing out my mistake with the related ticket number. I transposed the last 2 digits. It should have been 2624. I have changed the ticket accordingly.


  18. Angie Rauscher closed this discussion on 24 Jul, 2011 07:27 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac