Investment Transactions Not Downloading (MD+)

Mark J's Avatar

Mark J

04 Feb, 2023 09:38 PM

I was having this problem last summer and 2022.4 (4067) fixed it. Sometime between Dec 12, 2022 and now it has stopped working again with Ameriprise Financial via Plaid (MD+).

Banking transactions (interest, transfers) download, but investment transactions (security purchases, dividends, etc) do not download. System says "0 new transactions downloaded." Upgraded to 2022.6 (4097) today and it's still a problem. LMK how I can help troubleshoot.

Thanks, Mark

  1. 1 Posted by dtd on 04 Feb, 2023 10:49 PM

    dtd's Avatar

    just a user - use toolbox to check your "last download date" for that account. If it is past Dec 12, 2022 and also past some transactions that didn't download, you might want to reset that date, then pick a new date like Nov 1, 2022, and see if it gathers the information.

    You might get duplicates that you will need to handle, but better duplicates than missing items.

    Not saying this will solve your problem, but it is one way to recheck for items that are no longer being looked at by Plaid(MD+)

  2. 2 Posted by cameron.s.mcleo... on 11 Mar, 2023 03:25 PM

    cameron.s.mcleod's Avatar

    I've had this same problem since last September, with no progress towards a solution.

  3. 3 Posted by Stuart Beesley ... on 11 Mar, 2023 03:31 PM

    Stuart Beesley (Mr Toolbox)'s Avatar

    What happens if you disconnect the md+ connection and then reconnect it?

  4. 4 Posted by cameron.s.mcleo... on 11 Mar, 2023 03:34 PM

    cameron.s.mcleod's Avatar

    I've done all of the invasive testing: disconnected Ameriprise accounts in MD+, cleared caches, reset download dates, cancelled MD+ and re-enrolled, removed accounts from the Plaid portal...

    The behavior I see is that Ameriprise seems to download transactions from the past 1-2 days. I suspect if I opened MD and hit download every day for every account, I might see all the transactions. But, if I do it once every week or two there is either nothing or older transactions are missing.

  5. 5 Posted by Mark J on 15 Mar, 2023 11:33 AM

    Mark J's Avatar

    Thanks, @dtd, Toolbox is a very cool extension! The download dates are accurate and are not the cause of the problem. MD gets all the right data in the download, for some reason it is just failing to recognize the security transactions as valid. It may be that Ameriprise does not provide some data that MD uses to determine whether a transaction should be included in the account or not.

    @Stuart, after disconnecting and reconnecting MD+, on the next download I got the most recent banking (simple interest on the cash) transaction (again), but this error (which I was not seeing before): There was an error communicating with your financial institution. The details of this error are below.

    Bank Name: Moneydance+
    Account: {masked}
    Account Number:{masked}

    The error code reported by the server was: 0

    Received malformed response: Response{protocol=h2, code=500, message=, url=https://mdplus.infinitekind.com/plaid/investments/transactions/get}
    Error: java.lang.RuntimeException: Could not parse error response

    Any thoughts from that? Need me to send the console data?

  6. 6 Posted by Stuart Beesley ... on 15 Mar, 2023 08:24 PM

    Stuart Beesley (Mr Toolbox)'s Avatar

    Mark, thoughts…. Try again later… That’s all really…

    On 15 Mar 2023, at 12:33, Mark J <[email blocked]> wrote:

  7. 7 Posted by Mark J on 30 May, 2023 12:02 PM

    Mark J's Avatar

    This comment was split into a new private discussion: Investment Transactions Not Downloading (MD+)

    Upon upgrading to 2023.1, the downloads worked one time (meaning the investment transactions as well as banking downloaded). Then it went back to the same behavior (bank transactions like interest or transfers only).

    I've downloaded csv2qif from MoneyThumb (https://www.moneythumb.com/) to simplify the process of downloading and importing CSVs, but it's still disappointing that MD+ doesn't work as advertised.

  8. System closed this discussion on 29 Aug, 2023 12:10 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac