Moneydance stops responding to a keyboard

Andrey's Avatar


08 Apr, 2023 03:35 PM

I have a problem with Moneydance (2023.1, 5006) on Linux (Xubuntu 22.04.2 LTS) stopping responding to a keyboard. I have to close it using mouse and start again. Maybe it's related to me switching back and force between Moneydance and a browser when I enter transactions. The problem started several versions back (I don't remember exactly) and now happens consistently.
Attached is the errlog.txt file.

  1. 1 Posted by Andrey on 08 Apr, 2023 03:44 PM

    Andrey's Avatar

    Also, I noticed a similar discussion mentioning extensions. I have only one installed, QuoteLoader and it's up to date.

  2. 2 Posted by Stuart Beesley ... on 08 Apr, 2023 03:54 PM

    Stuart Beesley (Mr Toolbox)'s Avatar

    Update to md2023.2(5007) first.

    Can you install/run toolbox extension. Does it popup any warnings?

    After this. Restart MD and then send a new console over.

  3. 3 Posted by Andrey on 08 Apr, 2023 04:08 PM

    Andrey's Avatar

    This comment was split into a new private discussion: Moneydance stops responding to a keyboard

    I don't see the 2023.2 (5007) version yet. I installed and ran Toolbox - no warnings.
    Attached is the new console log (right after starting MD, no issues yet)

  4. 4 Posted by Stuart Beesley ... on 08 Apr, 2023 04:35 PM

    Stuart Beesley (Mr Toolbox)'s Avatar

    So a mystery. A few people are seeing this….

  5. 5 Posted by jjbarratt on 24 May, 2023 12:29 PM

    jjbarratt's Avatar

    Same thing happening to me every time I use the application. After just a few transaction entries the keyboard fails to respond and I have to restart.
    Version 2023.1 5006

  6. 6 Posted by ajbarr on 01 Jun, 2023 12:20 AM

    ajbarr's Avatar

    I'm having the same issue. Using Kubuntu (Ubuntu 22.04.2 LTS). Version 2023.1 5006. I can provide some error debugging but don't feel comfortable attaching it to a public forum.
    I see someone mentioning testing Moneydance 2023.2 (5007). Is it possible to get a beta version to test? Moneydance Moneydance 2023.1 (5006) isn't usable.

  7. 7 Posted by dwg on 01 Jun, 2023 12:56 AM

    dwg's Avatar

    Build 5007 is available from:

  8. 8 Posted by ajbarr on 02 Jun, 2023 02:09 AM

    ajbarr's Avatar

    Thanks for the link. I downloaded Build 5007. However, I still had the
    problem today. I am having it happen while confirming transactions. I
    have to do some other things to see if it happens other times.


    On Wed, May 31, 2023 at 8:56 PM dwg <[email blocked]> wrote:

  9. 9 Posted by Andrey on 16 Jun, 2023 05:13 PM

    Andrey's Avatar

    I tried to do some investigation. I created an extension that enables logging for "sun.awt.X11.kye.XToolkit". When MD works properly I see both "before XFilterEvent:" and "after XFilterEvent:" messages printed by XToolkit. When a keyboard stops responding I only see "before XFilterEvent:" message. It looks like XlibWrapper.XFilterEvent starts returning true, which leads to keyboard problems.
    I don't know how useful is this information but this is as far as I could go, XlibWrapper.XFilterEvent is a native method. Also, if I can check anything else, let me know.

  10. 10 Posted by georgettalbot on 01 Jul, 2023 03:17 PM

    georgettalbot's Avatar

    Having this problem as well.

  11. 11 Posted by Stuart Beesley ... on 01 Jul, 2023 03:36 PM

    Stuart Beesley (Mr Toolbox)'s Avatar

    The developer told me this:

    1. The keyboard-not-responding problems I've seen so far are related to MD doing a bunch of processing after a transaction is recorded. The first step to take is to go into the preferences and remove the Foresight views from the summary page.

    2. If that doesn't work, this is worth a try: make changes to a transaction, then click on another transaction in the register. When prompted whether you want to save the transaction, click Yes. For some people that works, and I'm still tracking down that specific bug. I think it's probably related to MD trying to automatically add an exchange rate entry based on the transaction.

  12. 12 Posted by Dan on 01 Jul, 2023 06:26 PM

    Dan's Avatar

    I am also seeing this -- see

    I tried build 5007 and it doesn't fix the issue. I removed everything from the Summary page except for some bank and credit card accounts.

  13. 13 Posted by misc on 06 Aug, 2023 04:28 PM

    misc's Avatar

    I have been experiencing this for quite some time myself, happened several times today already. I'm running MD 2023.1 5006 on Kubuntu 22.04.3 LTS.
         For me it seems to happen more frequently when I use the arrow keys to scroll up or down on transaction entries and possibly when clicking on drop down menu entries.
      I have tried running several different versions of jvm thinking it could be related to that.
         Do any of the MD folks know when and if there will be a resolution? This is very frustrating - only able to enter 2 or 3 transactions before the keyboard stops responding.

  14. 14 Posted by andyschmid on 04 Oct, 2023 05:34 PM

    andyschmid's Avatar

    Just chiming in, I also experience this problem. Running linux too.

  15. 15 Posted by scott.geiger on 15 Oct, 2023 03:35 PM

    scott.geiger's Avatar

    I also opened a thread (which has now been closed due to inactivity) for the same behavior. I have tried all sorts of different suggestions with no luck. I even tried switching out the JRE/JDK bundled with MD. I tried changing the JRE/JDK on my system (update-alternatives).

    Interestingly (in a bad way) I just had MD 2022.6 (4097) lock-up as well. Originally it seemed to be with 2023.x. The 2022 branch seems less prone to this, but it seems it may have existed there. With 2023 it is consistent; it happens every time within 5 - 10 minutes.

  16. 16 Posted by Stuart Beesley ... on 15 Oct, 2023 03:37 PM

    Stuart Beesley (Mr Toolbox)'s Avatar

    Try the alpha. Backup first.

  17. 17 Posted by scott.geiger on 15 Oct, 2023 03:44 PM

    scott.geiger's Avatar

    Stuart, if you are referring to MD 2023.2 (5007) already did that, still locks up.
    I have removed all extensions, still locks up.
    I don't use Foresight (it's not on my summary page), still locks up.

    Here is the link to my thread:

  18. 18 Posted by Stuart Beesley ... on 15 Oct, 2023 04:15 PM

    Stuart Beesley (Mr Toolbox)'s Avatar

    Nope. Alpha. Build 5045. For test purposes

  19. 19 Posted by scott.geiger on 22 Oct, 2023 12:41 PM

    scott.geiger's Avatar

    Where do I find 5045?

  20. 20 Posted by Stuart Beesley ... on 22 Oct, 2023 04:16 PM

    Stuart Beesley (Mr Toolbox)'s Avatar

    Remember it’s an alpha. For testing only. Backup first and ideally only use a backup test copy of data.

  21. 21 Posted by scott.geiger on 05 Nov, 2023 12:23 PM

    scott.geiger's Avatar

    Hi Stuart, I still don't see where to find the alpha build. In your reply all I see are three dots, no attachment or link.

  22. 22 Posted by dwg on 05 Nov, 2023 12:29 PM

    dwg's Avatar

    Moneydance Build 5051 is now a preview version and available from the normal preview location.

  23. 23 Posted by dwg on 05 Nov, 2023 12:31 PM

    dwg's Avatar

    Note this is still beta software, we think most of the major issues have been found but I would not run it on live data as yet.

  24. 24 Posted by scott.geiger on 05 Nov, 2023 12:32 PM

    scott.geiger's Avatar

    Thanks @dwg. Understood that it's beta and I'll test accordingly.

  25. 25 Posted by scott.geiger on 05 Nov, 2023 03:08 PM

    scott.geiger's Avatar

    Unfortunately still getting KB lockup on b5051.

    I created a copy of my .moneydance folder before starting. Attempting to start with the existing .moneydance folder did not work; the application never started. I deleted the .moneydance folder and allowed it to recreate. I imported my existing transactions from a previous backup. This worked and started with no extensions, configuration, or license key (as expected). I began entering transactions and after a few minutes the keyboard stopped responding.

    Back to 2022.6 (b4097)

  26. 26 Posted by scott.geiger on 10 Dec, 2023 04:18 PM

    scott.geiger's Avatar

    Just tested the newest release 2023.3 (5064). Unfortunately still getting kb lockup. Only a couple minutes in and a few transactions the kb stopped responding.

  27. 27 Posted by cpradio on 24 Dec, 2023 04:35 AM

    cpradio's Avatar

    By chance are you also using a bluetooth wireless keyboard or a physical one? I also am experiencing this lockup and just thought about testing a physical keyboard the next time I am in it to see if that helps. I am also running Ubuntu 22.04.3 (if that matters)

  28. 28 Posted by ajbarr on 24 Dec, 2023 01:09 PM

    ajbarr's Avatar

    I have experienced the issue when using a usb keyboard and when using the
    keyboard on my laptop.

    On Sat, Dec 23, 2023 at 11:35 PM cpradio <[email blocked]>

  29. 29 Posted by scott.geiger on 24 Dec, 2023 03:07 PM

    scott.geiger's Avatar

    @cpradio: like @ajbarr I am also using a wired/USB keyboard. I have had a very few rare instances of the lockup happening on 2022.6 (b4097). All of the 2023 builds to-date have consistently locked up for me within minutes of starting up.

    This morning I installed 2023.3 on a laptop (newer than my desktop). I normally work on my desktop, but plan to travel over the holidays and wanted it on my laptop. I setup sync on the desktop and allowed the laptop to sync and update. Both the desktop and laptop are running Linux Mint 20.3. I then used the laptop for my normal transaction entry and had no kb lockups. There are definite differences between the two; the desktop is quite a bit older, less RAM and older CPU and different kernel.


    Kernel: 5.4.0-166
    RAM: 16 GB
    Swap: 5 GB
    CPU: Intel(R) Core(TM) i5-3470 CPU @ 3.20GHz


    Kernel: 5.14.0-1044-oem
    RAM: 32 GB
    Swap: 9 GB
    CPU: 11th Gen Intel(R) Core(TM) i7-11850H @ 2.50GHz

  30. 30 Posted by dwg on 24 Dec, 2023 09:44 PM

    dwg's Avatar

    I cannot say I have seen any instances of my test Linux notebook locking up when using Moneydance.

    For reference:

    Linux Mint 21.2
    Kernel: 5:15.0-91
    Ram: 16GB
    CPU: 7th Gen i5-7200U

    This is with the built in keyboard and a USB wired mouse.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:


Already uploaded files

  • moneydance-errlog.txt 5.8 KB

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac