Problems getting USAA to download transactions

Chris 's Avatar


01 Sep, 2023 06:27 PM

Hi Moneydance master minds,

I'm having an issue with USAA not downloading transactions when I go to the download accounts part of Online. Moneydance version 2023.1 (5006)

I switched to Moneydance + several months ago and had no issue with downloading any of my 4 USAA accounts. About the middle of July, it stopped downloading new transactions...worked fine before that, and it works fine for other non USAA accounts.

It connects to USAA no problem, and it looks like it's downloading, but below the register, I get a notice...too fast to capture it completely...and almost too fast to get a screenshot...that says "Zero new transactions (of 1 downloaded) for USAA Checking after dup..."

There are new transactions in my account...and apparently Moneydance is seeing them, but somehow not allowing them to show up in the register.

Any suggestions?


  1. 1 Posted by dtd on 01 Sep, 2023 10:17 PM

    dtd's Avatar

    It seems like you are still connecting to USAA and it seems things are downloading, but obviously not what you want.

    You might want to reset the sync date to see if that helps. Go into MD+, select the USAA account (note the current sync date and report that here) - and click reset sync date. When prompted pick something like July 1 so as not to get too many duplicates.

    See if that helps.

  2. 2 Posted by Chris Boyd on 02 Sep, 2023 02:18 PM

    Chris Boyd's Avatar


    Thanks.  Unfortunately that didn't work.  It just gave me the same statement at the bottom saying that "Zero transactions (of 22 downloaded after dup...."   I even tried deleting some transactions from the register, so see if they would get downloaded, and nope...didn't download those.

    On 9/1/2023 3:17:24 PM, dtd <[email blocked]> wrote:

  3. 3 Posted by dtd on 02 Sep, 2023 09:10 PM

    dtd's Avatar

    Bring up the Help/Console window, keep it open, then do your download again. With the Console open it should show the file being downloaded (assuming MD+ works the same was as the older OFX direct download did) and you can then examine directly the file being downloaded and what it contains.

    As to: Unfortunately that didn't work. --- what was the current sync date, and what date did you pick when you resynced?

  4. 4 Posted by bzs on 03 Sep, 2023 01:38 PM

    bzs's Avatar

    Just wanted to confirm that I'm having exactly the same problem with my USAA accounts. I also tried to reset the sync date without success. As another attempt to fix the problem, I unlinked and re-linked the accounts, and that worked - it downloaded the new transactions - but that turns out to be only a temporary fix. The USAA accounts have since returned to ignoring the new transactions.

  5. 5 Posted by Chris Boyd on 03 Sep, 2023 01:43 PM

    Chris Boyd's Avatar

    Hi again,

    Sorry I forgot to include the sync date info in the previous email.  It was July 14 and I reset it to July 1.  

    I did the open console.  That's a lot of data!  Here's the portion for my most active account.  The same issue is happening with all the USAA accounts.

    downloading from USAA Checking, with starting date Wed Aug 02 00:01:00 PDT 2023
    received MD+ txn: 8DBR446aj7c4RdRA1nZYIpzJ0VaXNDUKD5Oe5 20230803 USAA INSURANCE PAYMENT -50000
    logging txn; file: tiksync/out/20230903131348_606.txn-tmp
    logging txn; file: tiksync/out/20230903131348_606.txn-tmp
    it took 0.003 seconds to eliminate 1 duplicates from 1 downloaded transactions
    logging txn; file: tiksync/out/20230903131348_606.txn-tmp
    it took 0.015 seconds to build a plaid client
    I'm sure you know what looking at, but here's a screenshot I was able to capture of the message I get at the bottom of the screen.

    Thanks for your help,
    On 9/2/2023 2:10:11 PM, dtd <[email blocked]> wrote:

  6. 6 Posted by Chris Boyd on 03 Sep, 2023 01:44 PM

    Chris Boyd's Avatar

    Thanks....not just me then.  

    On 9/3/2023 6:38:32 AM, bzs <[email blocked]> wrote:

  7. 7 Posted by bzs on 03 Sep, 2023 01:54 PM

    bzs's Avatar

    To try and answer some of DTD's questions - my sync date was August 11 2023. I reset to August 1 2023. The download then told me "zero new transactions (of 3 downloaded) after duplicates removed. "

    Note that there were 2 new transaction from mid-August but MD+ ignored them as though they had already been downloaded.

    The sync date is now back to August 11 2023.

    Console log from the MD+ download:

    it took 0.013 seconds to build a plaid client
    downloading from USAA Checking, with starting date Thu Aug 10 00:01:00 VET 2023
    received MD+ txn: Qz7bwPBgeRIZp80JEDBOsv8jJozrYgfOp0ZBJ 20230811 Winwin Solutions PAYROLL 100000
    received MD+ txn: pkVq0JmrZpFLwYme7zEOI11Rr0qqeatAzy97B 20230810 CAPITAL ONE CARD ONLINE PMT -178088
    logging txn; file: tiksync/out/20230903135125_712.txn-tmp
    logging txn; file: tiksync/out/20230903135125_712.txn-tmp
    it took 0.021 seconds to eliminate 2 duplicates from 2 downloaded transactions
    logging txn; file: tiksync/out/20230903135125_712.txn-tmp

    Hope that helps!


  8. 8 Posted by dtd on 03 Sep, 2023 09:36 PM

    dtd's Avatar

    Ok, the information provided is good, but frustrating. My accounts are sitting on Aug 22, which would be correct as the next data is 9/1, and there are delays (3-7 days) sometimes to get new data. So mine "is working", but who knows about new transactions. I'll just have to wait a couple of days to say if my accounts are still downloading.

    Interesting that unlinking and relinking fixes one of the problems "temporarily". Scary that deleting a couple of recent items doesn't make them get re-added as non-duplicates, especially after resetting the sync date.

    I am still using 2022.6(4097), as the 2023 changes aren't significant to me yet. I doubt this is significant, but if one of you is willing to grab 2022.6(4097) and see if it works, that would be interesting.... otoh, MD+ is sort of independent of MD version, so I'm not hopeful it would be different.

    As you can tell, this one is flummoxing me as I can't reproduce the problem, but see that your comments are well founded.... (i.e. I can't point out anything you didn't do correctly)

  9. 9 Posted by Lauri on 03 Sep, 2023 10:48 PM

    Lauri's Avatar

    I too am having issues with USAA. I switched to Moneydance + because of previous issues with USAA. My last download date was 8/22

  10. 10 Posted by dtd on 03 Sep, 2023 11:07 PM

    dtd's Avatar

    Do you have transactions since 8/22 that haven't come in? Like from 8/23 or 8/24 (mine are from 9/1 so are in the 3-7 day window)

  11. 11 Posted by dtd on 03 Sep, 2023 11:23 PM

    dtd's Avatar

    I deleted couple of transactions, and they did redownload properly.

    I'm starting to wonder if USAA isn't providing late August information, or something like that. Still, it sounds like there are some older transactions missing as well for a couple of you, which is why I suggested resetting the sync date to an earlier date.

    Still thinking about this.

  12. 12 Posted by Chris Boyd on 04 Sep, 2023 01:45 PM

    Chris Boyd's Avatar

    I tried something today...not sure if it helps, but I went back and deleted my mortgage payments back to May...same amount...same time of month so easy to see.  I set the sync back to April 1 and it reloaded the May, June, and July payments but didn't reload the August or September payments.   

    I then tried deleting some July payments to see if I could narrow down the window where they stopped loading.  Somewhere between July 10 and August 1st is when they stopped working.  Sorry I couldn't get a closer date than that.

    Thanks for helping with this!

    On 9/3/2023 4:23:36 PM, dtd <[email blocked]> wrote:

  13. 13 Posted by dtd on 07 Sep, 2023 03:24 PM

    dtd's Avatar

    I can verify that my USAA accounts are still downloading transactions, I just had to wait till after Labor Day to see them.

    Doesn't help either of you much, I know.

    I still think it possibly is a combination of the sync date being set improperly somehow, or Moneydance thinking that these are indeed duplicates (which is why downloaded 0 out of 22 duplicates)

    Without more detailed analysis, that's about all I can suggest - I'm currently out of town.

  14. 14 Posted by RML on 12 Sep, 2023 05:34 PM

    RML's Avatar

    This comment was split into a new private discussion: Problems getting USAA to download transactions

    I'd like to add my 2 cents, since USAA doesn't seem to want to ... I've been using MD+/Plaid with USAA accounts for over 1 year and as of today, I'm am not getting any transactions after Aug 31. No changes made on my side at all, just nothing from plaid/usaa.

    I'd appreciate any info you've got, TIA

  15. 15 Posted by DL on 14 Sep, 2023 06:05 PM

    DL's Avatar

    I'm having this issue as well. I've used MD for years but just started my trial of MD+. The first couple of downloads went fine but I've gotten no new transactions from USAA since 9/8, although there are at least 4 which have been cleared for days in my account. Also having the (probably unrelated) re-link problem with Amex documented elsewhere; if this continues, I don't think I'm going to pay for MD+. Any ideas are appreciated.

  16. 16 Posted by bzs on 17 Sep, 2023 03:07 PM

    bzs's Avatar

    As a follow-up, today MD+ told me I had to relink the USAA account, which I thought might be a positive step (maybe they fixed something?). However, after going through the re-link process and refreshing (so the USAA accounts show as connected), the same problem persists - it downloads the transactions but thinks they are already matched. I again reset the synch date to June 1, 2023, and re-downloaded, with the same results.

  17. 17 Posted by Chris Boyd on 17 Sep, 2023 03:38 PM

    Chris Boyd's Avatar

    No sure what happened...but today all my USAA  transactions back to Aug 1 downloaded again for all three accounts I have.  I have a lot of transactions to sort through and try to figure out, but I'd rather get duplicates that I can use the merge function on, than non at all.

    On 9/17/2023 8:07:25 AM, bzs <[email blocked]> wrote:

  18. 18 Posted by dtd on 17 Sep, 2023 08:36 PM

    dtd's Avatar

    Sounds like USAA is trying to fix some things, but still don't have it right yet. Sigh.

    @bzs - do you have automatically merge on? If so, I'd turn it off for this situation.

  19. 19 Posted by bzs on 18 Sep, 2023 03:11 AM

    bzs's Avatar

    @DTD - no, I don't have auto merge on, but I have good (and surprising)
    news - today MD+ downloaded the transactions and KNEW THEY WERE NEW! I
    can't predict if this means USAA or Plaid fixed the problem, or if it was a
    one-time-only correct download (and it's not even my birthday!) - however,
    after a few more days, when some more transactions come in, I will update
    this thread.

    Hope it works for some of the rest of you as well...

    On Sun, Sep 17, 2023 at 4:36 PM dtd <[email blocked]> wrote:

  20. 20 Posted by dtd on 18 Sep, 2023 04:55 AM

    dtd's Avatar

    Sounds like USAA is trying to fix things, and assigned a new FITID number to items (the field that says new or not new). This is sounding hopeful, but we will see.

  21. 21 Posted by bzs on 19 Sep, 2023 12:38 PM

    bzs's Avatar

    Well, I'm not comfortable declaring complete victory here (because we've
    been disappointed before...) but I did just successfully download a
    transaction from only a few days ago, so I am feeling cautiously
    optimistic. Is anyone else who reported problems in this thread having
    success? Note that I also had to re-link my USAA accounts, which may have
    been part of it, so that's something else you all might want to try...

    On Mon, Sep 18, 2023 at 12:55 AM dtd <[email blocked]>

  22. 22 Posted by Chris Boyd on 19 Sep, 2023 02:55 PM

    Chris Boyd's Avatar

    I too, am cautiously optimistic.  I just downloaded the one transaction that cleared overnight.  No issues.

    Thanks for all who helped!


    On 9/19/2023 5:39:00 AM, bzs <[email blocked]> wrote:

  23. 23 Posted by rnrlee on 19 Sep, 2023 05:35 PM

    rnrlee's Avatar

    Like some of you, I relinked my USAA accounts, and in just the last few
    days I’ve started getting recent transactions. So, it works, but is it
    fixed.? It would be nice to know what got fixed. Support folks, any

    thanks to all

    On Tue, Sep 19, 2023 at 8:55 AM Chris Boyd <[email blocked]>

  24. 24 Posted by DL on 20 Sep, 2023 03:33 AM

    DL's Avatar

    I didn't get a request to re-link but I tried it anyway based on @bzs and @Chris's good fortune. Alas, no change for me.

  25. 25 Posted by dtd on 20 Sep, 2023 05:56 PM

    dtd's Avatar

    @rnrlee - Nothing changed in Moneydance, of course, you'd probably need to talk to USAA support, and it will be hard to get to the tech level for any real info.

  26. Support Staff 26 Posted by Maddy on 21 Sep, 2023 09:44 AM

    Maddy's Avatar


    The latest update about the USAA connection we've received from Plaid states the following:

    'While we are unable to provide additional detail, here are a few things the users can look into that may resolve the issue':

    • If your user is on a VPN, have them disconnect from the VPN before trying to link

    • Similarly, if your user is using traffic-anonymizing software, have them turn off this software before trying to link

    • Try connecting via a different device (phone, computer) or different network (try mobile internet on phone vs WiFi)'

    I hope this information is helpful. Please let us know if you have further questions or need more assistance.

    Maddy, Infinite Kind Support

  27. 27 Posted by Lauri on 21 Sep, 2023 07:27 PM

    Lauri's Avatar

    Today my downloads started working and went back to the beginning of September! without me doing anything. I am hopefully optimistic that this will continue.

  28. 28 Posted by DL on 23 Sep, 2023 12:32 AM

    DL's Avatar

    @Lauri--mine too! Fingers crossed!

  29. System closed this discussion on 23 Dec, 2023 12:40 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac