Fidelity OFX connection issue with VPN on

Dave's Avatar


08 Nov, 2023 11:58 PM

Can a user still connect to Fidelity using Plaid? I have been connecting for quite some time now and this month (Nov '23) it has stopped. In looking at this reddit article it appears that Fidelity and Plaid no longer play well together:

I tried online at Fidelity and their bots could not answer if Plaid is still supported. I then tried similar chat bots at Plaid and got no where. I am too stupid to find a way to email either of these companies. I then called Fidelity and they were useless and would not confirm or deny that they support Plaid. Can you please provide insight on this connectivity issue?

Showing page 2 out of 2. View the first page

  1. 31 Posted by dtd on 06 Dec, 2023 10:51 PM

    dtd's Avatar

    I think you are right you have something "stuck" in the process. Broker ID, historically for me and others I've helped, isn't the right thing to come up here. It should be more like you describe.

    You are using Fidelity Investments, which is the correct way to go, as I know that Investments works, but not necessarily Fidelity Bank.

    I'd test it myself, but honestly, I'm just not going to take the chance that I break my working system for Fidelity.

  2. 32 Posted by dtd on 06 Dec, 2023 10:55 PM

    dtd's Avatar

    @sth - I reread your comment - AMEX Savings has NEVER worked with OFX...

  3. 33 Posted by sth on 07 Dec, 2023 03:50 AM

    sth's Avatar

    @dtd, I don't want to get off topic and stay with the original poster's issue. Will start a new thread, but AMEX savings did work with Plaid and now needs relinking every other day.

    @dave, I agree with @dtd, I still use OFX download with fidelity. But it does not cover their checking/savings accounts. So you can't use OFX with fidelity bank. It never worked for me so I closed my fidelity checking.

    So for brokerage accounts keep using OFX. For checking / Savings I think you are out of luck. For fidelity DAF, it is a little weird and sales are not reported.

  4. 34 Posted by dtd on 07 Dec, 2023 05:21 AM

    dtd's Avatar

    Sorry, you are correct Amex Savings works with MD+, and you are also correct, it requires redoing every 2-3 days.

    So, if you wish, start a new thread.

  5. 35 Posted by dwg on 07 Dec, 2023 03:10 PM

    dwg's Avatar

    The recommendation for any institution is if they offer Direct Connect go with that.

    Moneydance+ was introduced specifically for those institution that do not offer Direct connect in the U.S. and to also in due course support institutions outside of the U.S. who have never supported Direct Connect and are unlikely to ever do so. Outside of the U.S. we are seeing more adoption of Open Banking which provides a legislated method to gain access to the data i.e. the institutions have to provide access.

  6. 36 Posted by dtd on 07 Dec, 2023 11:17 PM

    dtd's Avatar

    @dave- appears you got rid of the MD+ link for fidelity, but the ofx item isn't working properly.

    Have you tried Toolbox/Online Banking Tools/Delete OFX Banking Service? You may still have your old Fidelity OFX in place, and it may need to be removed/recreated?

    (this only blows away one thing, not anything else you have set up)

  7. 37 Posted by Dave on 09 Dec, 2023 02:07 PM

    Dave's Avatar

    This comment was split into a new private discussion: Fidelity - OFX

    I did a few things today:
    1) I updated to the latest version of MD - 2023.3 (5064) at Sat Dec 09 08:44:22 EST 2023
    2) Ran Cleanup missing Online Banking Links - None found
    3) Delete OFX Banking Service / Login Profile - I had 6 of them with 2 of them being Fidelity. All have been deleted.
    4) Restarted MD.

    This did not solve the issue. I then tried to reestablish the OFX connection to Fidelity and received the same screens as I have above with the Broker ID coming up and then nothing. I then looked at the console and saw the error below. If you can send me a link to a secure site to upload the console log I can do that. I also tried in a browser and I can hit the page. Per the output below, could this be an issue with your proxy?

    Console output for Fidelity Connection:
    Created new custom trust manager



    connecting to: with method: POST
    Error refreshing profile information: Unable to tunnel through Proxy returns "HTTP/1.1 400 Bad Request"
    at java.base/ Source)
    selected account: Fidelity Account
    storing investment values
    stored investment values
    account: Fidelity Account; serviceType: 6; service: Fidelity Investments; mode=banking
    account modified: Fidelity Account
    calculated portfolio cost basis in 0.007 seconds

  8. 38 Posted by Dave on 12 Dec, 2023 08:39 PM

    Dave's Avatar

    I have been able to resolve this issue. I have a Norton Secure VPN running on my machine. I first attempted turning on an off Norton Virus protection and the Firewall. This did not allow me to connect. I then noted that I had the VPN on. I turned off the VPN and the broker id and or the failure to connect issue went away.

    In the VPN OFF position I then tried to reestablish the connection. I was able to get the Fidelity credentials prompt and was able to download transactions. If I turn the VPN connection ON, this process fails. I did try to use the split connection feature but this did not work. The solution to resolve this issue currently is to turn OFF the VPN when using MD. I will attempt to work with Norton to see if I can all MD traffic to bypass the VPN.

    Thank you for your help with this.

  9. Support Staff 39 Posted by Maddy on 13 Dec, 2023 11:11 AM

    Maddy's Avatar

    We are very pleased to hear that you were able to detect and resolve the problem, Dave!

    I'll close this discussion for now, but please don't hesitate to contact us again, if you need further assistance.

     We wish you a lovely festive season!

    Maddy, Infinite Kind Support

  10. Maddy closed this discussion on 13 Dec, 2023 11:11 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac