Abrupt Appl. Shutdown when Adding an Attachment

Henry Sully's Avatar

Henry Sully

28 Jan, 2024 11:28 PM

Using version 2023.1 (5006) on Win 10 machine. Long time user since 2015 and never had any significant issues. I add attachments often. I tried rebooting, but no improvement (the problem persists). The program just goes away without any warning as soon as I click the attachment that I am trying to add. I tried adding different attachments with no avail (even ones that I had added in the past). After restarting MD, there is no attachment present. I have a large hard drive 2T with at least 1/2 unused space.
I hesitate to upgrade at this point, because everything has be very stable up until today, but will try it if advised.

  1. 1 Posted by Stuart Beesley ... on 29 Jan, 2024 08:12 AM

    Stuart Beesley (Mr Toolbox)'s Avatar

    Windows? Mac?

    Please install toolbox extension and try again.

    Then when it crashes, find the file errlog.txt on disk and upload that here.

  2. 2 Posted by Henry Sully on 29 Jan, 2024 01:45 PM

    Henry Sully's Avatar

    Ok, it is attached. Thanks.

  3. 3 Posted by Henry Sully on 29 Jan, 2024 05:10 PM

    Henry Sully's Avatar

    Update to issue:
    1) I noticed that when I ran toolbox, it indicated/listed a few possible duplicate securities. So, I investigated this and fixed the duplication issues that were being listed.
    2) After doing this, I restarted MD and then tried again to attach a document to a transaction. This time it worked with no issue. I tried a second attachment and it also worked without any issue.
    So, it appears that my problem has been fixed for now.
    Thanks. I really have no idea how I should be using toolbox (there are a lot of menus) but it did seem to make visible these issues above.
    -Henry

  4. 4 Posted by Stuart Beesley ... on 29 Jan, 2024 06:56 PM

    Stuart Beesley (Mr Toolbox)'s Avatar

    Well toolbox is both mysterious and magic, but the thing you ran would not have fixed the issue you mentioned..

    However, please remove the following extensions:
    extinstaller
    rhumba
    txtimport (only if you are not using this one....

    Also, I see this:

    JVM - Maximum memory possible:   1.1 GB
    JVM - Total memory allocated:    0.6 GB (used 0.4 GB / free 0.2 GB)
    

    You need to either edit your vmoptions file (toolbox, general tools, vmoptions tells you how to do this)... Or upgrade to 2023.3(5064) and it will take care if this for you... I expect you have been getting out of memory issues and then it crashes....

  5. 5 Posted by dwg on 29 Jan, 2024 10:13 PM

    dwg's Avatar

    Rhumba was part of much older versions of the Quote Loader extension. If you have not already done so you would need to upgrade Quite Loader, Rhumba should definitely be removed.

  6. 6 Posted by HH Sully-Gmail on 30 Jan, 2024 03:22 PM

    HH Sully-Gmail's Avatar

    To: Stuart Beesley,

    Thank you for your help! I was able to edit vmoptions to 2048m.

    I seem to be having a warning I don't know what to do with though.....

    When I invoke Toolbox, I get the following warning:

    INVALID WINDOW LOCATIONS WARNING:

    Toolbox has detected that you have at least one saved
    Moneydance window location that is invalid / 'off-screen'.
    >> To zap these invalid settings, use UPDATE Mode...
    ........

    Unfortunately, I am clueless as to what this means or how to correctly use
    "UPDATE Mode"  Is that something you can help me with resolving?

    Thanks,

    Henry Sully

  7. 7 Posted by Stuart Beesley ... on 30 Jan, 2024 03:34 PM

    Stuart Beesley (Mr Toolbox)'s Avatar

    In toolbox there is a tick box near the top bar that says uodate mode. Tick this. Then a new button will appear. Fix invalid window locations. Click that.

  8. 8 Posted by Henry Sully on 30 Jan, 2024 04:06 PM

    Henry Sully's Avatar

    Thanks for all the help. The warning is gone now.

  9. Maddy closed this discussion on 06 Feb, 2024 01:51 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

29 May, 2024 07:01 AM
29 May, 2024 06:26 AM
29 May, 2024 02:38 AM
29 May, 2024 12:43 AM
28 May, 2024 11:59 PM