File copied from MacOS does not seem to work in Linux Debian 12

tariq.khan's Avatar


12 Feb, 2024 07:47 PM

With the help from @sprimost I was able to install MD into Linux Debian 12.
Now I appear to have a different problem. I have been using MD in MacOS so I thought that I would just copy my main file to a USB and open it in Linux. It usually works in Windows so I thought it should also work in Linux since MacOS and Linux are both UNIX based. I was wrong.
The MD icon such as accounts.moneydance on the Mac appears in Linux as a folder with the same name and extension, just like it does in Windows. Usually in Windows you can simply open Moneydance and find the folder and click on the icon inside the folder but that does not seem to happen with Linux.
Anyway, to cut through the chase, would appreciate if anyone can help with this problem. I am moving from Mac to Linux but am trying it out before I make the final move. The Linux distribution I am using is Debian 12.
Many thanks
Kind regards

  1. 1 Posted by Stuart Beesley ... on 12 Feb, 2024 08:14 PM

    Stuart Beesley (Mr Toolbox)'s Avatar

    It should copy fine. However, rather than your method. Try this.

    File/export backup. Copy the xxx.moneydancearchive file to Linux. Then file/restore backup.

  2. 2 Posted by sth on 13 Feb, 2024 03:58 AM

    sth's Avatar

    It may be the format of your USB drive does not allow preservation of extended attributes. I think this confuses linux when they are stripped off. Not sure how linux handles the Mac "bundle" concept.

  3. 3 Posted by tariq.khan on 13 Feb, 2024 01:49 PM

    tariq.khan's Avatar

    Stuart Beesley - Thanks Stuart that was very helpful. File/Export Backup did the job. But instead of file/restore, I opened the file from the main menu “Import new account set” as I had not created any accounts set on Linux as yet. I think that is probably what you meant anyway.
    Appreciate your help.
    Thank you

  4. 4 Posted by tariq.khan on 13 Feb, 2024 02:06 PM

    tariq.khan's Avatar

    sth - Replying to your post on my other post.
    I’ve been a mac user since the 1980s when they first came out. The company I worked for went all Mac back then. I started owning Macs since that time. I had a Classic, which I still have, an LC which I junked after a few years and replaced it with iMac, which is still in my attic. I replaced that with a MB Pro 17” when they came out in 2000s. That got dated and then I got this MBA in 2013. Lovely machine, just changed the battery about six months ago which cost me £25.
    What I resent is that they have stopped supporting High Sierra which happened a while back but wasn’t a problem as other software suppliers were still supporting it. But now that is changing. Even Brave browser is not supporting it. There is nothing wrong with the machine I’ve got. It does everything I need. I run my business on it. So if Apple will not support me, I will not support Apple.
    May son just bought a new MBA. It’s nice has a great screen and is a bit faster. All the other changes just appear cosmetic.
    Linux Debian is on a 5 year old PCSpecialists Optimus which belonged to my son who was on windows (used to be a gamer). It was bloated and very slow. Now with Linux on it, it’s very fast and only occupies 14GB of space with all the apps that I need now installed. That was bit of a surprise to me.
    It is a bit of a learning curve with command line interaction but there is an awful lot of help out there with very enthusiastic experienced users, the way it used to be with Mac.
    BTW, I’ve also ditched my iPhone for a degoogled phone for the same reason plus privacy concerns. I’ve had no regrets doing that. The GrapheneOS is superb.

  5. 5 Posted by Stuart Beesley ... on 13 Feb, 2024 02:11 PM

    Stuart Beesley (Mr Toolbox)'s Avatar

    👍 Nope. I meant what I said. But no matter. What you did auto detects the backup and performs a restore anyway.

    Glad it’s working.

  6. 6 Posted by tariq.khan on 13 Feb, 2024 04:26 PM

    tariq.khan's Avatar

    Another question Stuart please.
    I usually store my MD account sets in an encrypted container which I create using Veracrypt.

    In Linux, the folder where the MD program seems to launch myaccounts.moneydance from is in home/.moneydance/documents. Moving the folder to the Veracrypt container is no good because MD does not recognise it. I tried File/Restore backup as before saving it into the Container but when I open it, it opens it back in home/.moneydance/documents which is no help.

    I managed to send the backups or archives into VeraCrypt by using the Preferences/Backups which took me a while to figure out. But I can’t figure out how to put my account sets into the container.
    Any ideas.

  7. 7 Posted by Stuart Beesley ... on 13 Feb, 2024 05:34 PM

    Stuart Beesley (Mr Toolbox)'s Avatar

    Try toolbox extension. General tools. Relocate dataset.

  8. 8 Posted by tariq.khan on 13 Feb, 2024 07:34 PM

    tariq.khan's Avatar

    Thank you Stuart. Took several attempts. The first attempt was my mistake as I had not opened the Veracrypt container after a system update.
    The second attempt failed and locked MD so it won’t open. Had to restart.
    The restart unlocked the launch so tried again and it did move something but it was not a dataset. The data was missing from the account set.
    Used the previous Imported original dataset that I had imported from Mac and changed the filename slightly when it asked it to be saved. Tried again and it worked.
    Thank you for your help. Really they could make this easier.
    Never used Toolbox before and I’ve been an MD user since 2007 or maybe before.
    Many thanks again.

  9. 9 Posted by Stuart Beesley ... on 13 Feb, 2024 09:34 PM

    Stuart Beesley (Mr Toolbox)'s Avatar

    Toolbox 🧰 +1 😃

  10. tariq.khan closed this discussion on 14 Feb, 2024 12:03 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac