Keyboard not recognized

ironrod3's Avatar

ironrod3

26 Mar, 2024 12:16 AM

This is the second time in the last couple days when the keyboard is no longer recognized by MoneyDance. I am working along making lots of entries. I click on [New Transaction] and no keys are recognized. I have tried pasting in text -- nothing. I have tried the onscreen keyboard -- nothing. In both cases, the only option was to close MoneyDance and re-open it.

  1. 1 Posted by derekkent23 on 26 Mar, 2024 08:45 AM

    derekkent23's Avatar

    I am not support staff, just a user.
    Hi ironrod3

    It could help others to help you if you provided basic information
    What version/build of Moneydance are you running, e.g. 2023.3(5064).
    What is your computer operating system.
    Is the keyboard inbuilt, separate etc.

  2. 2 Posted by ironrod3 on 27 Mar, 2024 03:21 PM

    ironrod3's Avatar

    MoneyDance 2023.3 (5064)

    LinuxMint 21.3, kernel 6.5.0-25

    The keyboard is wireless Microsoft

    NOTE: When this happens, it is only MoneyDance that exhibits the issue. All other applications continue to accept keyboard input.

  3. 3 Posted by ironrod3 on 22 Apr, 2024 10:51 PM

    ironrod3's Avatar

    This is still happening with the update to 2024.1 (5118). If anything, it is happening more often -- three times today, alone.

    Is no one in support going to respond to this post?

  4. 4 Posted by sth on 23 Apr, 2024 02:38 AM

    sth's Avatar

    Possibly not. It may or may not be an MD issue. It may just be that MD is more sensitive to bluetooth issues. It seems that linux Mint has some bluetooth keyboard issues. It may be that Java applications don't like continual disconnect/reconnect issues.

    https://forums.linuxmint.com/viewtopic.php?t=382715
    https://www.reddit.com/r/linuxmint/comments/175jpup/linux_mint_21_b...
    https://gtechbooster.com/linux-mint-21-bluetooth-not-working-here-i...

    You could provide your errlog.txt file to rule out a problem in the Java code. But I would suggest searching your syslog files for bluetooth issues as a more productive first step.

    (NOT IK support)

  5. 5 Posted by ironrod3 on 23 Apr, 2024 04:19 AM

    ironrod3's Avatar

    There's no question that only MD experiences this. I never experience it in any other app -- even using LibreOffice which also uses Java, right?

    I'm pretty sure this is not a Bluetooth keyboard but uses other RF. Yet you bring up a good point. I'll try connecting a wired keyboard for a while and see if I can confirm it happening there at all.

    Thanks for the links, I'll examine them for clues as well.

    --
    Rod Barnes

  6. 6 Posted by dwg on 23 Apr, 2024 04:35 AM

    dwg's Avatar

    LibreOffice is not written in Java, it only requires Java if you are using features like Base which by default makes use of a Java database.

    There are no other reports of keyboard problems at the moment.

  7. 7 Posted by ajbarr on 15 May, 2024 10:13 PM

    ajbarr's Avatar

    I opened a private support ticket and they asked me to send in my /home/userid/.moneydance/errlog.txt file. I don't see any errors in that file so I doubt it will be useful. I have also had multiple exchanges with support and so far no resolution.
    I don't understand why this isn't reproducible by the infinitekind developers. Have they even tried?

  8. 8 Posted by dwg on 15 May, 2024 10:55 PM

    dwg's Avatar

    None one else has reported such a problem but yet you seem to think that is should be trivial to reproduce.

    To start with people may have to have an identical environment software and hardware wise to even have a chance of being able to, and yet the problem still may not occur, it may be isolated to something on your system

    I would suggest you try a wired keyboard/mouse combo and see if the problem is still present.

  9. 9 Posted by ajbarr on 16 May, 2024 12:16 AM

    ajbarr's Avatar

    @dwg, I am using a wired keyboard. If you search the discussions you will find multiple people who are having this issue so it isn't isolated to my system... 5 discussion reports and in each report there are multiple people with different versions of Linux.

    https://infinitekind.tenderapp.com/discussions/problems/93685-keyboard-stops-working
    https://infinitekind.tenderapp.com/discussions/problems/89640-moneydance-stops-responding-to-a-keyboard
    https://infinitekind.tenderapp.com/discussions/problems/89287-moneydance-stops-reponding-to-keyboard-input
    https://infinitekind.tenderapp.com/discussions/problems/89868-problems-with-md-20231-and-linux

    I'm annoyed because the issue has existed since paying to upgrade to 2023 and it hasn't been fixed.

  10. 10 Posted by sth on 16 May, 2024 01:21 AM

    sth's Avatar

    Not an expert but a little googling shows that keyboards have problem in linux with Java Apps. There are some pointers that SCIM (Smart Common Input Method) may be the issue. Every reported MD issue seems to be on a linux box and given the diversity of linux versions and hardware it is NOT trivial to reproduce. Many linux setups seem to run fine. A few have problems. I would try to start collecting data on the forum as to where the problem occurs. This thread includes wireless and wired keyboards so that may not be the problem. But changing your keyboard hardware might be a good first test.

    (NOT IK Support)

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac